<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9jzm6dt" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9jzm6dt";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Bliznyuk sets single season scoring record in loss to Utah Valle - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</title>
<meta name="Description" content="Big Sky Conference MVP Bogdan Bliznyuk set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley."><meta name="KEYWORDS" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="news_keywords" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2018/03/14"><meta name="owner" content="SWXRN"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="7.6.0.4"><meta name="wn-base" content="IIS22"><meta name="wnreadableurl" content="bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><meta property="og:title" content="Bliznyuk sets single season scoring record in loss to Utah Valley in CBI"><meta property="og:type" content="article"><meta property="og:url" content="http://www.swxrightnow.com/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><meta property="og:image" content="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?lastEditedDate=20180314002658"><meta property="og:description" content="Big Sky Conference MVP Bogdan Bliznyuk set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley."><link rel="canonical" href="http://www.swxrightnow.com/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Bliznyuk sets single season scoring record in loss to Utah Valley in CBI"><meta name="twitter:description" content="Big Sky Conference MVP Bogdan Bliznyuk set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley."><meta name="twitter:image" content="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?lastEditedDate=20180314002658"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:page_id" content="130847515832" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.6.0.4_7.4.8-8">
<link type="text/css" rel="stylesheet" media="all" href="http://SWXRN.images.worldnow.com/interface/css/container-e.css?ver=2018-02-22%2015%3A29%3A32_7.4.8-8">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.4.8-8_7.6.0.4" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.6.0.4"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.6.0.4"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.6.0.4"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1641 UL
                    , #menu1641 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641 A,
                    #menu1641 LI.wnOn .wnSublevel A,
                    #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641
                        .wnLevel1, #menu1641
                        .wnLevel1 LI { height: 38px; }
                            #menu1641 .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu1641 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu1641 LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1641 .wnSublevel { background-color: #d5d5d5;  }
                #menu1641 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu1641 > .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel { width: 978px; }
                    #menu1641 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu1641 .wnLeft { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu1641 LI.wnOn .wnLeft { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1641 .wnRight { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu1641 LI.wnOn .wnRight { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1641 .wnRight .wnMiddle { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1641 LI.wnOn .wnMiddle { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu1641 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu1641 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'SWXRN',
            affiliateId : '863',
            baseUrl : 'www.swxrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.4.8-8',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '64',mdPartnerDomain : 'http://dub.swxrightnow.com'},
            registrationId : '557063',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://SWXRN.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.6.0.4';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.disableSecurityWarning=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='SWXRN';
wng_pageInfo.ownerAffiliateId=parseInt('863',10);
wng_pageInfo.containerId=parseInt('37719430',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='Sport - NCAA-Basketball';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Bliznyuk sets single season scoring record in loss to Utah Valley in CBI';
wng_pageInfo.pageTitle='Bliznyuk sets single season scoring record in loss to Utah Valle - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTag='SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffSWXRN';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NCAA-Basketball",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NCAA-Basketball",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NCAA-Basketball",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NCAA-Basketball",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NCAA-Basketball",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:300,height:150,wncc:"Sport - NCAA-Basketball",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NCAA-Basketball",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["63"]={id:"63",wnsz:"63",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'inline',aff:'SWXRN'},width:300,height:600,wncc:"Sport - NCAA-Basketball",parent:"WNAd63",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.adsettings={disableInitialLoad:true};</script>
<script type="text/javascript" src="http://SWXRN.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2018-02-22%2015%3A29%3A32_7.4.8-8"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/SWXRN.config.js?ver=7.6.0.4_7.4.8-8"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.6.0.4_7.4.8-8"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/swxrn/custom/swxrn_story_zoom.css" /><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel='alternate' type='application/rss+xml' title='Top Sports Headlines' href='http://www.swxrightnow.com/category/162885/publishing-category-top-stories?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='College Headlines' href='http://www.swxrightnow.com/category/162314/college?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Pro Headlines' href='http://www.swxrightnow.com/category/162313/pro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Prep Headlines' href='http://www.swxrightnow.com/category/160221/high-school-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington Sports' href='http://www.swxrightnow.com/category/50896/washington-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Idaho Sports' href='http://www.swxrightnow.com/category/50867/idaho-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington State' href='http://www.swxrightnow.com/category/162664/washington-state?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Univ. of Idaho' href='http://www.swxrightnow.com/category/162831/idaho?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Eastern Washington' href='http://www.swxrightnow.com/category/162663/ewu-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Gonzaga' href='http://www.swxrightnow.com/category/160218/gonzaga?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Central Washington' href='http://www.swxrightnow.com/category/192801/central-washington?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Whitworth' href='http://www.swxrightnow.com/category/174693/whitworth-university?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Shock' href='http://www.swxrightnow.com/category/160220/spokane-shock?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Chiefs' href='http://www.swxrightnow.com/category/162666/spokane-chiefs?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Americans' href='http://www.swxrightnow.com/category/115764/tri-city-americans?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Dust Devils' href='http://www.swxrightnow.com/category/145287/tri-city-dust-devils?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Yakima Bears' href='http://www.swxrightnow.com/category/108040/yakima-bears?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Seattle Mariners' href='http://www.swxrightnow.com/category/162830/seattle-mariners?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Hydro Insider' href='http://www.swxrightnow.com/category/78290/hydroinsidercom-unlimited-hydroplane-racing?clienttype=rss'><link rel='stylesheet' type='text/css' href='http://ftpcontent.worldnow.com/swxrn/custom/custom.css' /><script src="http://ftpcontent.worldnow.com/swxrn/custom/custom.js"></script><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><script src="//acdn.adnxs.com/prebid/c/7045/pb.js"></script></head><body id="WNAffSWXRN" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>var globalSharedAnalyticsData = { dma: '73', group: 'Cowles' }; (function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-55' ,"dma":globalSharedAnalyticsData.dma ,"group":globalSharedAnalyticsData.group})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Bliznyuk sets single season scoring record in loss to Utah Valle - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo_dark.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1641" class="wnMainMenu"><div class="wnHorizontal"><div class="wnStatic"><div class="wnMenuTypeImage"><ul class="wnLevel1" id="submenu1641"><li class="wnFirstNode" id="menu1641_1-C155145"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/"><img src="http://SWXRN.images.worldnow.com/images/499120_G.gif" width="49" height="38" border="0" alt="SWX Right Now.com" title="SWX Right Now.com" onsrc="http://SWXRN.images.worldnow.com/images/499121_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_1-C155145"><li class="wnFirstNode" id="menu1641_1_1-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_1_3-C163470"><span><a href="/category/163470/games-contests">Games &amp; Contests</a></span></li><li class="" id="menu1641_1_2-C220728"><span><a href="/category/220728/featured-slideshows">Featured Slideshows</a></span></li></ul></li><li class="" id="menu1641_2-C160216"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160216/scores"><img src="http://SWXRN.images.worldnow.com/images/499122_G.gif" width="97" height="38" border="0" alt="Scores" title="Scores" onsrc="http://SWXRN.images.worldnow.com/images/499123_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_2-C160216"><li class="wnFirstNode" id="menu1641_2_1-C161806"><span><a href="/category/161806/national-scores">National Scores</a></span></li><li class="" id="menu1641_2_2-C161807"><span><a href="/category/161807/college-scores">College Scores</a></span></li><li class="" id="menu1641_2_3-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_2_4-S9920984"><span><a href="/story/9920984/report-a-score">Report a Score</a></span></li></ul></li><li class="" id="menu1641_3-C162314"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162314/college"><img src="http://SWXRN.images.worldnow.com/images/499124_G.gif" width="65" height="38" border="0" alt="College" title="College" onsrc="http://SWXRN.images.worldnow.com/images/499125_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_3-C162314"><li class="wnFirstNode" id="menu1641_3_1-C162664"><span><a href="/category/162664/washington-state">WSU</a></span></li><li class="" id="menu1641_3_2-C160218"><span><a href="/category/160218/gonzaga">Gonzaga</a></span></li><li class="" id="menu1641_3_3-C162663"><span><a href="/category/162663/ewu-sports">EWU</a></span></li><li class="" id="menu1641_3_4-C174693"><span><a href="/category/174693/whitworth-university">Whitworth</a></span></li><li class="" id="menu1641_3_5-C162831"><span><a href="/category/162831/idaho">Idaho</a></span></li><li class="" id="menu1641_3_6-C267736"><span><a href="/category/267736/university-of-washington">Washington</a></span></li><li class="" id="menu1641_3_7-C192801"><span><a href="/category/192801/central-washington">CWU</a></span></li><li class="" id="menu1641_3_8-C262164"><span><a href="/category/262164/bobcats">Bobcats</a></span></li><li class="" id="menu1641_3_9-C262165"><span><a href="/category/262165/grizzlies">Grizzlies</a></span></li></ul></li><li class="" id="menu1641_4-C162313"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162313/pro"><img src="http://SWXRN.images.worldnow.com/images/499126_G.gif" width="36" height="38" border="0" alt="Pro" title="Pro" onsrc="http://SWXRN.images.worldnow.com/images/499127_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_4-C162313"><li class="wnFirstNode" id="menu1641_4_3-C272346"><span><a href="/category/272346/seattle-seahawks">Seattle Seahawks</a></span></li><li class="" id="menu1641_4_4-C162666"><span><a href="/category/162666/spokane-chiefs">Spokane Chiefs</a></span></li><li class="" id="menu1641_4_5-C160220"><span><a href="/category/160220/spokane-empire">Spokane Empire</a></span></li><li class="" id="menu1641_4_2-C193768"><span><a href="/category/193768/the-offseason">The Offseason</a></span></li><li class="" id="menu1641_4_1-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_5-C160221"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160221/high-school-sports"><img src="http://SWXRN.images.worldnow.com/images/499128_G.gif" width="96" height="38" border="0" alt="High School" title="High School" onsrc="http://SWXRN.images.worldnow.com/images/499129_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_5-C160221"><li class="wnFirstNode" id="menu1641_5_1-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_5_2-C318106"><span><a href="/category/318106/student-athlete">Student Athlete </a></span></li><li class="" id="menu1641_5_4-C162688"><span><a href="/category/162688/greater-spokane-league">Greater Spokane League</a></span></li><li class="" id="menu1641_5_5-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_5_3-C286972"><span><a href="/category/286972/prep-countdown">Prep Countdown</a></span></li></ul></li><li class="" id="menu1641_6-L654994"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://www.nwprepsnow.com"><img src="http://SWXRN.images.worldnow.com/images/4054557_G.png" width="140" height="38" border="0" alt="High School to NWPrepsNow.com" title="High School to NWPrepsNow.com" onsrc="http://SWXRN.images.worldnow.com/images/4054564_G.png"></a></span></span></span></span></li><li class="" id="menu1641_7-C160222"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160222/video-center"><img src="http://SWXRN.images.worldnow.com/images/499132_G.gif" width="102" height="38" border="0" alt="Video Center" title="Video Center" onsrc="http://SWXRN.images.worldnow.com/images/499133_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_7-C160222"><li class="wnFirstNode" id="menu1641_7_1-L375234"><span><a href="http://www.swxrightnow.com/global/category.asp?c=">All Video</a></span></li><li class="" id="menu1641_7_2-C162982"><span><a href="/category/162982/vc-college">College </a></span></li><li class="" id="menu1641_7_3-C162981"><span><a href="/category/162981/vc-pro">Pro </a></span></li><li class="" id="menu1641_7_4-C162980"><span><a href="/category/162980/vc-high-school">High School </a></span></li><li class="" id="menu1641_7_5-C162983"><span><a href="/category/162983/vc-gonzaga">Gonzaga </a></span></li><li class="" id="menu1641_7_6-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_7_7-C162984"><span><a href="/category/162984/vc-wsu">WSU</a></span></li><li class="" id="menu1641_7_8-C162986"><span><a href="/category/162986/vc-ewu">EWU</a></span></li><li class="" id="menu1641_7_9-C162987"><span><a href="/category/162987/vc-spokane-empire">VC - Spokane Empire</a></span></li></ul></li><li class="" id="menu1641_8-C155146"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather"><img src="http://SWXRN.images.worldnow.com/images/499134_G.gif" width="73" height="38" border="0" alt="Weather" title="Weather" onsrc="http://SWXRN.images.worldnow.com/images/499135_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_8-C155146"><li class="wnFirstNode" id="menu1641_8_1-C120835"><span><a href="/category/120835/road-pass-conditions">Road &amp; Pass Conditions</a></span></li><li class="" id="menu1641_8_2-S9962976"><span><a href="/story/9962976/radar-maps">Radar</a></span></li><li class="" id="menu1641_8_3-S9963255"><span><a href="/story/9963255/satellite-maps">Satellite</a></span></li><li class="" id="menu1641_8_4-S9974691"><span><a href="/story/9974691/school-closures-delays">School Closures &amp; Delays</a></span></li><li class="" id="menu1641_8_5-L524823"><span><a href="/link/524823/inland-northwest-ski-conditions">Ski Conditions</a></span></li></ul></li><li class="" id="menu1641_9-C160225"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160225/about-us"><img src="http://SWXRN.images.worldnow.com/images/499136_G.gif" width="76" height="38" border="0" alt="About Us" title="About Us" onsrc="http://SWXRN.images.worldnow.com/images/499137_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_9-C160225"><li class="wnFirstNode" id="menu1641_9_1-S9913533"><span><a href="/story/9913533/swx-contact-information">SWX Contact Information</a></span></li><li class="" id="menu1641_9_2-S9914380"><span><a href="/story/9914380/swx-on-tv">SWX on TV</a></span></li><li class="" id="menu1641_9_4-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_9_5-S9914228"><span><a href="/story/9914228/advertise-with-swx">Advertise with SWX</a></span></li><li class="" id="menu1641_9_3-S12164224"><span><a href="/story/12164224/closed-captioning-inquiries">Closed Captioning Inquiries</a></span></li><li class="" id="menu1641_9_6-S9914091"><span><a href="/story/9914091/jobs-at-swx">Jobs at SWX</a></span></li><li class="" id="menu1641_9_7-L376213"><span><a href="http://www.khq.com/">KHQ Right Now</a></span></li><li class="" id="menu1641_9_8-L376216"><span><a href="http://www.nbcrightnow.com/">NBC Right Now</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1641"></div></div></div></div><div id="spacermenu1641" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1641', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : true, level1Height : '38', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Bliznyuk sets single season scoring record in loss to Utah Valley in CBI</h3>
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnLeft" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img alt="Photo: EWU Athletics" title="Photo: EWU Athletics" border="0" src="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?auto=webp&amp;disable=upscale&amp;width=800&amp;lastEditedDate=20180314002658" width="180">
<span>Photo: EWU Athletics</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated left"><p><em>By Eastern Washington Athletics </em></p><p>The season ended, but there was a silver lining.<br />&nbsp;<br />Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a></strong> set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley Tuesday (March 13) in Orem, Utah, in EWU's third-straight appearance for the Eagles in the College Basketball Invitational.<br />&nbsp;<br />Bliznyuk tied the record with 50 seconds left, then broke it with a 3-pointer on the last shot of his illustrious career with 20 ticks remaining. The game was long decided by then, as Utah Valley used runs of 9-0 in the first half and 9-0 and 15-0 in the second half put the game out of reach. Bliznyuk, the Big Sky's all-time leading scorer with 2,169 points, finished with 741 this season to rank sixth in league history and break the previous school record of 738 set three years ago by Tyler Harvey.<br />&nbsp;<br />He closed his career with 27 points against UVU &ndash; the 44th time in his 138-game career he's scored at least 20. It was also his 100th double-digit performance, and Bliznyuk's late 3-pointer helped him tie the school record with 265 field goals this season. He closed his collegiate career with 14 school records, a variety of Big Sky Conference Tournament marks, a NCAA Division I single season free throw record with 77-straight makes and the utmost respect from his head coach.<br />&nbsp;<br />&quot;I love Tyler to death, but I wasn't about to let Bogdan go without that record,&quot; said <strong><a href="http://goeags.com/coaches.aspx?rc=126" id="sidearmAd2" rel="smarttag">Shantay Legans</a></strong>. &quot;I want to make sure our team knows how important everything is, and Bogdan is going to understand some day how much he accomplished. Right now he doesn't see it and his teammates don't understand what they just witnessed. It was probably the best single season a player has had at Eastern Washington and probably the best career &ndash; he's going to be in the record books a long time.&quot;<br />&nbsp;<br />The Wolverines advance to play the winner of the Colgate at San Francisco game which will be played Wednesday (March 14) at USF. The Eagles close their season 20-15 on the season won 17 of their last 24 games after a 3-8 start. The 35 games EWU played equaled the school record.<br />&nbsp;<br />Utah Valley is 23-10 this season &ndash; including a 16-1 mark at home and the nation's fourth-longest home winning streak at 14 games. The Eagles are 6-12 on opponent home courts, and had won their last two on the road and two of its last three on a neutral court.<br />&nbsp;<br />Eastern was making its sixth appearance in a national postseason tournament in school history and fourth-in-a-row. Eastern advanced to the NCAA Tournament in 2004 and 2015, were in the NIT in 2003 and have played in the last two College Basketball Invitational (CBI) tournaments. In the 2016 CBI, Eastern recorded its first win in a national postseason tournament with a 79-72 home win over Pepperdine.<br />&nbsp;<br />&nbsp;<br /><em><strong>Records . . . </strong></em><br />&nbsp;<br />* The Eagles finished 20-15 on the season and were 13-5 in the Big Sky, and won 17 of their last 24 games after a 3-8 start. The Eagles were 11-1 at home, 6-12 on opponent home courts and 3-2 at neutral sites this season, finishing 5-4 on the road in the league season and 8-1 at home. With an 82-70 victory over Southern Utah in the semifinals of the Big Sky Conference Tournament, Eastern extended its winning streak to eight games &ndash; its longest in 14 years. Eastern has 20 victories for the second-straight season and the third time in the last four, with EWU achieving that mark just one other time in the school's 35 seasons as a member of NCAA Division I.<br />&nbsp;<br />* Utah Valley is 23-10 this season &ndash; including a 16-1 mark at home where it averages more than 3,500 fans per game &ndash; and were 10-4 in the Western Athletic Conference. The Wolverines beat CSU Bakersfield 81-74 and lost to Grand Canyon 75-60 at the WAC Tournament. They were 4-1 versus common opponents with EWU, while the Eagles were also 4-1.<br />&nbsp;<br />* Both teams lost to Seattle and former Eagle head coach Jim Hayford. The Eagles lost in Seattle 84-65 on Dec. 3, while the Wolverines lost there 55-54 during the WAC season. Utah Valley ended the regular season with a 73-47 win over the Redhawks in Orem. Eastern defeated North Dakota twice and Idaho State and Weber State once each, and Utah Valley beat each of those opponents once.<br />&nbsp;<br /><br /><em><strong>What's Next . . . </strong></em><br />&nbsp;<br />* Advancing to the quarterfinals of the 16-team tournament, Utah Valley advances to play the winner of the Colgate (19-13) at San Francisco (18-15) game which will be played Wednesday (March 14) at USF. The other first-round games to be played on Wednesday are Miami of Ohio (16-17) at Campbell (16-15), Colgate (19-13) at San Francisco (18-15), UTRGV (15-17) at New Orleans (15-16), Central Arkansas (17-16) at Seattle (20-13), North Texas (15-17) at South Dakota (26-8), Mercer (18-14) at Grand Canyon (22-11) and Jacksonville State (21-12) at Canisius (21-11).<br />&nbsp;<br />* The CBI is a single-elimination tournament up until the best-of-three finals, with all games played at campus sites. After the first round games, the quarterfinal round will take place on Monday, March 19, followed by the semifinal round on Wednesday, March 21. After the quarterfinals, the remaining teams will be re-bracketed for travel purposes. The finals series is a best-of-three in which one team will host two of the three games. Those games will be played on March 26, March 28, and March 30.<br />&nbsp;<br />&nbsp;<br /><em><strong>Keys to Game . . . </strong></em><br />&nbsp;<br />*&nbsp;Coming off an emotional 82-65 loss to the Montana in the Big Sky Conference Tournament championship game, the Eagles were out-shot 55.8 percent to 35.7 percent. It was the third-lowest shooting performance of the season for the Eagles, and its 18.5 percent from the 3-point stripe (5-of-27) equaled its lowest.<br />&nbsp;<br /><br /><em><strong>Turning Point . . . </strong></em><br />&nbsp;<br />*&nbsp;Eastern made six of its first 10 shots and took an early 12-8 lead. But then the Eagles missed their next 11 shots and went eight minutes without a field goal. The resulting 9-0 run gave the Wolverines the lead for good, and they led 36-29 at halftime. Eastern was within six in the second half at 42-36, but a 9-0 Utah Valley run opened a 16-point advantage, and then a late 15-0 run put the nail in the coffin as UVU opened its biggest lead of the game at 27.<br />&nbsp;<br />&nbsp;<br /><em><strong>Top Performers . . . </strong></em><br />&nbsp;<br />* Big Sky Conference all-time leading scorer <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd3" rel="smarttag">Bogdan Bliznyuk</a> </strong>scored 27 on 11-of-21 shooting from the field and made all four of his free throws to finish with the school single season record for free throw percentage (90.2 percent). He also led the Eagles with seven rebounds and three assists. Bliznyuk finished with 17 performances this season with at least 20 points and 43 in his career, and he had 32 double-figure scoring performances in 35 games this season and 100 in his 138-game career.<br />* Three other Eagles scored at least seven points, with junior <strong><a href="http://goeags.com/roster.aspx?rp_id=4938" id="sidearmAd4" rel="smarttag">Ty Gibson</a> </strong>finishing with eight, junior <strong><a href="http://goeags.com/roster.aspx?rp_id=4934" id="sidearmAd5" rel="smarttag">Cody Benzel</a> </strong>getting seven and redshirt freshman <strong><a href="http://goeags.com/roster.aspx?rp_id=4936" id="sidearmAd6" rel="smarttag">Jacob Davison</a> </strong>also scoring seven.<br />&nbsp;<br />&nbsp;<br /><em><strong>Key Stats . . . </strong></em><br /><br />* Eastern had just 11 turnovers compared to 19 for Utah Valley, but was out-rebounded by a 46-27 margin. Eastern was also out-shot 55.8 percent to 35.7 percent overall, and 43.8 percent to 18.5 percent in the second half. The Eagles have had 50-percent shooting performances in six of their last nine games to improve to 12-0 this season when they hit that mark, but closed the year with performances of 45.0 percent in the Big Sky Conference Championship game on March 10 and 35.7 percent three days later in the CBI. For the season, Eastern was 18-2 when they out-shoot their opponents and 2-13 when they didn't. Eastern had all 12 of its 50-percent shooting nights in the last 23 games.<br />&nbsp;<br />&nbsp;<br /><em><strong>Other Team Highlights . . . </strong></em><br />&nbsp;<br />* Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd7" rel="smarttag">Bogdan Bliznyuk</a></strong> added No. 14 to his school records by upping his season total of points scored to 741. That broke the record of 738 set by Tyler Harvey three seasons ago which now ranks sixth in Big Sky history. The only players ahead of Harvey are Northern Colorado's Andre Spight with 745 thus far this season, Southern Utah's Randy Onwuasor with 780 last season and Weber State's Damian Lillard with 748 in 2012, as well as a pair of players at the top of the list with more than 800 points. Lawrence Butler of Idaho State scored 812 in 1979, and Dave Wagnon from Idaho State finished with 845 in 1966 in the league's third season of existence. The 14th record he broke was for single season field goals made with 265. Less than a week ago, in a Big Sky Conference Tournament semifinal win on March 9 over Southern Utah, he broke the 24-year old league all-time career scoring record of 2,102 points set by Orlando Lightfoot from Idaho in three seasons from 1991-94. Just five players in the 55-year history of the league have hit the 2,000-point mark, and Bliznyuk stands above them all with a current total of 2,169 points in 138 career games.<br />&nbsp;<br />&nbsp;<br /><em><strong>Notables . . . </strong></em><br /><br />* The Eagles and Wolverines have met twice before, with EWU winning the last meeting on Nov. 17, 2014, in Cheney, Wash., by a 75-50 score. Eastern lost to them previously 86-83 on Nov. 20, 2012, on a neutral court at the CBE Classic in Santa Clara, Calif. In the previous meeting with UVU, then freshman <strong><a href="http://goeags.com/roster.aspx?rp_id=4945" id="sidearmAd8" rel="smarttag">Sir Washington</a> </strong>made a 3-pointer in his lone shot of the game in three minutes of action. <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd9" rel="smarttag">Bogdan Bliznyuk</a> </strong>made his only shot and finished with two points, three rebounds, an assist and a block in 10 minutes. Zach Nelson is the only Wolverine still on the Utah Valley roster, and he had 12 points on 5-of-10 shooting with 2-of-3 3-pointers, four rebounds and a blocked shot in 26 minutes. Utah Valley never led as the Eagles had a 38-25 halftime advantage and were up by as many as 27 in the second half. Eastern led for 37:16 and the game was tied for the other 2:05. &nbsp;Eastern is 18-14 all-time versus current members of the Western Athletic Conference, but 25 of those have come against Seattle (15-10). Eastern is also 1-1 versus University of Missouri Kansas City and 1-2 against Chicago State, and has not played New Mexico State, Grand Canyon, UT Rio Grande Valley or CSU Bakersfield.<br />&nbsp;<br />&nbsp;* Utah Valley is coached by Mark Pope, who graduated in 1991 from Newport High School in Bellevue (Wash.), and was the Pac-12 Freshman of the Year in 1992. However, Pope transferred to Kentucky where he helped lead the Wildcats to the 1996 NCAA Tournament championship. After playing professionally for seven seasons in the NBA and two in Turkey, Pope was an assistant at Georgia, Wake Forest and BYU before taking over at UVU in the 2015-16 season. He was 12-18 in his first year and 17-17 in his second before a 22-10 record this season. He took over for Dick Hunsaker, who was the only head coach the Wolverines had in their first 11 seasons as a member of NCAA Division I.<br />&nbsp;<br />* With size throughout its lineup, Utah Valley is the 18th-best rebounding team in NCAA Division I with a +6.3 rebounding margin. The Wolverines feature a starting lineup of 7-0, 6-7, 6-5, 6-4 and 6-2, and all five of them average in double figures. They also have a pair of 6-11 players off the bench. Six-foot-7 Kenneth Ogbe leads UVU with an average of 13.2 points per game, and 7-foot Akolda Manyang averages 13.0 points and 7.9 rebounds, and ranks 20th nationally with an average of 2.3 blocked shots per game. Conner Toolson averages 12.5 points and has hit 74-of-182 3-pointers for 40.7 percent, and Jake Toolson averages 11.4. Brandon Randolf averages 10.8 points and 4.6 assists. The Wolverines are 25th in the nation in scoring margin (+10.3 per game), and 29th in field goal shooting (48.1 percent). They also rank in the top 50 in 3-point field goal shooting offense (38.3 percent, 45th) and 3-point field goal shooting defense (32.3 percent, 33rd).<br />&nbsp;<br />&nbsp;<br /><em><strong>Other EWU Postseason Notes . . . </strong></em><br />&nbsp;<br />* Eastern was making its sixth appearance in a national postseason tournament in school history and fourth-in-a-row. Eastern advanced to the NCAA Tournament in 2004 and 2015, were in the NIT in 2003 and have played in the last two College Basketball Invitational (CBI) tournaments. In the 2016 CBI, Eastern recorded its first win in a national postseason tournament with a 79-72 home win over Pepperdine on March 16, 2016. The Eagles are now 1-5 in postseason national tournaments as a member of NCAA Division I, and 7-10 overall. In 2003, Eastern fell at Wyoming 78-71 in the first round of the NIT, then a year later lost 75-56 to Oklahoma State in the NCAA Tournament in Kansas City, Mo. In 2015, after winning the Big Sky Conference Tournament title in Missoula, Eastern fell to 22nd-ranked Georgetown 84-74 in the NCAA Tournament. After the win over Pepperdine in the CBI in 2016, Eastern lost at Nevada 85-70 in Reno, Nevada. In EWU's most recent appearance in the CBI, the Eagles fell 91-81 at Wyoming on March 15, 2017, in Laramie, Wyo. Eastern also played in the NAIA Championships (then known as NAIB) on five occasions, with a 6-5 record in appearances in 1942, 1943, 1945, 1946 and 1947. Before beating Pepperdine in 2016, Eastern's previous national tournament victory came on March 12, 1947, when Eastern &ndash; then known as the Eastern Washington College of Education Savages &ndash; beat Dakota Wesleyan 62-48. One year earlier, Eastern lost to Pepperdine before meeting the Waves again for the second time in school history nearly 70 years to the day later in the CIT.<br />&nbsp;<br />* Including Utah Valley, Eastern was a respectable 5-10 this season versus 11 teams who reached national postseason tournament, with that record including a 1-8 record on the road, 1-2 at neutral sites and 3-0 at home. Eastern split a pair of games with NCAA Tournament participant Montana (26-7), and lost 68-50 to a talented Georgia State (24-10) team which also advanced to the Big Dance as the Sun Belt champion. Eastern faced three Pac-12 opponents, and all three of them advanced to the NIT. Eastern won 67-61 at Stanford (18-15), but lost 79-69 at Washington (20-12) and 85-69 at Utah (19-11). Three other Pac-12 teams advanced to the NCAA Tournament (Arizona, UCLA and Arizona State). Joining Eastern in the CBI are Jim Hayford-coached Seattle (20-14), San Francisco (18-15) and South Dakota (26-8). Eastern lost to all three of those teams in consecutive road games in December &ndash; 84-65 to the Redhawks, 81-71 to the Dons and 75-73 versus the Coyotes. Eastern also split two games this season with Northern Colorado and was 2-1 versus Portland State, as both of those teams were selected to play in the College Insider Tournament. Eastern played four other 20-victory teams which either chose not to play or were not selected for the postseason &ndash; UNLV (20-13), Wyoming (20-13), Idaho (22-9) and Weber State (20-11). In all, Eastern joined 10 of its opponents with at least 20 victories this season. A record six Big Sky teams had at least 20 wins, eclipsing the 2014-15 season when four teams had that many. Eastern led the way that season with a 26-9 record on its way to the NCAA Tournament.<br />&nbsp;<br />&nbsp;<br /><em><strong>Comments from Head Coach </strong></em><strong><a href="http://goeags.com/coaches.aspx?rc=126" id="sidearmAd10" rel="smarttag">Shantay Legans</a></strong><em><strong> . . . </strong></em><br />&nbsp;<br /><em>On Loss: &quot;</em><em>Our guys were more mentally drained than I expected. I thought after the loss against Montana in that championship game that they would bounce back after a couple of days and be ready to go. But we couldn't get them linked up and sometimes that happens in this kind of game. I have to teach and coach them to get them there. In life when things aren't always going right, you just have to get back off the ground and fight. That's my job here at Eastern to show them how important it is to compete and keep swinging. We didn't do that today and I was a little disappointed, but I'm proud with how well they responded all year long.&quot;</em><br />&nbsp;<br />On Bliznyuk: &quot;He's established his legacy not just in the Big Sky or at Eastern, but in the NCAA as well. I don't think his free throw record will be ever be broken. As a coach you understand what we just witnessed a little bit, but you have to keep moving on and keep moving forward. But it has been a tremendous season for Bogdan.&quot;<br />&nbsp;<br /><em>On His First Year as Head Coach:</em> &quot;The support has been great back home. Everybody and the athletic department has been right behind us every single step of the way. It's been a tremendous first year for me and I couldn't be happier. I want to thank everybody for believing in this team and being part of something special this year. I'm sorry we couldn't win the tournament and get to the dance, but we'll be back next year. We want everybody to support these players because they deserve it &ndash; they work their tails off on the court and in the classroom. Supporting them is huge to our team and means a lot. I'm excited about our future and our athletic department.&quot;</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><!--Start of Display Size:  (7)--><div class="wnBlock displaySize displaySizeId7 nestedCategory" id="DisplaySizeId7"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">College Sports</span><span class="text abridgedHeadline">College</span><a class="wnContent more enabled" href="/category/162314/college"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportNCAABasketball story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-14 04:29:51"><h4 class="wnContent headline"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">Bliznyuk sets single season scoring record in loss to Utah Valley in CBI</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">Bliznyuk sets single season scoring record in loss to Utah Valley in CBI</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180314002658" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180314002658" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a></strong> set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley.</p></span><a class="more" href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a></strong> set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley.</p></span><a class="more" href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-13 23:05:29"><h4 class="wnContent headline"><a href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><span class="text">June Daugherty will not return as WSU coach</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><span class="text">June Daugherty will not return as WSU coach</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16308632_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313190459" title="Daugherty spent 11 seasons as Cougars head coach" alt="Daugherty spent 11 seasons as Cougars head coach"></a><span class="caption left width180"><span class="text">Daugherty spent 11 seasons as Cougars head coach</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16308632_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313190459" title="Daugherty spent 11 seasons as Cougars head coach" alt="Daugherty spent 11 seasons as Cougars head coach"></a><span class="caption left width115"><span class="text">Daugherty spent 11 seasons as Cougars head coach</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Daugherty, hired prior to the 2007-08 campaign, has guided the Cougars for the past 11 seasons, posting a combined 130-218 record, including three WNIT appearances.</p></span><a class="more" href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Daugherty, hired prior to the 2007-08 campaign, has guided the Cougars for the past 11 seasons, posting a combined 130-218 record, including three WNIT appearances.</p></span><a class="more" href="/story/37717969/june-daugherty-will-not-return-as-wsu-coach"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-20 odd-20"><meta content="News"><meta content="2018-03-13 21:36:13"><h4 class="wnContent headline"><a href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><span class="text">Throwback to 1986: MSU stuns Big Sky Conference, goes dancing</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><span class="text">Throwback to 1986: MSU stuns Big Sky Conference, goes dancing</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, March 13 2018 5:36 PM EDT</span><span class="wnContent timestamp gmttime">2018-03-13 21:36:38 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/16307638_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313173417"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/16307638_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313173417"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Montana State men's team finished a disappointing season with a 14-17 overall mark. Then something magical happened &ndash; the Cats won the Big Sky Tournament as the six seed and the automatic bid to the NCAA Tournament.&nbsp;</p></span><a class="more" href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Montana State men's team finished a disappointing season with a 14-17 overall mark. Then something magical happened &ndash; the Cats won the Big Sky Tournament as the six seed and the automatic bid to the NCAA Tournament.&nbsp;</p></span><a class="more" href="/story/37717274/throwback-to-1986-msu-stuns-big-sky-conference-goes-dancing"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport"><meta content="2018-03-13 04:43:30"><h4 class="wnContent headline"><a href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><span class="text">Gonzaga Women earn 13 Seed in NCAA Tournament, set to face Stanford Saturday</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><span class="text">Gonzaga Women earn 13 Seed in NCAA Tournament, set to face Stanford Saturday</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16257682_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313004305" title="Zags win their 2nd straight WCC tournament title" alt="Zags win their 2nd straight WCC tournament title"></a><span class="caption left width180"><span class="text">Zags win their 2nd straight WCC tournament title</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16257682_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313004305"></a></div><div class="wnContent summary abridged"><span class="text"><p>Gonzaga was selected for its ninth NCAA Tournament in 10 years and 10th overall.&nbsp;</p></span><a class="more" href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Gonzaga was selected for its ninth NCAA Tournament in 10 years and 10th overall.&nbsp;</p></span><a class="more" href="/story/37709395/gonzaga-women-earn-13-seed-in-ncaa-tournament-set-to-face-stanford-saturday"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="General001"><meta content="2018-03-13 04:25:17"><h4 class="wnContent headline"><a href="/story/37709349/super-8-plays-of-the-week-312"><span class="text">Super 8 Plays of the Week 3/12</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37709349/super-8-plays-of-the-week-312"><span class="text">Super 8 Plays of the Week 3/12</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, March 13 2018 12:30 AM EDT</span><span class="wnContent timestamp gmttime">2018-03-13 04:30:06 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37709349/super-8-plays-of-the-week-312"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/16301982_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313002143"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37709349/super-8-plays-of-the-week-312"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/16301982_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313002143"></a></div><div class="wnContent summary abridged"><span class="text"><p>Check out the final Super 8 Plays of the Week until football season!</p></span><a class="more" href="/story/37709349/super-8-plays-of-the-week-312"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Check out the final Super 8 Plays of the Week until football season!</p></span><a class="more" href="/story/37709349/super-8-plays-of-the-week-312"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="General001"><meta content="2018-03-13 04:19:11"><h4 class="wnContent headline"><a href="/story/37709318/msub-women-win-first-west-regional-since-1999"><span class="text">MSUB Women Win First West Regional Since 1999</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37709318/msub-women-win-first-west-regional-since-1999"><span class="text">MSUB Women Win First West Regional Since 1999</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, March 13 2018 12:19 AM EDT</span><span class="wnContent timestamp gmttime">2018-03-13 04:19:11 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37709318/msub-women-win-first-west-regional-since-1999"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/16301975_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313001806"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37709318/msub-women-win-first-west-regional-since-1999"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/16301975_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180313001806"></a></div><div class="wnContent summary abridged"><span class="text"><p>MSUB snapped a 9 game losing streak to Alaska Anchorage with the win.</p></span><a class="more" href="/story/37709318/msub-women-win-first-west-regional-since-1999"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>MSUB snapped a 9 game losing streak to Alaska Anchorage with the win.</p></span><a class="more" href="/story/37709318/msub-women-win-first-west-regional-since-1999"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport"><meta content="2018-03-13 02:58:07"><h4 class="wnContent headline"><a href="/story/37709024/sport"><span class="text">Former Griz Show Out For NFL Scouts</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, March 12 2018 11:01 PM EDT</span><span class="wnContent timestamp gmttime">2018-03-13 03:01:35 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37709024/sport"><img border="0" width="180" data-path="http://KTMF.images.worldnow.com/images/16301424_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180312230108"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37709024/sport"><img border="0" width="115" data-path="http://KTMF.images.worldnow.com/images/16301424_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180312230108"></a></div><div class="wnContent summary abridged"><span class="text"><p>Courtesy Montana Sports Information Former Griz leave it all on the field on Pro Day Months of toil and sweat in weight rooms across the country culminated for eight former Montana Grizzlies at the team's annual Pro Day in Missoula on Monday.&nbsp;</p></span><a class="more" href="/story/37709024/sport"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Courtesy Montana Sports Information Former Griz leave it all on the field on Pro Day Months of toil and sweat in weight rooms across the country culminated for eight former Montana Grizzlies at the team's annual Pro Day in Missoula on Monday.&nbsp;</p></span><a class="more" href="/story/37709024/sport"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-12 04:01:27"><h4 class="wnContent headline"><a href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><span class="text">Washington to play Boise State in 1st round of NIT</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><span class="text">Washington to play Boise State in 1st round of NIT</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16293479_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311235931" title="Photo: Washington Athletics" alt="Photo: Washington Athletics"></a><span class="caption left width180"><span class="text">Photo: Washington Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16293479_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311235931" title="Photo: Washington Athletics" alt="Photo: Washington Athletics"></a><span class="caption left width115"><span class="text">Photo: Washington Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>The University of Washington Men's Basketball Team earned a number five seed in the 2018 National Invitational Tournament and will host four-seed Boise State on Wednesday, March 14 at 7 p.m.</p></span><a class="more" href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The University of Washington Men's Basketball Team earned a number five seed in the 2018 National Invitational Tournament and will host four-seed Boise State on Wednesday, March 14 at 7 p.m.</p></span><a class="more" href="/story/37699577/washington-to-play-boise-state-in-1st-round-of-nit"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-12 02:36:09"><h4 class="wnContent headline"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">Eagles to play Utah Valley in 1st round of CBI Tournament</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">Eagles to play Utah Valley in 1st round of CBI Tournament</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16293113_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311222918" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16293113_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311222918" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>The Eastern Washington University men's basketball team has been invited to play in the College Basketball Invitational and will open play on Tuesday.</p></span><a class="more" href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Eastern Washington University men's basketball team has been invited to play in the College Basketball Invitational and will open play on Tuesday.</p></span><a class="more" href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAA story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NCAA"><meta content="2018-03-11 22:24:05"><h4 class="wnContent headline"><a href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><span class="text">Gonzaga gets #4 seed; Will play #13 UNC Greensboro in first round</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><span class="text">Gonzaga gets #4 seed; Will play #13 UNC Greensboro in first round</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, March 11 2018 6:59 PM EDT</span><span class="wnContent timestamp gmttime">2018-03-11 22:59:19 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><img border="0" width="180" data-path="http://khq.images.worldnow.com/images/10091172_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311182249"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><img border="0" width="115" data-path="http://khq.images.worldnow.com/images/10091172_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311182249"></a></div><div class="wnContent summary abridged"><span class="text"><p>SPOKANE, Wash. -&nbsp;The Gonzaga Bulldogs snagged a #4 seed in the NCAA tournament and will play #13 seeded UNC Greensboro in the first round of the NCAA tournament in Boise, ID.&nbsp;This is Gonzaga's 20th&nbsp;consecutive appearance in the tournament, which ranks 6th in current active streaks, with Kansas at the top of the list, making their 29th appearance this year.&nbsp;</p></span><a class="more" href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>SPOKANE, Wash. -&nbsp;The Gonzaga Bulldogs snagged a #4 seed in the NCAA tournament and will play #13 seeded UNC Greensboro in the first round of the NCAA tournament in Boise, ID.&nbsp;This is Gonzaga's 20th&nbsp;consecutive appearance in the tournament, which ranks 6th in current active streaks, with Kansas at the top of the list, making their 29th appearance this year.&nbsp;</p></span><a class="more" href="/story/37698651/gonzaga-gets-4-seed-will-play-13-unc-greensboro-in-first-round"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId7');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size:  (7)--><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd63" class="wnad wnad63">
<script>wnad_63.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Promo Box - Col 4A (24)--><div class="wnBlock displaySize displaySizeId24 promoBox" id="DisplaySizeId24"><ul class="wnGroup contentGroup odd last"><li class="wnItem feature  link priority-1 odd displaySizeId-4 odd-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.khq.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376213_LS.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.khq.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376213_LA.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.</span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.<br /></span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-2 even displaySizeId-4 even-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.nbcrightnow.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376216_LS.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.nbcrightnow.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376216_LA.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.<br /></span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.</span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-3 odd displaySizeId-4 odd-4 last"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.kulr8.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/702249_LS.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.kulr8.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/702249_LA.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text">Breaking news, weather and community information for Billings, MT and surrounding areas.</span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Billings, Mont. and surrounding area, including northern Wyoming.<br /></span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId24');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Promo Box - Col 4A (24)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Eastern Washington</span><span class="text abridgedHeadline">EWU</span><a class="wnContent more enabled" href="/category/162663/ewu-sports"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportNCAABasketball story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-14 04:29:51"><h4 class="wnContent headline"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">Bliznyuk sets single season scoring record in loss to Utah Valley in CBI</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">Bliznyuk sets single season scoring record in loss to Utah Valley in CBI</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180314002658" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16310711_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180314002658" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a></strong> set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley.</p></span><a class="more" href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a></strong> set yet another school scoring record, this time for single season points, but the Eastern Washington University men's basketball team fell to Utah Valley.</p></span><a class="more" href="/story/37719430/bliznyuk-sets-single-season-scoring-record-in-loss-to-utah-valley-in-cbi"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-12 02:36:09"><h4 class="wnContent headline"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">Eagles to play Utah Valley in 1st round of CBI Tournament</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">Eagles to play Utah Valley in 1st round of CBI Tournament</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16293113_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311222918" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16293113_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311222918" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>The Eastern Washington University men's basketball team has been invited to play in the College Basketball Invitational and will open play on Tuesday.</p></span><a class="more" href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Eastern Washington University men's basketball team has been invited to play in the College Basketball Invitational and will open play on Tuesday.</p></span><a class="more" href="/story/37699401/eagles-to-play-utah-valley-in-1st-round-of-cbi-tournament"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-11 05:23:28"><h4 class="wnContent headline"><a href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><span class="text">EWU runs out of gas in the 2nd half; Griz take Big Sky Tourney & tourney bid</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><span class="text">EWU runs out of gas in the 2nd half; Griz take Big Sky Tourney & tourney bid</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16290300_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311004210"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16290300_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180311004210"></a></div><div class="wnContent summary abridged"><span class="text"><p>EWU Athletics For a half, the Eagles looked every bit like the Big Sky Conference's representative in the NCAA Tournament. &nbsp; But a turnaround in fortune in the second half helped Montana defeat the Eastern Washington University men's basketball team 82-65 in EWU's seventh Big Sky Conference Tournament championship game in school history Saturday (March 10) at the Reno (Nevada) Events Center. &nbsp; The Eagles led 40-29 at halftime thanks to 53.3 percent shooting that included 8-...</p></span><a class="more" href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>EWU Athletics For a half, the Eagles looked every bit like the Big Sky Conference's representative in the NCAA Tournament. &nbsp; But a turnaround in fortune in the second half helped Montana defeat the Eastern Washington University men's basketball team 82-65 in EWU's seventh Big Sky Conference Tournament championship game in school history Saturday (March 10) at the Reno (Nevada) Events Center. &nbsp; The Eagles led 40-29 at halftime thanks to 53.3 percent shooting that included 8-...</p></span><a class="more" href="/story/37696453/ewu-runs-out-of-gas-in-the-2nd-half-griz-take-big-sky-tourney-tourney-bid"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-10 06:47:35"><h4 class="wnContent headline"><a href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><span class="text">Bliznyuk makes history as Eagles head to Big Sky Championship</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><span class="text">Bliznyuk makes history as Eagles head to Big Sky Championship</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16287437_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180310014557" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16287437_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180310014557" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>On a night Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a> </strong>became the all-time leading scorer in the 55-year history of the league and set a trio of tournament records.</p></span><a class="more" href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>On a night Big Sky Conference MVP <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a> </strong>became the all-time leading scorer in the 55-year history of the league and set a trio of tournament records.</p></span><a class="more" href="/story/37693405/bliznyuk-makes-history-as-eagles-head-to-big-sky-championship"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2018-03-10 03:14:08"><h4 class="wnContent headline"><a href="/story/37692760/annual-pro-day-features-9-eagles"><span class="text">Annual Pro Day features 9 Eagles</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37692760/annual-pro-day-features-9-eagles"><span class="text">Annual Pro Day features 9 Eagles</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37692760/annual-pro-day-features-9-eagles"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16286412_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180309221332" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37692760/annual-pro-day-features-9-eagles"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16286412_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180309221332" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>With <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd1" rel="smarttag">Albert Havili</a></strong> turning in an impressive performance in the bench press, nine former Eastern Washington University football players took part in testing for 15 professional football scouts.</p></span><a class="more" href="/story/37692760/annual-pro-day-features-9-eagles"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>With <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd1" rel="smarttag">Albert Havili</a></strong> turning in an impressive performance in the bench press, nine former Eastern Washington University football players took part in testing for 15 professional football scouts.</p></span><a class="more" href="/story/37692760/annual-pro-day-features-9-eagles"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-09 06:36:13"><h4 class="wnContent headline"><a href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><span class="text">Eagles advance to Big Sky semifinals after 78-72 win over Portland State</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><span class="text">Eagles advance to Big Sky semifinals after 78-72 win over Portland State</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16279103_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180309013431" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16279103_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180309013431" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>The winner of the EWU-SUU game advances to Saturday's championship game at 5 p.m., with the winner receiving a berth into the NCAA Tournament.</p></span><a class="more" href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The winner of the EWU-SUU game advances to Saturday's championship game at 5 p.m., with the winner receiving a berth into the NCAA Tournament.</p></span><a class="more" href="/story/37685399/eagles-advance-to-big-sky-semifinals-after-78-72-win-over-portland-state"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-08 06:11:22"><h4 class="wnContent headline"><a href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><span class="text">Eagles eliminated from Big Sky Tournament after 82-73 loss to Portland State</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><span class="text">Eagles eliminated from Big Sky Tournament after 82-73 loss to Portland State</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16269871_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180308011051" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16269871_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180308011051"></a></div><div class="wnContent summary abridged"><span class="text"><p>A long road trip, a late game and a hot-shooting opponent conspired against the Eastern Washington University women's basketball team as it fell 82-73 to Portland State Wednesday.</p></span><a class="more" href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A long road trip, a late game and a hot-shooting opponent conspired against the Eastern Washington University women's basketball team as it fell 82-73 to Portland State Wednesday.</p></span><a class="more" href="/story/37675086/eagles-eliminated-from-big-sky-tournament-after-82-73-loss-to-portland-state"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport"><meta content="2018-03-06 05:25:00"><h4 class="wnContent headline"><a href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><span class="text">Bogdan Bliznyuk named Big Sky MVP, Mason Peatling named honorable mention All-Big Sky</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><span class="text">Bogdan Bliznyuk named Big Sky MVP, Mason Peatling named honorable mention All-Big Sky</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16100158_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180306002433" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16100158_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180306002433" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>A NCAA Division I record and move up to third on the Big Sky Conference all-time men's basketball scoring chart were the accomplishments last week for Eastern Washington University's&nbsp;Bogdan Bliznyuk&nbsp;as he was selected as the Ready Nutrition Player of the Week by the league office on Monday (March 5).</p></span><a class="more" href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A NCAA Division I record and move up to third on the Big Sky Conference all-time men's basketball scoring chart were the accomplishments last week for Eastern Washington University's&nbsp;Bogdan Bliznyuk&nbsp;as he was selected as the Ready Nutrition Player of the Week by the league office on Monday (March 5).</p></span><a class="more" href="/story/37653923/bogdan-bliznyuk-named-big-sky-mvp-mason-peatling-named-honorable-mention-all-big-sky"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-04 02:46:23"><h4 class="wnContent headline"><a href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><span class="text">Bliznyuk sets NCAA record as Eagles beat Northern Arizona, 85-68</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><span class="text">Bliznyuk sets NCAA record as Eagles beat Northern Arizona, 85-68</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16238393_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180303214545" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16238393_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180303214545" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Eastern Washington University men's basketball player <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a> </strong>set a new NCAA Division I record for consecutive free throws made as the Eagles beat Northern Arizona 85-68.</p></span><a class="more" href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Eastern Washington University men's basketball player <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd1" rel="smarttag">Bogdan Bliznyuk</a> </strong>set a new NCAA Division I record for consecutive free throws made as the Eagles beat Northern Arizona 85-68.</p></span><a class="more" href="/story/37640849/bliznyuk-sets-ncaa-record-as-eagles-beat-northern-arizona-85-68"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NCAA-Basketball"><meta content="2018-03-03 05:46:28"><h4 class="wnContent headline"><a href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><span class="text">Delaney Hodgins scores Big Sky record 46 points in win over Northern Arizona</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><span class="text">Delaney Hodgins scores Big Sky record 46 points in win over Northern Arizona</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16234537_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180303004531" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16234537_G.jpg?auto=webp&amp;disable=upscale&amp;width=650&amp;lastEditedDate=20180303004531" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width115"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Hodgins broke Eastern Washington's single-game record of 38, held by Vanessa Jones since Dec. 5, 1990 and didn't stop there. Her total of 46 points is the most scored in Eastern Washington basketball history, male or female.</p></span><a class="more" href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Hodgins broke Eastern Washington's single-game record of 38, held by Vanessa Jones since Dec. 5, 1990 and didn't stop there. Her total of 46 points is the most scored in Eastern Washington basketball history, male or female.</p></span><a class="more" href="/story/37637679/delaney-hodgins-scores-big-sky-record-46-points-in-win-over-northern-arizona"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://SWXRN.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText">All content &copy; Copyright  2000  - 2018 SWXRN. All Rights Reserved.<BR>For more information on this site, please read  our <A HREF='/story/18990/this-web-sites-privacy-policy'  >Privacy Policy</a>, and <A HREF='/story/18991/this-sites-terms-of-service'  >Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.</div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E")); </script> <script type="text/javascript"> try { var pageTracker = _gat._getTracker("UA-15497971-2"); pageTracker._trackPageview(); } catch(err) {}</script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>