<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9jzm6dt" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9jzm6dt";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Chiefs cruise past Americans, winning 6-3 - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</title>
<meta name="Description" content="Yamamoto, with a goal and four assists, was in on the first five of Spokane’s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points."><meta name="KEYWORDS" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="news_keywords" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2018/02/11"><meta name="owner" content="SWXRN"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="7.3.20.1"><meta name="wn-base" content="IIS16"><meta name="wnreadableurl" content="chiefs-cruise-past-americans-winning-6-3"><meta property="og:title" content="Chiefs cruise past Americans, winning 6-3"><meta property="og:type" content="article"><meta property="og:url" content="http://www.swxrightnow.com/story/37477688/chiefs-cruise-past-americans-winning-6-3"><meta property="og:image" content="http://SWXRN.images.worldnow.com/images/16052108_G.jpg"><meta property="og:description" content="Yamamoto, with a goal and four assists, was in on the first five of Spokane’s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points."><link rel="canonical" href="http://www.swxrightnow.com/story/37477688/chiefs-cruise-past-americans-winning-6-3"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Chiefs cruise past Americans, winning 6-3"><meta name="twitter:description" content="Yamamoto, with a goal and four assists, was in on the first five of Spokane’s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points."><meta name="twitter:image" content="http://SWXRN.images.worldnow.com/images/16052108_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:page_id" content="130847515832" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.3.20.1_7.4.4-6">
<link type="text/css" rel="stylesheet" media="all" href="http://SWXRN.images.worldnow.com/interface/css/container-e.css?ver=2018-01-10%2012%3A29%3A54_7.4.4-6">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.4.4-6_7.3.20.1" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.3.20.1"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.3.20.1"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.3.20.1"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1641 UL
                    , #menu1641 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641 A,
                    #menu1641 LI.wnOn .wnSublevel A,
                    #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641
                        .wnLevel1, #menu1641
                        .wnLevel1 LI { height: 38px; }
                            #menu1641 .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu1641 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu1641 LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1641 .wnSublevel { background-color: #d5d5d5;  }
                #menu1641 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu1641 > .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel { width: 978px; }
                    #menu1641 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu1641 .wnLeft { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu1641 LI.wnOn .wnLeft { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1641 .wnRight { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu1641 LI.wnOn .wnRight { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1641 .wnRight .wnMiddle { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1641 LI.wnOn .wnMiddle { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu1641 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu1641 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'SWXRN',
            affiliateId : '863',
            baseUrl : 'www.swxrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.4.4-6',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '64',mdPartnerDomain : 'http://dub.swxrightnow.com'},
            registrationId : '557063',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://SWXRN.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.3.20.1';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.disableSecurityWarning=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='SWXRN';
wng_pageInfo.ownerAffiliateId=parseInt('863',10);
wng_pageInfo.containerId=parseInt('37477688',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='Sport - Local';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/37477688/chiefs-cruise-past-americans-winning-6-3';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Chiefs cruise past Americans, winning 6-3';
wng_pageInfo.pageTitle='Chiefs cruise past Americans, winning 6-3 - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTag='SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffSWXRN';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - Local",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - Local",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - Local",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - Local",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - Local",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:300,height:150,wncc:"Sport - Local",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - Local",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["63"]={id:"63",wnsz:"63",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'inline',aff:'SWXRN'},width:300,height:600,wncc:"Sport - Local",parent:"WNAd63",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.adsettings={disableInitialLoad:true};</script>
<script type="text/javascript" src="http://SWXRN.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2018-01-10%2012%3A29%3A54_7.4.4-6"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/SWXRN.config.js?ver=7.3.20.1_7.4.4-6"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.3.20.1_7.4.4-6"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/swxrn/custom/swxrn_story_zoom.css" /><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel='alternate' type='application/rss+xml' title='Top Sports Headlines' href='http://www.swxrightnow.com/category/162885/publishing-category-top-stories?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='College Headlines' href='http://www.swxrightnow.com/category/162314/college?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Pro Headlines' href='http://www.swxrightnow.com/category/162313/pro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Prep Headlines' href='http://www.swxrightnow.com/category/160221/high-school-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington Sports' href='http://www.swxrightnow.com/category/50896/washington-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Idaho Sports' href='http://www.swxrightnow.com/category/50867/idaho-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington State' href='http://www.swxrightnow.com/category/162664/washington-state?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Univ. of Idaho' href='http://www.swxrightnow.com/category/162831/idaho?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Eastern Washington' href='http://www.swxrightnow.com/category/162663/ewu-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Gonzaga' href='http://www.swxrightnow.com/category/160218/gonzaga?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Central Washington' href='http://www.swxrightnow.com/category/192801/central-washington?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Whitworth' href='http://www.swxrightnow.com/category/174693/whitworth-university?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Shock' href='http://www.swxrightnow.com/category/160220/spokane-shock?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Chiefs' href='http://www.swxrightnow.com/category/162666/spokane-chiefs?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Americans' href='http://www.swxrightnow.com/category/115764/tri-city-americans?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Dust Devils' href='http://www.swxrightnow.com/category/145287/tri-city-dust-devils?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Yakima Bears' href='http://www.swxrightnow.com/category/108040/yakima-bears?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Seattle Mariners' href='http://www.swxrightnow.com/category/162830/seattle-mariners?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Hydro Insider' href='http://www.swxrightnow.com/category/78290/hydroinsidercom-unlimited-hydroplane-racing?clienttype=rss'><link rel='stylesheet' type='text/css' href='http://ftpcontent.worldnow.com/swxrn/custom/custom.css' /><script src="http://ftpcontent.worldnow.com/swxrn/custom/custom.js"></script><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><script src="//acdn.adnxs.com/prebid/c/7045/pb.js"></script></head><body id="WNAffSWXRN" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-55' ,"dma":'73' ,"group":'Cowles'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Chiefs cruise past Americans, winning 6-3 - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo_dark.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1641" class="wnMainMenu"><div class="wnHorizontal"><div class="wnStatic"><div class="wnMenuTypeImage"><ul class="wnLevel1" id="submenu1641"><li class="wnFirstNode" id="menu1641_1-C155145"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/"><img src="http://SWXRN.images.worldnow.com/images/499120_G.gif" width="49" height="38" border="0" alt="SWX Right Now.com" title="SWX Right Now.com" onsrc="http://SWXRN.images.worldnow.com/images/499121_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_1-C155145"><li class="wnFirstNode" id="menu1641_1_1-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_1_3-C163470"><span><a href="/category/163470/games-contests">Games &amp; Contests</a></span></li><li class="" id="menu1641_1_2-C220728"><span><a href="/category/220728/featured-slideshows">Featured Slideshows</a></span></li></ul></li><li class="" id="menu1641_2-C160216"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160216/scores"><img src="http://SWXRN.images.worldnow.com/images/499122_G.gif" width="97" height="38" border="0" alt="Scores" title="Scores" onsrc="http://SWXRN.images.worldnow.com/images/499123_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_2-C160216"><li class="wnFirstNode" id="menu1641_2_1-C161806"><span><a href="/category/161806/national-scores">National Scores</a></span></li><li class="" id="menu1641_2_2-C161807"><span><a href="/category/161807/college-scores">College Scores</a></span></li><li class="" id="menu1641_2_3-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_2_4-S9920984"><span><a href="/story/9920984/report-a-score">Report a Score</a></span></li></ul></li><li class="" id="menu1641_3-C162314"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162314/college"><img src="http://SWXRN.images.worldnow.com/images/499124_G.gif" width="65" height="38" border="0" alt="College" title="College" onsrc="http://SWXRN.images.worldnow.com/images/499125_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_3-C162314"><li class="wnFirstNode" id="menu1641_3_1-C162664"><span><a href="/category/162664/washington-state">WSU</a></span></li><li class="" id="menu1641_3_2-C160218"><span><a href="/category/160218/gonzaga">Gonzaga</a></span></li><li class="" id="menu1641_3_3-C162663"><span><a href="/category/162663/ewu-sports">EWU</a></span></li><li class="" id="menu1641_3_4-C174693"><span><a href="/category/174693/whitworth-university">Whitworth</a></span></li><li class="" id="menu1641_3_5-C162831"><span><a href="/category/162831/idaho">Idaho</a></span></li><li class="" id="menu1641_3_6-C267736"><span><a href="/category/267736/university-of-washington">Washington</a></span></li><li class="" id="menu1641_3_7-C192801"><span><a href="/category/192801/central-washington">CWU</a></span></li><li class="" id="menu1641_3_8-C262164"><span><a href="/category/262164/bobcats">Bobcats</a></span></li><li class="" id="menu1641_3_9-C262165"><span><a href="/category/262165/grizzlies">Grizzlies</a></span></li></ul></li><li class="" id="menu1641_4-C162313"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162313/pro"><img src="http://SWXRN.images.worldnow.com/images/499126_G.gif" width="36" height="38" border="0" alt="Pro" title="Pro" onsrc="http://SWXRN.images.worldnow.com/images/499127_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_4-C162313"><li class="wnFirstNode" id="menu1641_4_3-C272346"><span><a href="/category/272346/seattle-seahawks">Seattle Seahawks</a></span></li><li class="" id="menu1641_4_4-C162666"><span><a href="/category/162666/spokane-chiefs">Spokane Chiefs</a></span></li><li class="" id="menu1641_4_5-C160220"><span><a href="/category/160220/spokane-empire">Spokane Empire</a></span></li><li class="" id="menu1641_4_2-C193768"><span><a href="/category/193768/the-offseason">The Offseason</a></span></li><li class="" id="menu1641_4_1-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_5-C160221"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160221/high-school-sports"><img src="http://SWXRN.images.worldnow.com/images/499128_G.gif" width="96" height="38" border="0" alt="High School" title="High School" onsrc="http://SWXRN.images.worldnow.com/images/499129_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_5-C160221"><li class="wnFirstNode" id="menu1641_5_1-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_5_2-C318106"><span><a href="/category/318106/student-athlete">Student Athlete </a></span></li><li class="" id="menu1641_5_4-C162688"><span><a href="/category/162688/greater-spokane-league">Greater Spokane League</a></span></li><li class="" id="menu1641_5_5-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_5_3-C286972"><span><a href="/category/286972/prep-countdown">Prep Countdown</a></span></li></ul></li><li class="" id="menu1641_6-L654994"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://www.nwprepsnow.com"><img src="http://SWXRN.images.worldnow.com/images/4054557_G.png" width="140" height="38" border="0" alt="High School to NWPrepsNow.com" title="High School to NWPrepsNow.com" onsrc="http://SWXRN.images.worldnow.com/images/4054564_G.png"></a></span></span></span></span></li><li class="" id="menu1641_7-C160222"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160222/video-center"><img src="http://SWXRN.images.worldnow.com/images/499132_G.gif" width="102" height="38" border="0" alt="Video Center" title="Video Center" onsrc="http://SWXRN.images.worldnow.com/images/499133_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_7-C160222"><li class="wnFirstNode" id="menu1641_7_1-L375234"><span><a href="http://www.swxrightnow.com/global/category.asp?c=">All Video</a></span></li><li class="" id="menu1641_7_2-C162982"><span><a href="/category/162982/vc-college">College </a></span></li><li class="" id="menu1641_7_3-C162981"><span><a href="/category/162981/vc-pro">Pro </a></span></li><li class="" id="menu1641_7_4-C162980"><span><a href="/category/162980/vc-high-school">High School </a></span></li><li class="" id="menu1641_7_5-C162983"><span><a href="/category/162983/vc-gonzaga">Gonzaga </a></span></li><li class="" id="menu1641_7_6-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_7_7-C162984"><span><a href="/category/162984/vc-wsu">WSU</a></span></li><li class="" id="menu1641_7_8-C162986"><span><a href="/category/162986/vc-ewu">EWU</a></span></li><li class="" id="menu1641_7_9-C162987"><span><a href="/category/162987/vc-spokane-empire">VC - Spokane Empire</a></span></li></ul></li><li class="" id="menu1641_8-C155146"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather"><img src="http://SWXRN.images.worldnow.com/images/499134_G.gif" width="73" height="38" border="0" alt="Weather" title="Weather" onsrc="http://SWXRN.images.worldnow.com/images/499135_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_8-C155146"><li class="wnFirstNode" id="menu1641_8_1-C120835"><span><a href="/category/120835/road-pass-conditions">Road &amp; Pass Conditions</a></span></li><li class="" id="menu1641_8_2-S9962976"><span><a href="/story/9962976/radar-maps">Radar</a></span></li><li class="" id="menu1641_8_3-S9963255"><span><a href="/story/9963255/satellite-maps">Satellite</a></span></li><li class="" id="menu1641_8_4-S9974691"><span><a href="/story/9974691/school-closures-delays">School Closures &amp; Delays</a></span></li><li class="" id="menu1641_8_5-L524823"><span><a href="/link/524823/inland-northwest-ski-conditions">Ski Conditions</a></span></li></ul></li><li class="" id="menu1641_9-C160225"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160225/about-us"><img src="http://SWXRN.images.worldnow.com/images/499136_G.gif" width="76" height="38" border="0" alt="About Us" title="About Us" onsrc="http://SWXRN.images.worldnow.com/images/499137_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_9-C160225"><li class="wnFirstNode" id="menu1641_9_1-S9913533"><span><a href="/story/9913533/swx-contact-information">SWX Contact Information</a></span></li><li class="" id="menu1641_9_2-S9914380"><span><a href="/story/9914380/swx-on-tv">SWX on TV</a></span></li><li class="" id="menu1641_9_4-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_9_5-S9914228"><span><a href="/story/9914228/advertise-with-swx">Advertise with SWX</a></span></li><li class="" id="menu1641_9_3-S12164224"><span><a href="/story/12164224/closed-captioning-inquiries">Closed Captioning Inquiries</a></span></li><li class="" id="menu1641_9_6-S9914091"><span><a href="/story/9914091/jobs-at-swx">Jobs at SWX</a></span></li><li class="" id="menu1641_9_7-L376213"><span><a href="http://www.khq.com/">KHQ Right Now</a></span></li><li class="" id="menu1641_9_8-L376216"><span><a href="http://www.nbcrightnow.com/">NBC Right Now</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1641"></div></div></div></div><div id="spacermenu1641" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1641', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : true, level1Height : '38', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Chiefs cruise past Americans, winning 6-3</h3>
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnLeft" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://SWXRN.images.worldnow.com/images/16052108_G.jpg" alt="Photo: Spokane Chiefs" title="Photo: Spokane Chiefs" border="0" width="180">
<span>Photo: Spokane Chiefs</span></div><!--Start of Display Size: Headline Box - Col 3 (27)--><div class="wnBlock displaySize displaySizeId27 headlineBox" id="DisplaySizeId27"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Hockey</span><a class="wnContent more enabled" href="/category/13549/hockey"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature NewsAPNational story priority-1 odd displaySizeId-1 odd-1"><meta content="News - AP-National"><meta content="2018-02-11 11:24:56"><h4 class="wnContent headline"><a href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><span class="text">US women rally to beat Finland 3-1 in Olympics opener</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><span class="text">US women rally to beat Finland 3-1 in Olympics opener</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:57 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:57:26 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052732_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052732_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">The United States women's hockey team rallied to beat Finland 3-1 to remain perfect when opening an Olympic tournament.</span><a class="more" href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">The United States women's hockey team rallied to beat Finland 3-1 to remain perfect when opening an Olympic tournament.</span><a class="more" href="/story/37477948/us-women-rally-to-beat-finland-3-1-in-olympics-opener"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-2 even displaySizeId-1 even-1"><meta content="News - AP-National"><meta content="2018-02-11 01:03:01"><h4 class="wnContent headline"><a href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><span class="text">The Latest: Germany's Peiffer wins surprise gold in biathlon</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><span class="text">The Latest: Germany's Peiffer wins surprise gold in biathlon</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:57 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:57:18 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050666_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050666_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">The Pyeongchang Olympic men's downhill has been postponed until Thursday because of strong winds.</span><a class="more" href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">The Pyeongchang Olympic men's downhill has been postponed until Thursday because of strong winds.</span><a class="more" href="/story/37476757/the-latest-germanys-peiffer-wins-surprise-gold-in-biathlon"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-3 odd displaySizeId-1 odd-1"><meta content="News - AP-National"><meta content="2018-02-11 09:52:55"><h4 class="wnContent headline"><a href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><span class="text">Masked mystery man Ryan Zapolski is best hope for US medal</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><span class="text">Masked mystery man Ryan Zapolski is best hope for US medal</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:56 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:56:38 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052541_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052541_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Ryan Zapolski doesn't have the NHL experience of other Olympic goaltenders but is the United States' best chance to win a men's hockey medal.</span><a class="more" href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Ryan Zapolski doesn't have the NHL experience of other Olympic goaltenders but is the United States' best chance to win a men's hockey medal.</span><a class="more" href="/story/37477865/masked-mystery-man-ryan-zapolski-is-best-hope-for-us-medal"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-4 even displaySizeId-1 even-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-10 03:45:33"><h4 class="wnContent headline"><a href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><span class="text">What to watch from Pyeongchang -- Day 2</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><span class="text">What to watch from Pyeongchang -- Day 2</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:56 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:56:29 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16045672_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16045672_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Speed, tricks and big air: what to watch as competition in full force at Pyeongchang Olympics.</span><a class="more" href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Speed, tricks and big air: what to watch as competition in full force at Pyeongchang Olympics.</span><a class="more" href="/story/37473373/what-to-watch-from-pyeongchang-day-2"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-5 odd displaySizeId-1 odd-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-10 02:22:56"><h4 class="wnContent headline"><a href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><span class="text">Come visit: South Korea's leader invited to North Korea</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><span class="text">Come visit: South Korea's leader invited to North Korea</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:55 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:55:21 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16045204_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16045204_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">South Korean President Moon Jae-in is hosting lunch for senior North Korean officials including leader Kim Jong Un's sister in the most significant diplomatic encounter between the rivals in years.</span><a class="more" href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">South Korean President Moon Jae-in is hosting lunch for senior North Korean officials including leader Kim Jong Un's sister in the most significant diplomatic encounter between the rivals in years.</span><a class="more" href="/story/37473023/come-visit-south-koreas-leader-invited-to-north-korea"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-6 even displaySizeId-1 even-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-09 02:41:34"><h4 class="wnContent headline"><a href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><span class="text">The Latest: Spotlight on united Koreas in ceremony, on ice</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><span class="text">The Latest: Spotlight on united Koreas in ceremony, on ice</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 7:55 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 12:55:01 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16034420_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16034420_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">The Court of Arbitration for Sport has ruled that 45 Russian athletes who were excluded from the Pyeongchang Olympics over doping concerns can't compete.</span><a class="more" href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">The Court of Arbitration for Sport has ruled that 45 Russian athletes who were excluded from the Pyeongchang Olympics over doping concerns can't compete.</span><a class="more" href="/story/37464604/the-latest-spotlight-on-united-koreas-in-ceremony-on-ice"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-7 odd displaySizeId-1 odd-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-11 10:22:58"><h4 class="wnContent headline"><a href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><span class="text">Red alert: Gerard wins United States' 1st gold of games</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><span class="text">Red alert: Gerard wins United States' 1st gold of games</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 6:34 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 11:34:15 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052622_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052622_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Red Gerard won the United States' first gold medal of the games by overcoming a blustery win in the men's slopestyle event in the snowboarding competition on the second day of full competition at the Pyeongchang...</span><a class="more" href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Red Gerard won the United States' first gold medal of the games by overcoming a blustery win in the men's slopestyle event in the snowboarding competition on the second day of full competition at the Pyeongchang Olympics.</span><a class="more" href="/story/37477910/red-alert-gerard-wins-united-states-1st-gold-of-games"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-8 even displaySizeId-1 even-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-11 11:24:50"><h4 class="wnContent headline"><a href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><span class="text">Favored Russians ooze confidence, feel like 'red machine'</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><span class="text">Favored Russians ooze confidence, feel like 'red machine'</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 6:33 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 11:33:13 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052729_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16052729_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Super-talented Russia looks like the hands-down gold-medal favorite in men's hockey with defenseman Nikita Nesterov describing the team as a "red machine.".</span><a class="more" href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Super-talented Russia looks like the hands-down gold-medal favorite in men's hockey with defenseman Nikita Nesterov describing the team as a "red machine.".</span><a class="more" href="/story/37477945/favored-russians-ooze-confidence-feel-like-red-machine"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-9 odd displaySizeId-1 odd-1 collapsed"><meta content="News - AP-National"><meta content="2018-02-10 23:42:40"><h4 class="wnContent headline"><a href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><span class="text">Skating's Shibutanis make strike back at NBC's Andrea Joyce</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><span class="text">Skating's Shibutanis make strike back at NBC's Andrea Joyce</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 4:43 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 09:43:37 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050020_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050020_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">NBC's television coverage of the opening ceremonies reached 27.8 million on the TV network, and a total of 28.3 million when digital followers are added.</span><a class="more" href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">NBC's television coverage of the opening ceremonies reached 27.8 million on the TV network, and a total of 28.3 million when digital followers are added.</span><a class="more" href="/story/37476437/skatings-shibutanis-make-strike-back-at-nbcs-andrea-joyce"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-10 even displaySizeId-1 even-1 collapsed last"><meta content="News - AP-National"><meta content="2018-02-11 00:23:11"><h4 class="wnContent headline"><a href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><span class="text">Johnson shares the lead at Pebble Beach</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><span class="text">Johnson shares the lead at Pebble Beach</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, February 11 2018 3:46 AM EST</span><span class="wnContent timestamp gmttime">2018-02-11 08:46:45 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050335_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16050335_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Dustin Johnson tied for the lead as he goes for 3rd victory at Pebble Beach.</span><a class="more" href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Dustin Johnson tied for the lead as he goes for 3rd victory at Pebble Beach.</span><a class="more" href="/story/37476605/johnson-shares-the-lead-at-pebble-beach"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId27');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 3 (27)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated left"><p><em>By Spokane Chiefs </em></p><p><strong>KENNEWICK. Wash. &ndash;</strong> Forwards Jaret Anderson-Dolan and Kailer Yamamoto piled up five points apiece in a 6-3 win over the rival Tri-City Americans on Saturday night in Kennewick. The victory wrapped up a seven-game road swing for the Chiefs, during which they posted a 5-0-2-0 record and vaulted to third place in the U.S. Division.</p><p>Yamamoto, with a goal and four assists, was in on the first five of Spokane&rsquo;s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points. It marked his second career five-point game after he filled&nbsp; the same statline (1G-4A) at Kootenay under two weeks ago on Feb. 2.</p><p>Anderson-Dolan, whose second goal of an eventual hat trick proved to be the game-winner, also scored the game&rsquo;s first and last goals, sealing the win with an empty-netter late. He assisted on the Chiefs&rsquo; second (Ty Smith on a power play) and fifth goals (Kailer Yamamoto) to pick up the first five-point effort of his three-year WHL career. His first goal was also his 30th of the season,&nbsp;marking the first Chief to reach the milestone during the 2017-18 campaign. The hat trick was the third by a Chief this season, joining forwards Jake McGrew and Milos Fafrak.&nbsp;<strong> </strong></p><div class="embed-related"><div class="embed-related-content"><div class="embed-related__title"><strong>Related Links </strong></div><div class="embed-related-list"><strong><a class="embed-related-list__item" href="http://bit.ly/2Bje4iu">Box Score: SPO (6) vs. T.C. (3) </a> </strong></div></div></div><p></p><p>Ethan McIndoe and Smith each scored once and added two helpers for three-point nights to round out the offense for Spokane.</p><p>After Anderson-Dolan&rsquo;s first of the game at 6:01 of the first, Tri-City responded to take a 2-1 lead into the first intermission and outshot the Chiefs 12-3 through 20 minutes.</p><p>Spokane responded in force, outshooting the Americans 12-5 in the middle frame and scoring two goals to take a 3-2 lead into the second break.</p><p>The Chiefs continued to take advantage of their opportunities in the third period, scoring three goals on just four shots on goal as they clogged the neutral zone to maintain the lead and secure the tough road victory.</p><p>Spokane has now earned at least a point in 10-straight games, going 8-0-2-0 over that span.</p><p>Dawson Weatherill started in goal for the Chiefs and turned aside 25 of 28 shots faced for his 18th win of the year. Beck Warm started for the Americans and made 13 saves on 18 shots faced. Spokane went 2-for-5 on the power play and 4-for-5 on the penalty kill, with Tri-City&rsquo;s power play goal coming on a 5-on-3.</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><!--Start of Display Size:  (7)--><div class="wnBlock displaySize displaySizeId7 nestedCategory" id="DisplaySizeId7"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Pro Sports</span><span class="text abridgedHeadline">Pro</span><a class="wnContent more enabled" href="/category/162313/pro"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportLocal story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - Local"><meta content="2018-02-11 06:32:00"><h4 class="wnContent headline"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">Chiefs cruise past Americans, winning 6-3</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">Chiefs cruise past Americans, winning 6-3</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16052108_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16052108_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Yamamoto, with a goal and four assists, was in on the first five of Spokane&rsquo;s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points.</p></span><a class="more" href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Yamamoto, with a goal and four assists, was in on the first five of Spokane&rsquo;s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points.</p></span><a class="more" href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NFL"><meta content="2018-02-08 00:39:26"><h4 class="wnContent headline"><a href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><span class="text">Yankees acquire Seahawks QB Russell Wilson in trade with Rangers</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><span class="text">Yankees acquire Seahawks QB Russell Wilson in trade with Rangers</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16004857_G.png" title="Photo: Seattle Seahawks" alt="Photo: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Photo: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16004857_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>&quot;I&nbsp;want to personally thank the Texas Rangers and Jon Daniels for drafting me and giving me the chance to experience professional baseball again.&rdquo;</p></span><a class="more" href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>&quot;I&nbsp;want to personally thank the Texas Rangers and Jon Daniels for drafting me and giving me the chance to experience professional baseball again.&rdquo;</p></span><a class="more" href="/story/37453887/yankees-acquire-seahawks-qb-russell-wilson-in-trade-with-rangers"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport"><meta content="2018-02-04 00:44:05"><h4 class="wnContent headline"><a href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><span class="text">Former Vandal Kramer gets NFL Hall call</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><span class="text">Former Vandal Kramer gets NFL Hall call</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15972167_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15972167_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Idaho Vandal great Jerry Kramer's long-awaited invitation to the Hall of Fame is finally over.&nbsp; The former Green Bay Packers guard earned enshrinement into the Pro Football Hall of Fame on Saturday.&nbsp;</p></span><a class="more" href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Idaho Vandal great Jerry Kramer's long-awaited invitation to the Hall of Fame is finally over.&nbsp; The former Green Bay Packers guard earned enshrinement into the Pro Football Hall of Fame on Saturday.&nbsp;</p></span><a class="more" href="/story/37421547/former-vandal-kramer-gets-nfl-hall-call"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NFL"><meta content="2018-01-30 23:58:43"><h4 class="wnContent headline"><a href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><span class="text">Bobby Wagner and Tyler Lockett make NFL.com's All-Pro teams</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><span class="text">Bobby Wagner and Tyler Lockett make NFL.com's All-Pro teams</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15939765_G.png" title="Photo: Seattle Seahawks" alt="Photo: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Photo: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15939765_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>A Seahawks player was represented on each of the respective teams with linebacker <strong><a class="player" href="http://www.seahawks.com/team/players/roster/bobby-wagner">Bobby Wagner</a></strong> making Wesseling's with two other players and wide receiver <strong><a class="player" href="http://www.seahawks.com/team/players/roster/tyler-lockett">Tyler Lockett</a></strong> making Harmon's as a kick returner.</p></span><a class="more" href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A Seahawks player was represented on each of the respective teams with linebacker <strong><a class="player" href="http://www.seahawks.com/team/players/roster/bobby-wagner">Bobby Wagner</a></strong> making Wesseling's with two other players and wide receiver <strong><a class="player" href="http://www.seahawks.com/team/players/roster/tyler-lockett">Tyler Lockett</a></strong> making Harmon's as a kick returner.</p></span><a class="more" href="/story/37388146/bobby-wagner-and-tyler-lockett-make-nflcoms-all-pro-teams"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="General001"><meta content="2018-01-30 04:50:55"><h4 class="wnContent headline"><a href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><span class="text">Billings' Austin Cardwell Takes Bronze at X Games</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><span class="text">Billings' Austin Cardwell Takes Bronze at X Games</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, January 29 2018 11:50 PM EST</span><span class="wnContent timestamp gmttime">2018-01-30 04:50:55 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/15932126_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/15932126_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>In the first ever X Games snow hillclimb, Austin Cardwell made Billings proud.</p></span><a class="more" href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>In the first ever X Games snow hillclimb, Austin Cardwell made Billings proud.</p></span><a class="more" href="/story/37378613/billings-austin-cardwell-takes-bronze-at-x-games"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-28 07:02:08"><h4 class="wnContent headline"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">Chiefs fall in overtime to Americans, 5-4</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">Chiefs fall in overtime to Americans, 5-4</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15920613_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15920613_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Tri City&rsquo;s Dylan Coglan scored his third goal of the game 1:14 into overtime to lift the Tri City Americans to a 5-4 come from behind win over the Spokane Chiefs.</p></span><a class="more" href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Tri City&rsquo;s Dylan Coglan scored his third goal of the game 1:14 into overtime to lift the Tri City Americans to a 5-4 come from behind win over the Spokane Chiefs.</p></span><a class="more" href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportMLB story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - MLB"><meta content="2018-01-25 01:06:39"><h4 class="wnContent headline"><a href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><span class="text">Edgar Martinez falls just short of Hall of Fame in 2018</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><span class="text">Edgar Martinez falls just short of Hall of Fame in 2018</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15898505_G.jpg" title="Photo: Seattle Mariners" alt="Photo: Seattle Mariners"></a><span class="caption left width180"><span class="text">Photo: Seattle Mariners</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15898505_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Martinez, who is about to begin his third year as hitting coach for the only team he played for in his 18-year career, was named on 70.4 percent of the 422 ballots cast by Baseball Writers' Association of America voters.</p></span><a class="more" href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Martinez, who is about to begin his third year as hitting coach for the only team he played for in his 18-year career, was named on 70.4 percent of the 422 ballots cast by Baseball Writers' Association of America voters.</p></span><a class="more" href="/story/37344026/edgar-martinez-falls-just-short-of-hall-of-fame-in-2018"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNBA story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NBA"><meta content="2018-01-25 00:17:24"><h4 class="wnContent headline"><a href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><span class="text">Domantas Sabonis to play in Rising Stars Challenge at All-Star Weekend</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><span class="text">Domantas Sabonis to play in Rising Stars Challenge at All-Star Weekend</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15898084_G.jpg" title="Photo: Indiana Pacers" alt="Photo: Indiana Pacers"></a><span class="caption left width180"><span class="text">Photo: Indiana Pacers</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15898084_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Sabonis is the Pacers' leading rebounder this season at 8.4 rebounds per game and is averaging 12.3 points per game.</p></span><a class="more" href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Sabonis is the Pacers' leading rebounder this season at 8.4 rebounds per game and is averaging 12.3 points per game.</p></span><a class="more" href="/story/37343785/domantas-sabonis-to-play-in-rising-stars-challenge-at-all-star-weekend"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-24 06:55:44"><h4 class="wnContent headline"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">Chiefs complete sweep with win over Broncos, 4-2</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">Chiefs complete sweep with win over Broncos, 4-2</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15891429_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15891429_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Chiefs held Swift Current forward Aleksi Heponiemi without a point, snapping the star forward&rsquo;s 28-game point streak.</p></span><a class="more" href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Chiefs held Swift Current forward Aleksi Heponiemi without a point, snapping the star forward&rsquo;s 28-game point streak.</p></span><a class="more" href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NFL"><meta content="2018-01-24 00:48:28"><h4 class="wnContent headline"><a href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><span class="text">Seahawks Duane Brown named to Pro Bowl roster</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><span class="text">Seahawks Duane Brown named to Pro Bowl roster</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15889289_G.png" title="Photo: Seattle Seahawks" alt="Photo: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Photo: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15889289_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>Brown replaces Philadelphia Eagles tackle Lane Johnson, who is unable to play in the Pro Bowl because the Eagles are in the Super Bowl.&nbsp;</p></span><a class="more" href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Brown replaces Philadelphia Eagles tackle Lane Johnson, who is unable to play in the Pro Bowl because the Eagles are in the Super Bowl.&nbsp;</p></span><a class="more" href="/story/37334043/seahawks-duane-brown-named-to-pro-bowl-roster"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId7');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size:  (7)--><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd63" class="wnad wnad63">
<script>wnad_63.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Spokane Chiefs</span><span class="text abridgedHeadline">Spokane Chiefs</span><a class="wnContent more enabled" href="/category/162666/spokane-chiefs"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportLocal story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - Local"><meta content="2018-02-11 06:32:00"><h4 class="wnContent headline"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">Chiefs cruise past Americans, winning 6-3</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">Chiefs cruise past Americans, winning 6-3</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/16052108_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/16052108_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Yamamoto, with a goal and four assists, was in on the first five of Spokane&rsquo;s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points.</p></span><a class="more" href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Yamamoto, with a goal and four assists, was in on the first five of Spokane&rsquo;s six goals, pushing him into a tie with Trent Whitfield for 11th place in franchise history with 269 points.</p></span><a class="more" href="/story/37477688/chiefs-cruise-past-americans-winning-6-3"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-2 even displaySizeId-20 even-20"><meta content="Sport - Local"><meta content="2018-01-28 07:02:08"><h4 class="wnContent headline"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">Chiefs fall in overtime to Americans, 5-4</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">Chiefs fall in overtime to Americans, 5-4</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15920613_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15920613_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Tri City&rsquo;s Dylan Coglan scored his third goal of the game 1:14 into overtime to lift the Tri City Americans to a 5-4 come from behind win over the Spokane Chiefs.</p></span><a class="more" href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Tri City&rsquo;s Dylan Coglan scored his third goal of the game 1:14 into overtime to lift the Tri City Americans to a 5-4 come from behind win over the Spokane Chiefs.</p></span><a class="more" href="/story/37366606/chiefs-fall-in-overtime-to-americans-5-4"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - Local"><meta content="2018-01-24 06:55:44"><h4 class="wnContent headline"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">Chiefs complete sweep with win over Broncos, 4-2</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">Chiefs complete sweep with win over Broncos, 4-2</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15891429_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15891429_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Chiefs held Swift Current forward Aleksi Heponiemi without a point, snapping the star forward&rsquo;s 28-game point streak.</p></span><a class="more" href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Chiefs held Swift Current forward Aleksi Heponiemi without a point, snapping the star forward&rsquo;s 28-game point streak.</p></span><a class="more" href="/story/37335668/chiefs-complete-sweep-with-win-over-broncos-4-2"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-18 06:41:02"><h4 class="wnContent headline"><a href="/story/37291047/chiefs-blank-wheat-kings-3-0"><span class="text">Chiefs blank Wheat Kings 3-0</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37291047/chiefs-blank-wheat-kings-3-0"><span class="text">Chiefs blank Wheat Kings 3-0</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37291047/chiefs-blank-wheat-kings-3-0"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15849042_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37291047/chiefs-blank-wheat-kings-3-0"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15849042_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Goaltender <strong>Bailey Brkin</strong> secured his first career WHL shutout while forwards <strong>Kailer Yamamoto</strong> and <strong>Ethan McIndoe</strong> each picked up two points in the win.</p></span><a class="more" href="/story/37291047/chiefs-blank-wheat-kings-3-0"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Goaltender <strong>Bailey Brkin</strong> secured his first career WHL shutout while forwards <strong>Kailer Yamamoto</strong> and <strong>Ethan McIndoe</strong> each picked up two points in the win.</p></span><a class="more" href="/story/37291047/chiefs-blank-wheat-kings-3-0"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-18 00:09:27"><h4 class="wnContent headline"><a href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><span class="text">Ty Smith named captain of Team Orr for Top Prospects Game</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><span class="text">Ty Smith named captain of Team Orr for Top Prospects Game</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15846428_G.jpg" title="Smith was the Chiefs' 1st pick in 2015 WHL Bantam Draft" alt="Smith was the Chiefs' 1st pick in 2015 WHL Bantam Draft"></a><span class="caption left width180"><span class="text">Smith was the Chiefs' 1st pick in 2015 WHL Bantam Draft</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15846428_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Smith was originally selected by the Chiefs with the first overall pick in the 2015 WHL Bantam Draft before earning the team&rsquo;s 2016-17 Rookie of the Year.</p></span><a class="more" href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Smith was originally selected by the Chiefs with the first overall pick in the 2015 WHL Bantam Draft before earning the team&rsquo;s 2016-17 Rookie of the Year.</p></span><a class="more" href="/story/37289266/ty-smith-named-captain-of-team-orr-for-top-prospects-game"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-14 06:42:57"><h4 class="wnContent headline"><a href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><span class="text">Chiefs fall short against Silvertips, 5-2</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><span class="text">Chiefs fall short against Silvertips, 5-2</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15819152_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15819152_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p><strong>&nbsp;</strong>The Spokane Chiefs fell to the Everett Silvertips on Saturday night by a score of 5-2 as they completed a stretch of four games in five nights.</p></span><a class="more" href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p><strong>&nbsp;</strong>The Spokane Chiefs fell to the Everett Silvertips on Saturday night by a score of 5-2 as they completed a stretch of four games in five nights.</p></span><a class="more" href="/story/37261854/chiefs-fall-short-against-silvertips-5-2"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-11 07:05:22"><h4 class="wnContent headline"><a href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><span class="text">Rockets score 7 goals in victory over Chiefs</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><span class="text">Rockets score 7 goals in victory over Chiefs</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15798517_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15798517_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Kelowna Rockets erased a 3-2 Spokane lead with 3 unanswered goals on their way to a 7-4 win over the Chiefs Wednesday night in Kelowna, B.C.</p></span><a class="more" href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Kelowna Rockets erased a 3-2 Spokane lead with 3 unanswered goals on their way to a 7-4 win over the Chiefs Wednesday night in Kelowna, B.C.</p></span><a class="more" href="/story/37241078/rockets-score-7-goals-in-victory-over-chiefs"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - Local"><meta content="2018-01-06 04:04:24"><h4 class="wnContent headline"><a href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><span class="text">Yamamoto & Americans earn Bronze, Kral & Czechs fourth at WJC</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><span class="text">Yamamoto & Americans earn Bronze, Kral & Czechs fourth at WJC</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15765179_G.jpg" title="Photo: Spokane Chiefs" alt="Photo: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15765179_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Spokane native and Edmonton Oilers draft pick finished the tournament with 2 goals and 2 assists, a +3 rating and 16 SOG.</p></span><a class="more" href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Spokane native and Edmonton Oilers draft pick finished the tournament with 2 goals and 2 assists, a +3 rating and 16 SOG.</p></span><a class="more" href="/story/37204777/yamamoto-americans-earn-bronze-kral-czechs-fourth-at-wjc"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - Local"><meta content="2017-12-18 07:27:47"><h4 class="wnContent headline"><a href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><span class="text">Thunderbirds stomp Chiefs 10-3 before holiday break</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><span class="text">Thunderbirds stomp Chiefs 10-3 before holiday break</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15649676_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15649676_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Spokane Chiefs, in their third game in as many nights, fell to the Seattle Thunderbirds on Sunday at Spokane Arena by a score of 10-3.</p></span><a class="more" href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Spokane Chiefs, in their third game in as many nights, fell to the Seattle Thunderbirds on Sunday at Spokane Arena by a score of 10-3.</p></span><a class="more" href="/story/37087568/thunderbirds-stomp-chiefs-10-3-before-holiday-break"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport"><meta content="2017-12-16 06:19:21"><h4 class="wnContent headline"><a href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><span class="text">Chiefs end Everett's nine game win streak</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><span class="text">Chiefs end Everett's nine game win streak</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15643484_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15643484_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The&nbsp;Spokane Chiefs pulled out the victory in back-and-forth game against the Everett Silvertips on Friday night, snapping Everett&rsquo;s nine-game winning streak. Carolina Hurricanes prospect Hudson Elynuik led the way offensively with two goals &ndash; including the game-winner &ndash; and an assist.</p></span><a class="more" href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The&nbsp;Spokane Chiefs pulled out the victory in back-and-forth game against the Everett Silvertips on Friday night, snapping Everett&rsquo;s nine-game winning streak. Carolina Hurricanes prospect Hudson Elynuik led the way offensively with two goals &ndash; including the game-winner &ndash; and an assist.</p></span><a class="more" href="/story/37081318/chiefs-end-everetts-nine-game-win-streak"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://SWXRN.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText">All content &copy; Copyright  2000  - 2018 SWXRN. All Rights Reserved.<BR>For more information on this site, please read  our <A HREF='/story/18990/this-web-sites-privacy-policy'  >Privacy Policy</a>, and <A HREF='/story/18991/this-sites-terms-of-service'  >Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.</div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E")); </script> <script type="text/javascript"> try { var pageTracker = _gat._getTracker("UA-15497971-2"); pageTracker._trackPageview(); } catch(err) {}</script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>