<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9jzm6dt" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9jzm6dt";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Eagles to play Southern Utah in Big Sky Conference matchup - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</title>
<meta name="Description" content="After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0. "><meta name="KEYWORDS" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="news_keywords" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/10/20"><meta name="owner" content="SWXRN"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="7.3.18.1"><meta name="wn-base" content="IIS19"><meta name="wnreadableurl" content="eagles-to-play-southern-utah-in-big-sky-conference-matchup"><meta property="og:title" content="Eagles to play Southern Utah in Big Sky Conference matchup"><meta property="og:type" content="article"><meta property="og:url" content="http://www.swxrightnow.com/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><meta property="og:image" content="http://SWXRN.images.worldnow.com/images/15211019_G.jpg"><meta property="og:description" content="After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0. "><link rel="canonical" href="http://www.swxrightnow.com/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Eagles to play Southern Utah in Big Sky Conference matchup"><meta name="twitter:description" content="After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0. "><meta name="twitter:image" content="http://SWXRN.images.worldnow.com/images/15211019_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:page_id" content="130847515832" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.3.18.1_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://SWXRN.images.worldnow.com/interface/css/container-e.css?ver=2017-09-09%2011%3A43%3A19_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_7.3.18.1" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.3.18.1"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.3.18.1"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.3.18.1"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1641 UL
                    , #menu1641 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641 A,
                    #menu1641 LI.wnOn .wnSublevel A,
                    #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641
                        .wnLevel1, #menu1641
                        .wnLevel1 LI { height: 38px; }
                            #menu1641 .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu1641 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu1641 LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1641 .wnSublevel { background-color: #d5d5d5;  }
                #menu1641 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu1641 > .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel { width: 978px; }
                    #menu1641 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu1641 .wnLeft { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu1641 LI.wnOn .wnLeft { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1641 .wnRight { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu1641 LI.wnOn .wnRight { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1641 .wnRight .wnMiddle { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1641 LI.wnOn .wnMiddle { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu1641 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu1641 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'SWXRN',
            affiliateId : '863',
            baseUrl : 'www.swxrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '64',mdPartnerDomain : 'http://dub.swxrightnow.com'},
            registrationId : '557063',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://SWXRN.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.3.18.1';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='SWXRN';
wng_pageInfo.ownerAffiliateId=parseInt('863',10);
wng_pageInfo.containerId=parseInt('36647943',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='Sport - NCAA-Football';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Eagles to play Southern Utah in Big Sky Conference matchup';
wng_pageInfo.pageTitle='Eagles to play Southern Utah in Big Sky Conference matchup - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTag='SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffSWXRN';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NCAA-Football",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NCAA-Football",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NCAA-Football",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NCAA-Football",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NCAA-Football",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:300,height:150,wncc:"Sport - NCAA-Football",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NCAA-Football",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["63"]={id:"63",wnsz:"63",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'inline',aff:'SWXRN'},width:300,height:600,wncc:"Sport - NCAA-Football",parent:"WNAd63",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.adsettings={disableInitialLoad:true};</script>
<script type="text/javascript" src="http://SWXRN.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-09-09%2011%3A43%3A19_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/SWXRN.config.js?ver=7.3.18.1_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.3.18.1_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/swxrn/custom/swxrn_story_zoom.css" /><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel='alternate' type='application/rss+xml' title='Top Sports Headlines' href='http://www.swxrightnow.com/category/162885/publishing-category-top-stories?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='College Headlines' href='http://www.swxrightnow.com/category/162314/college?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Pro Headlines' href='http://www.swxrightnow.com/category/162313/pro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Prep Headlines' href='http://www.swxrightnow.com/category/160221/high-school-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington Sports' href='http://www.swxrightnow.com/category/50896/washington-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Idaho Sports' href='http://www.swxrightnow.com/category/50867/idaho-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington State' href='http://www.swxrightnow.com/category/162664/washington-state?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Univ. of Idaho' href='http://www.swxrightnow.com/category/162831/idaho?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Eastern Washington' href='http://www.swxrightnow.com/category/162663/ewu-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Gonzaga' href='http://www.swxrightnow.com/category/160218/gonzaga?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Central Washington' href='http://www.swxrightnow.com/category/192801/central-washington?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Whitworth' href='http://www.swxrightnow.com/category/174693/whitworth-university?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Shock' href='http://www.swxrightnow.com/category/160220/spokane-shock?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Chiefs' href='http://www.swxrightnow.com/category/162666/spokane-chiefs?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Americans' href='http://www.swxrightnow.com/category/115764/tri-city-americans?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Dust Devils' href='http://www.swxrightnow.com/category/145287/tri-city-dust-devils?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Yakima Bears' href='http://www.swxrightnow.com/category/108040/yakima-bears?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Seattle Mariners' href='http://www.swxrightnow.com/category/162830/seattle-mariners?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Hydro Insider' href='http://www.swxrightnow.com/category/78290/hydroinsidercom-unlimited-hydroplane-racing?clienttype=rss'><link rel='stylesheet' type='text/css' href='http://ftpcontent.worldnow.com/swxrn/custom/custom.css' /><script src="http://ftpcontent.worldnow.com/swxrn/custom/custom.js"></script><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><script src="//acdn.adnxs.com/prebid/c/7045/pb.js"></script></head><body id="WNAffSWXRN" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-55' ,"dma":'73' ,"group":'Cowles'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Eagles to play Southern Utah in Big Sky Conference matchup - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo_dark.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1641" class="wnMainMenu"><div class="wnHorizontal"><div class="wnStatic"><div class="wnMenuTypeImage"><ul class="wnLevel1" id="submenu1641"><li class="wnFirstNode" id="menu1641_1-C155145"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/"><img src="http://SWXRN.images.worldnow.com/images/499120_G.gif" width="49" height="38" border="0" alt="SWX Right Now.com" title="SWX Right Now.com" onsrc="http://SWXRN.images.worldnow.com/images/499121_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_1-C155145"><li class="wnFirstNode" id="menu1641_1_1-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_1_5-C163470"><span><a href="/category/163470/games-contests">Games &amp; Contests</a></span></li><li class="" id="menu1641_1_4-C208947"><span><a href="/category/208947/extra-points">Extra Points</a></span></li><li class="" id="menu1641_1_2-C284880"><span><a href="/category/284880/swx-podcasts">SWX Podcast</a></span></li><li class="" id="menu1641_1_3-C220728"><span><a href="/category/220728/featured-slideshows">Featured Slideshows</a></span></li></ul></li><li class="" id="menu1641_2-C160216"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160216/scores"><img src="http://SWXRN.images.worldnow.com/images/499122_G.gif" width="97" height="38" border="0" alt="Scores" title="Scores" onsrc="http://SWXRN.images.worldnow.com/images/499123_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_2-C160216"><li class="wnFirstNode" id="menu1641_2_1-C161806"><span><a href="/category/161806/national-scores">National Scores</a></span></li><li class="" id="menu1641_2_2-C161807"><span><a href="/category/161807/college-scores">College Scores</a></span></li><li class="" id="menu1641_2_3-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_2_4-S9920984"><span><a href="/story/9920984/report-a-score">Report a Score</a></span></li></ul></li><li class="" id="menu1641_3-C162314"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162314/college"><img src="http://SWXRN.images.worldnow.com/images/499124_G.gif" width="65" height="38" border="0" alt="College" title="College" onsrc="http://SWXRN.images.worldnow.com/images/499125_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_3-C162314"><li class="wnFirstNode" id="menu1641_3_1-C162664"><span><a href="/category/162664/washington-state">WSU</a></span></li><li class="" id="menu1641_3_2-C160218"><span><a href="/category/160218/gonzaga">Gonzaga</a></span></li><li class="" id="menu1641_3_3-C162663"><span><a href="/category/162663/ewu-sports">EWU</a></span></li><li class="" id="menu1641_3_4-C174693"><span><a href="/category/174693/whitworth-university">Whitworth</a></span></li><li class="" id="menu1641_3_5-C162831"><span><a href="/category/162831/idaho">Idaho</a></span></li><li class="" id="menu1641_3_6-C267736"><span><a href="/category/267736/university-of-washington">Washington</a></span></li><li class="" id="menu1641_3_7-C192801"><span><a href="/category/192801/central-washington">CWU</a></span></li><li class="" id="menu1641_3_8-C262164"><span><a href="/category/262164/bobcats">Bobcats</a></span></li><li class="" id="menu1641_3_9-C262165"><span><a href="/category/262165/grizzlies">Grizzlies</a></span></li></ul></li><li class="" id="menu1641_4-C162313"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162313/pro"><img src="http://SWXRN.images.worldnow.com/images/499126_G.gif" width="36" height="38" border="0" alt="Pro" title="Pro" onsrc="http://SWXRN.images.worldnow.com/images/499127_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_4-C162313"><li class="wnFirstNode" id="menu1641_4_3-C272346"><span><a href="/category/272346/seattle-seahawks">Seattle Seahawks</a></span></li><li class="" id="menu1641_4_4-C162666"><span><a href="/category/162666/spokane-chiefs">Spokane Chiefs</a></span></li><li class="" id="menu1641_4_5-C160220"><span><a href="/category/160220/spokane-empire">Spokane Empire</a></span></li><li class="" id="menu1641_4_6-C284681"><span><a href="/category/284681/montana-pro-sports">Pro Sports</a></span></li><li class="" id="menu1641_4_2-C193768"><span><a href="/category/193768/the-offseason">The Offseason</a></span></li><li class="" id="menu1641_4_1-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_5-C160221"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160221/high-school-sports"><img src="http://SWXRN.images.worldnow.com/images/499128_G.gif" width="96" height="38" border="0" alt="High School" title="High School" onsrc="http://SWXRN.images.worldnow.com/images/499129_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_5-C160221"><li class="wnFirstNode" id="menu1641_5_1-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_5_2-C318106"><span><a href="/category/318106/student-athlete">Student Athlete </a></span></li><li class="" id="menu1641_5_4-C162688"><span><a href="/category/162688/greater-spokane-league">Greater Spokane League</a></span></li><li class="" id="menu1641_5_5-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_5_6-C284683"><span><a href="/category/284683/montana-high-school-sports">High School Sports</a></span></li><li class="" id="menu1641_5_3-C286972"><span><a href="/category/286972/prep-countdown">Prep Countdown</a></span></li></ul></li><li class="" id="menu1641_6-L654994"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://www.nwprepsnow.com"><img src="http://SWXRN.images.worldnow.com/images/4054557_G.png" width="140" height="38" border="0" alt="High School to NWPrepsNow.com" title="High School to NWPrepsNow.com" onsrc="http://SWXRN.images.worldnow.com/images/4054564_G.png"></a></span></span></span></span></li><li class="" id="menu1641_7-C160222"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160222/video-center"><img src="http://SWXRN.images.worldnow.com/images/499132_G.gif" width="102" height="38" border="0" alt="Video Center" title="Video Center" onsrc="http://SWXRN.images.worldnow.com/images/499133_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_7-C160222"><li class="wnFirstNode" id="menu1641_7_1-L375234"><span><a href="http://www.swxrightnow.com/global/category.asp?c=">All Video</a></span></li><li class="" id="menu1641_7_2-C162982"><span><a href="/category/162982/vc-college">College </a></span></li><li class="" id="menu1641_7_3-C162981"><span><a href="/category/162981/vc-pro">Pro </a></span></li><li class="" id="menu1641_7_4-C162980"><span><a href="/category/162980/vc-high-school">High School </a></span></li><li class="" id="menu1641_7_5-C162983"><span><a href="/category/162983/vc-gonzaga">Gonzaga </a></span></li><li class="" id="menu1641_7_6-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_7_7-C162984"><span><a href="/category/162984/vc-wsu">WSU</a></span></li><li class="" id="menu1641_7_8-C162986"><span><a href="/category/162986/vc-ewu">EWU</a></span></li><li class="" id="menu1641_7_9-C162987"><span><a href="/category/162987/vc-spokane-empire">VC - Spokane Empire</a></span></li></ul></li><li class="" id="menu1641_8-C155146"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather"><img src="http://SWXRN.images.worldnow.com/images/499134_G.gif" width="73" height="38" border="0" alt="Weather" title="Weather" onsrc="http://SWXRN.images.worldnow.com/images/499135_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_8-C155146"><li class="wnFirstNode" id="menu1641_8_1-C120835"><span><a href="/category/120835/road-pass-conditions">Road &amp; Pass Conditions</a></span></li><li class="" id="menu1641_8_2-S9962976"><span><a href="/story/9962976/radar-maps">Radar</a></span></li><li class="" id="menu1641_8_3-S9963255"><span><a href="/story/9963255/satellite-maps">Satellite</a></span></li><li class="" id="menu1641_8_4-S9974691"><span><a href="/story/9974691/school-closures-delays">School Closures &amp; Delays</a></span></li><li class="" id="menu1641_8_5-L524823"><span><a href="/link/524823/inland-northwest-ski-conditions">Ski Conditions</a></span></li></ul></li><li class="" id="menu1641_9-C160225"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160225/about-us"><img src="http://SWXRN.images.worldnow.com/images/499136_G.gif" width="76" height="38" border="0" alt="About Us" title="About Us" onsrc="http://SWXRN.images.worldnow.com/images/499137_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_9-C160225"><li class="wnFirstNode" id="menu1641_9_1-S9913533"><span><a href="/story/9913533/swx-contact-information">SWX Contact Information</a></span></li><li class="" id="menu1641_9_2-S9914380"><span><a href="/story/9914380/swx-on-tv">SWX on TV</a></span></li><li class="" id="menu1641_9_4-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_9_5-S9914228"><span><a href="/story/9914228/advertise-with-swx">Advertise with SWX</a></span></li><li class="" id="menu1641_9_3-S12164224"><span><a href="/story/12164224/closed-captioning-inquiries">Closed Captioning Inquiries</a></span></li><li class="" id="menu1641_9_6-S9914091"><span><a href="/story/9914091/jobs-at-swx">Jobs at SWX</a></span></li><li class="" id="menu1641_9_7-L376213"><span><a href="http://www.khq.com/">KHQ Right Now</a></span></li><li class="" id="menu1641_9_8-L376216"><span><a href="http://www.nbcrightnow.com/">NBC Right Now</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1641"></div></div></div></div><div id="spacermenu1641" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1641', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : true, level1Height : '38', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Eagles to play Southern Utah in Big Sky Conference matchup</h3>
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnLeft" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://SWXRN.images.worldnow.com/images/15211019_G.jpg" alt="Photo: EWU Athletics" title="Photo: EWU Athletics" border="0" width="180">
<span>Photo: EWU Athletics</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated left"><p><em>By Eastern Washington Athletics </em></p><p>It's a short history, but it's been a challenging one for the Eastern Washington University football team against Southern Utah.<br />&nbsp;<br />In yet another important Big Sky Conference game in October versus the Thunderbirds, No. 8 Eastern travels to Cedar City this Saturday (Oct. 21) for a 4:05 p.m. Pacific match-up with SUU, which will be looking for its second-straight victory and third overall against a ranked opponent.<br />&nbsp;<br />The game will be Eastern's first-ever game televised by Eleven Sports (www.elevensports.com), with national and international coverage provided by the London-based network. Fans can watch the webcast via Pluto TV and watchbigsky.com. Fans can also listen to the game on 700-AM ESPN, 105.3-FM, via the web at tunein.com and via mobile phone app, with pre-game coverage starting one hour prior to kickoff.<br />&nbsp;<br />After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0. Winners of their last 12 league games &ndash; two shy of the school record -- the Eagles have won 44 of their last 49 Big Sky games since a 0-2 start in 2011. That feat has been bettered only by Montana on a pair of occasions in the 54-year history of the league.<br />&nbsp;<br />With a&nbsp; 2-0 record against ranked teams in the NCAA Football Championship Subdivision, Southern Utah is 4-2 overall and 2-1 in the league after last week's convincing 32-16 road win at No. 16 Weber State. The Thunderbirds beat teams from the Southland (Stephen F. Austin, 51-14) and Missouri Valley (No. 18 Northern Iowa, 24-21) in the preseason, and opened Big Sky play with a loss to Sacramento State (54-27) and win over Cal Poly (20-14).<br />&nbsp;<br />&quot;They don't beat themselves &ndash; they don't turn the ball over and on defense they cause turnovers,&quot; said Eastern head coach <strong><a href="http://goeags.com/coaches.aspx?rc=112" id="sidearmAd2" rel="smarttag">Aaron Best</a></strong>. &quot;They make you try to beat them, because they are not going to themselves out of position. They are very sound defensively and very balanced offensively. It's going to be a tough test.&quot;<br />&nbsp;<br />The Eagles and Thunderbirds are 6-1 in league play thus far with four of those victories coming against five teams currently joining the EWU and SUU in the top seven in the league standings at 2-2 or better (five victories versus teams in the top eight).<br />&nbsp;<br />Eastern has gone into Cedar City with lofty national rankings before, but have had a difficult time pulling out wins. In the most recent meeting, back in 2014, Eastern was ranked second in FCS and trailed 14-7 before pulling away late for a 42-30 win. Two years earlier, Eastern was No. 1 in the nation but fell 30-27. During EWU's season-ending 11-game winning streak en route to the 2010 FCS title, Eastern scored the winning points with 3:39 to play to barely edge the Thunderbirds 31-24 at home. Eastern is 6-2 overall in the short series dating back to 1998, and is just 3-2 in Cedar City.<br />&nbsp;<br />&quot;They are always a tough opponent, and are an even tougher team at home,&quot; said Best, whose been a part of all eight previous meetings as either an EWU player or assistant coach. &quot;They showed how good they are by beating both Northern Iowa and doubling-up Weber State in Ogden. It's hard to win on the road, and it's even harder to win that decisively on the road in this league.&quot;<br />&nbsp;<br />With a five-game winning streak, EWU has moved up to eighth in this week's STATS FCS Top-25 rankings. Eastern is also rated eighth this week by the coaches. Southern Utah received enough votes this week to rank 32nd by STATS and 32nd by the coaches. North Dakota State is No. 2 in both polls, behind defending FCS champion James Madison. Eastern has now been ranked by STATS in 78 of its last 79 polls, and in the top 10 in 19 of the last 21. Eastern had its streak of being in the top 10 snapped at 15 after losing at home 40-13 to the Bison on Sept. 9.<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>EWU-Southern Utah Game Notes</u></strong></h2><p>&nbsp;<br />&nbsp;<strong><u>Eagles Have Third Down Magic Versus Bobcats</u></strong><br />&nbsp;<br />The Eagles were an impressive 11-of-14 on third down against Montana State on Oct. 14, and averaged 9.0 yards on that down alone. Quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd3" rel="smarttag">Gage Gubrud</a></strong> had a hand in seven of the conversions &ndash; rushes of 8, 12 and 13 yards, and passes of 12, 6, 10 and 12 yards. On his way to a 147-yard rushing day, running back <strong><a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd4" rel="smarttag">Antoine Custer Jr.</a>&nbsp; </strong>had three of them on rushes of 14, 10 and 1 yards. On the three that Eastern didn't convert, a 9-yard pass by Gubrud set-up a short field goal, a Custer 3-yard run led to a punt and a 22-yard pass by Gubrud on a third-and-26 play led to his 7-yard rush on fourth down that led to EWU's game-clinching touchdown with 3:09 to play.<br />&nbsp;<br />&nbsp;<br /><strong><u>After Just 20 Career Starts, Gubrud Already Up To Fourth in EWU Career Passing Yards</u></strong><br />&nbsp;<br />Junior quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd5" rel="smarttag">Gage Gubrud</a> </strong>is now 16-4 in 20 games as an Eastern starter, and has played in just 24 career games. During Eastern's current five -game winning streak, Gubrud has 2,071 passing yards (414.2 average per game) while completing 69 percent of his passes. He has thrown for 19 touchdowns and accounted for another four (three rushing, one receiving). In his best five-game stretch a year ago, he completed 69 percent of his passes for 2,160 yards (432.0 average) and 20 touchdowns in five victories from Sept. 24 to Oct. 29.<br />&nbsp;<br />His recent production has moved him up to No. 4 in school history in career passing yards with 7,638, ranking only behind 10,000-yard passers Matt Nichols (12,616), Vernon Adams Jr. (10,438) and Erik Meyer (10,261). He is also fourth in total offense with 8,378, ranking behind Nichols (13,308), Adams (11,670) and Meyer (10,942). If he were to play 15 more games in his career (four this year and 11 as a senior), he would have to average 332 passing yards and 329 yards of total offense to break the school and Big Sky records set by Nichols from 2006-09.<br />&nbsp;<br />After setting three FCS, seven Big Sky marks and 18 school records in the 2016 season, Gubrud now seeks to maintain a pair of career marks. After 24 games in his career (16-4 in 20 games as a starter), he remains the Eastern career leader in passing yards per game (318.2), completion percentage (.666) and total offense per game (349.1). He is also fifth in touchdown passes (68, two from No. 4 held by Bo Levi Mitchell with 70 from 2010-11).<br />&nbsp;<br />Gubrud now has a school-record nine 400-yard passing performances in his career, two more than Adams Jr. with seven. He has had back-to-back-to-back 400-yard performances on three occasions, and Adams, <a href="http://goeags.com/roster.aspx?rp_id=4614" id="sidearmAd6" rel="smarttag">Jordan West</a> and Matt Nichols are the only other quarterbacks in EWU history to have accomplished that feat two times in a row.<br />&nbsp;<br />Gubrud already owns seven of the top nine single game total offense performances in school history (1-2-3-4-6-7-9) and six of the top 15 passing performances (1-2-4-7-14-15). In addition, he had an impressive string of 222 passes without an interception in 2016, going four full games in 2016 from Sept. 24 to Oct. 22 without a pick. He had what was then a school-record 551 yards of total offense in the first start of his career, a 45-42 season-opening victory over Washington State of the Pac-12 Conference.<br />&nbsp;<br />&nbsp;<br /><strong><u>Custer Has Most Rushing Yards for an Eagle in 29 Games</u></strong><br />&nbsp;<br />Sophomore running back <strong><a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd7" rel="smarttag">Antoine Custer Jr.</a> </strong>had a career-best 147 rushing yards and two touchdowns in EWU's 31-19 victory over Montana State on Oct. 14. It was the second 100-yard game of his career, eclipsing the 141 he had as a true freshman in 2016 against Idaho State. His rushing yards were the most for an Eagle in 29 games since <a href="http://goeags.com/roster.aspx?rp_id=4618" id="sidearmAd8" rel="smarttag">Jabari Wilson</a> had 188 versus Montana State early in the 2015 season. He had 45 yards and a 2-yard touchdown in the opening quarter, 52 in the second quarter, 33 in the third and then 43 and a game-clinching 3-yard TD run in the fourth.<br />&nbsp;<br />For the season, Custer leads EWU with 410 rushing yards and five touchdowns, and has also caught 13 passes for 208 yards and two scores. In his 20-game career (12 as a starter), he has 826 yards on the ground, 395 receiving and 434 on kickoff returns for a total of 1,655 all-purpose yards (82.8 per game). As a true freshman in 2016, he finished his debut season with 977 all-purpose yards and a pair of Big Sky Conference Player of the Week accolades for his kickoff returning prowess. He averaged 26.7 yards on 14 kickoff returns with a touchdown. Custer started at running back in six games, including Eastern's opener against Washington State, and scored the first touchdown of the season for the Eagles on a pass from Gubrud.<br />&nbsp;<br />&nbsp;<br /><strong><u>Hometown Product Has 31 Tackles in Last Three Games</u></strong><br />&nbsp;<br />Junior defensive end <strong><a href="http://goeags.com/roster.aspx?rp_id=4932" id="sidearmAd9" rel="smarttag">Keenan Williams</a></strong> finished with nine tackles, a key fumble recovery in the fourth quarter and a quarterback hurry in EWU's 31-19 win over Montana State on Oct. 14. Trailing just 24-19 in the fourth quarter, Montana State recovered its second EWU fumble within a 2 1/2 minute span in the fourth quarter, taking over at the EWU 25 yard line. However, two plays later, the Bobcats fumbled and Williams recovered for EWU with 8:52 to play in the game. The Eagles turned that into a game-clinching 13-play, 78-yard TD drive that took 5:43 off the clock. The hurry for Williams came on a second down play on MSU's last possession of the game, a possession which ended with an interception by EWU's <strong><a href="http://goeags.com/roster.aspx?rp_id=4871" id="sidearmAd10" rel="smarttag">Victor Gamboa</a></strong> with 2:01 remaining.<br />&nbsp;<br />Eastern held the Bobcats to 353 yards of total offense, including 218 rushing and 135 passing. Bobcat quarterback Chris Murray had a 54-yard touchdown run, but finished with only 88 rushing yards and 135 through the air. Thus, outside his long run, he averaged only 4.7 yards per play. Murray, the Big Sky Conference Freshman of the Year last season, entered the game with a team-leading 543 yards (108.6 per game to lead the league) and three touchdowns, and had passed for another 646 and eight scores. The Bobcats entered 10th in FCS in rushing, averaging 250.6 yards per game.<br />&nbsp;<br />The performance by Williams &ndash; a 2015 graduate of Cheney, Wash., High School -- came after back-to-back weeks in which he had a career highs for tackles with 12 (UC Davis) and 10 (Sacramento State). He now has 44 tackles for the season to rank third on the team and first among EWU defensive linemen. He also has 1 1/2 sacks and a pair of quarterback hurries to go along with his fumble recovery. In his 29-game career (16 as a starter), he has 105 tackles with 4 1/2 sacks.<br />&nbsp;<br />&nbsp;<br /><strong><u>Eagle Offense Has Been Prolific Beyond Compare</u></strong><br />&nbsp;<br />After starting the season 0-2, Eastern has won its last five games by a combined 228-150 scoring margin (average score of 45-30), with scores of 56-21 (Fordham), 48-41 (Montana), 52-31 (Sacramento State), 41-38 (UC Davis) and 31-19 (Montana State). Eastern's 2,870 yards of total offense in that stretch &ndash; 574.0 per game &ndash; has never been matched in school history. The Eagles have averaged 45.6 points and have 2,114 passing yards (422.8 per game) during the winning streak, which are just short of EWU's five-game stretch a year ago when the Eagles had 238 points (47.6 average) and 2,214 passing yards (442.8). The 2016 team had 2,825 total yards in those five victories (565.0). Here is how the 2017 and 2016 teams compare:<br />&nbsp;<br /><strong><em>Year &ndash; Opponent &ndash; Points &ndash; Total Yards &ndash; Passing Yards</em></strong><br />2017 - Fordham &ndash; 56 &ndash; 650 &ndash; 399<br />2017 &ndash; Montana &ndash; 48 &ndash; 617 &ndash; 549<br />2017 &ndash; Sac State &ndash; 52 &ndash; 651 &ndash; 490<br />2018 &ndash; UC Davis &ndash; 41 &ndash; 501 &ndash; 452<br />2019 &ndash; Montana St. &ndash; 31 &ndash; 451 &ndash; 224<br /><strong>5-Game Totals &ndash; 228 &ndash; 2870 &ndash; 2114</strong><br /><strong>Averages &ndash; 45.6 &ndash; 574.0 &ndash; 422.8</strong><br />&nbsp;<br />2016 &ndash; Northern Ariz. &ndash; 50 &ndash; 540 &ndash; 392<br />2016 &ndash; UC Davis &ndash; 63 &ndash; 627 &ndash; 486<br />2016 &ndash; Northern Colo. &ndash; 49 &ndash; 659 &ndash; 435<br />2016 &ndash; Montana State &ndash; 41 &ndash; 596 &ndash; 520<br />2016 &ndash; Montana &ndash; 35 &ndash; 403 &ndash; 381<br /><strong>5-Game Totals &ndash; 238 &ndash; 2825 &ndash; 2214</strong><br /><strong>Averages &ndash; 47.6 &ndash; 565.0 &ndash; 442.8</strong><br />&nbsp;<br />&nbsp;<br /><strong><u>Offense Back Near the Top in FCS Statistics</u></strong><br />&nbsp;<br />Averaging 574 yards of offense in its last five outings, Eastern's offense now ranks in the top nine in passing and total offense. Eastern is fourth in passing (352.6 per game) and ninth in total offense (482.1), and is also 16th in scoring (35.9). Quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd11" rel="smarttag">Gage Gubrud</a></strong> is leading FCS in touchdown passes (20) and points responsible for (152). He had only one TD pass in his first two games, but has had 19 in the five games since. He is also second in FCS in total passing yards (2,412), third in points responsible for per game (21.7), fourth in passing yards per game (344.6) and fourth in total offense per game (359.3). A year ago he led FCS in both passing and total offense (368.6 and 411.0, respectively). <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd12" rel="smarttag">Nic Sblendorio</a> </strong>is 10th in FCS with an average of 7.4 catches per game (52 total) and 48th in yards (72.1 per game). <strong><a href="http://goeags.com/roster.aspx?rp_id=4928" id="sidearmAd13" rel="smarttag">Nsimba Webster</a></strong> is 15th in receptions (6.6) and 39th in yards (76.3)<br />&nbsp;<br />Eastern's kickoff return unit has long been impressive, and so far this year the Eagles and <strong><a href="http://goeags.com/roster.aspx?rp_id=4864" id="sidearmAd14" rel="smarttag">Dre' Sonte Dorton</a></strong> are leading the way. With two returns of 51 yards and others of 49 and 38 this season, Dorton has averaged 25.6 yards on 16 returns to rank 19th in the NCAA Football Championship Subdivision, while the team is 13th at 24.22 per return. In addition, Eastern is 38th in net punting (36.94) and <strong><a href="http://goeags.com/roster.aspx?rp_id=4861" id="sidearmAd15" rel="smarttag">Jordan Dascalo</a> </strong>is 32nd in average per punt (41.0).<br />&nbsp;<br />Defensively, Eastern is 32nd in sacks at 2.57 per game, with <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd16" rel="smarttag">Albert Havili</a></strong> ranking 42nd nationally and third in the league with an average of 0.71 per game (total of five). Safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd17" rel="smarttag">Mitch Fettig</a></strong> has averaged 9.6 tackles per game thus far (total of 67) to rank 25th nationally and seventh in the Big Sky.<br />&nbsp;<br />Besides Dorton, Eastern has some other top-notch returners back from a year ago. Last year as a true freshman, <strong><a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd18" rel="smarttag">Antoine Custer Jr.</a> </strong>averaged 26.7 yards on 14 kickoff returns with a touchdown, with long returns of 93, 55 and 35 yards. Teammate <strong><a href="http://goeags.com/roster.aspx?rp_id=4928" id="sidearmAd19" rel="smarttag">Nsimba Webster</a> </strong>had a 65-yard return against UC Davis, but broke his clavicle in the process. Webster had a 25.3 average per return, and EWU's 21.7 average as a team ranked fourth in the Big Sky and 25th nationally. Eastern has returned 18 kickoffs for touchdowns in the past 21 seasons and 19 punts for scores in the same time span (1996 through 2016).<br />&nbsp;<br />&nbsp;<br /><strong><u>Eagles Have Impressive 44-5 Big Sky Record Since 0-2 Start in 2011 </u></strong><br />&nbsp;<br />Winners of their last 12 league games, the Eagles have won 44 of their last 49 Big Sky games since a 0-2 start in 2011. The only Big Sky school which has come close to that in the 54-year history of the league was Montana, which won 50 of 55 games from 1995-2002 and 46 of 51 from 2003-2009.<br />&nbsp;<br />&nbsp;Eastern has won 34 of its last 38 league games, with the lone losses coming against Montana and Portland State in 2015 and Northern Arizona in both 2015 and 2014. An Oct. 25, 2014, loss at Northern Arizona snapped EWU's school-record 14-game conference winning streak and a home loss against the Lumberjacks on Nov. 7, 2015, ended a streak of eight Big Sky wins in a row. The two teams do not play in the 2017 season, but currently are a combined 7-0 in the league.<br />&nbsp;<br />Including non-conference victories (two versus MSU and one against Cal Poly) and a playoff win (Montana), the Eagles have won 38 of their last 42 versus conference foes, and are 48-6 since the 0-2 start in 2011. Including three wins at the end of the 2009 season, Eastern has a 54-9 record in league games since then.<br />&nbsp;<br />What's perhaps most impressive about the winning streaks is Eastern's ability to consistently win on the road. The Eagles have now won its previous road game versus all 13 other league members, as well a 2012 road victory at Idaho, which will join the league next year. Eastern still faces challenges to that accomplishment this season at Southern Utah (Oct. 21) and North Dakota (Nov. 11).<br />&nbsp;<br />As a result, head coach Beau Baldwin left Eastern with a 58-14 Big Sky record for a winning percentage of .806 to rank as the fifth-best in league history. His .726 winning percentage overall (85-32) is seventh all-time in the 53-year history of the Big Sky.<br />&nbsp;<br />&nbsp;<br /><strong><u>Eagles Have Now Won 23 Games Since 2010 When Trailing or Tied in Fourth Quarter</u></strong><br />&nbsp;<br />Eastern has now won 23 games since 2010 when trailing or tied in the fourth quarter, including two this season, two in 2016 and 2015, one in 2014, two in 2013, six in 2012, two in 2011 and six during EWU's national championship season in 2010<br />&nbsp;<br />Three of the 23 comebacks have been against Montana, including Eagle victories in 2017 (48-41), 2012 (32-26) and 2010 (36-27). Earlier this year, No. 11 Eastern trailed 24-6 at halftime but scored 42 points in the second half to stun the Grizzlies. In the second half, Eastern scored on touchdowns on five of its six possessions, and had a dominating 259-68 yardage advantage in the third quarter. After knotting the game at 27 and 34, Eastern took the lead for good on a tie-breaking 3-yard TD pass from <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd20" rel="smarttag">Gage Gubrud</a></strong> to <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd21" rel="smarttag">Nic Sblendorio</a></strong> with 6:53 left. Eastern expanded it to 48-34 on a 10-yard TD run by <a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd22" rel="smarttag">Antoine Custer Jr.</a> with 2:12 to play. The defense did its part by recording three key stops in the fourth quarter Gubrud broke his own school record with a 549-yard passing performance, finishing with four touchdowns through the air and one on the ground. His 560 yards of offense were also a record, as he eclipsed his own previous records of 520 passing and 551 total yards. The 549 team passing yards were also a school record, breaking the previous mark of 526 set in 2015 versus Northern Iowa.<br />&nbsp;<br />At UC Davis on Oct. 7, No. 10 Eastern rallied from an 11-point deficit in the fourth quarter by scoring 21 points in the period and went on to win a heart-stopping 41-38 victory over the Aggies at Davis, Calif. <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd23" rel="smarttag">Gage Gubrud</a></strong> engineered scoring drives of 71, 55 and 75 yards in the final quarter, and finished with six touchdown passes and 452 yards passing. He passed 6 yards to <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd24" rel="smarttag">Nic Sblendorio</a></strong> for a game-winning TD with 1:37 to play, followed by a missed 49-yard field goal by the Aggies that could have knotted the game. Gubrud passed for 452 yards and six touchdowns in the win.<br />&nbsp;<br />&nbsp;<br /><strong><u>Eastern Now 40-0 Since 2010 When Winning the TO Battle</u></strong><br />&nbsp;<br />The Eagles had their first turnover advantages of the 2017 season against Sacramento State on Sept. 30 and Montana State on Oct. 14. The Eagles had three fumble recoveries and an interception against a Bobcats team that had just four turnovers in its first five games, including only one fumble and no fumbles lost. Versus Sac State, the Hornets had entered the game leading FCS with 10 interceptions, but EWU had none while recording one defensively by senior safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4879" id="sidearmAd25" rel="smarttag">Jake Hoffman</a>. </strong>Sac State entered the game fifth in FCS with a +2.0 turnover margin per game, while EWU was -2.0 and ranked 119th out of 123 FCS schools. Prior to that, EWU had lost the turnover battle 3-0 versus Texas Tech, tying North Dakota State 2-2, finishing with a 5-1 deficit against Fordham and losing the battle against Montana 2-1. Eastern had two turnovers and forced none at UC Davis on Oct. 14.<br />&nbsp;<br />In the last nine-plus seasons, the Eagles are now 49-1 when they've won the turnover battle, 21-6 when they've been tied and 20-27 when they've lost (total of 90-34). The last time EWU lost when it won the turnover battle came in the 2009 FCS Playoffs at Stephen F. Austin when EWU had two miscues and forced four in the 44-33 loss. Thus, EWU is 40-0 since 2010 when they've won the turnover battle, 18-5 when they've been tied and 18-20 when they've lost. That's a collective record of 76-25 (75 percent), with 20 of those 25 losses (80 percent) coming in games EWU has lost the turnover battle and 53 percent of EWU's wins coming when they've won the turnover battle (77 percent when including ties).<br />&nbsp;<br />After going six games without winning the turnover battle in 2016 (including the first three), Eastern had turnover advantages in six of its last 12 games, including a 7-1 advantage in its two playoff victories. The Eagles had a dominating 5-1 advantage over Richmond, and one game earlier had a 2-0 advantage over Central Arkansas. But EWU lost the turnover battle 2-1 to Youngstown State, as EWU finished the season 6-0 when it won the turnover battle, 2-2 when it lost and 4-0 when it was tied.<br />&nbsp;<br />&nbsp;<br /><strong><u>Challenging Schedule Proving to Be Just That</u></strong><br />&nbsp;<br />Eastern's three non-conference foes in 2017 are so far 10-8, including a pair of victories over the Eagles. North Dakota State leads the way at 6-0, Texas Tech is 4-2 and Fordham is 1-6. Those three foes combined to win 68 percent of their games overall in 2016 (25-12), 65 percent in league play (15-8) and 67 percent in the postseason (2-1). By contrast, Eastern's non-conference opponents in 2016 were 31-11 overall the year before for 74 percent, 18-7 in league play (72 percent) and 7-1 in the postseason (88 percent). The Eagles emerged from that gauntlet with a 2-1 record.<br />&nbsp;<br />After finishing a perfect 8-0 in league play a year ago, Eastern's eight Big Sky Conference foes this coming season combined for a 40-50 record overall and 30-34 league mark in 2016. Two of the opponents &ndash; North Dakota and Weber State &ndash; advanced to the FCS Playoffs and were a collective 16-8 on the season and 14-2 in the Big Sky.<br />&nbsp;<br />&nbsp;<br /><strong><u>Depth Helps Eagles Win Five Straight Despite Injuries to Eight Starters </u></strong><br />&nbsp;<br />As a testament of Eastern's outstanding depth, Eastern won their fifth-straight game against Montana State on Oct. 14 despite playing without eight injured players who have started this season (combined 25 starts). A pair have been lost for the year (seven starts), with five (18 starts) expected to return at some point &ndash; tight end <strong><a href="http://goeags.com/roster.aspx?rp_id=4851" id="sidearmAd26" rel="smarttag">Henderson Belk</a></strong>, safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4879" id="sidearmAd27" rel="smarttag">Jake Hoffman</a></strong>, wide receiver <strong><a href="http://goeags.com/roster.aspx?rp_id=4873" id="sidearmAd28" rel="smarttag">Terence Grady</a></strong>, defensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4898" id="sidearmAd29" rel="smarttag">Andre Lino</a></strong> and offensive guard <strong><a href="http://goeags.com/roster.aspx?rp_id=4905" id="sidearmAd30" rel="smarttag">Matt Meyer</a></strong>. Out indefinitely is senior cornerback <strong><a href="http://goeags.com/roster.aspx?rp_id=4927" id="sidearmAd31" rel="smarttag">D'londo Tucker</a></strong>, who was injured at Montana on Sept. 23 and has 57 total tackles, three interceptions, a sack and 12 passes broken up in his 35-game career (nine as a starter).<br />&nbsp;<br />As a result, opportunities have been given to numerous Eagles to assume starting roles in recent weeks, including nose tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4894" id="sidearmAd32" rel="smarttag">Dylan Ledbetter</a></strong>, safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4911" id="sidearmAd33" rel="smarttag">Tysen Prunty</a></strong>, true freshman defensive back <strong><a href="http://goeags.com/roster.aspx?rp_id=4829" id="sidearmAd34" rel="smarttag">Anfernee Gurley</a></strong>, offensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4924" id="sidearmAd35" rel="smarttag">Brett Thompson</a> </strong>and wide receivers <strong><a href="http://goeags.com/roster.aspx?rp_id=4866" id="sidearmAd36" rel="smarttag">Zach Eagle</a> </strong>and <strong><a href="http://goeags.com/roster.aspx?rp_id=4931" id="sidearmAd37" rel="smarttag">Jayson Williams</a></strong>. In addition, linebacker <strong><a href="http://goeags.com/roster.aspx?rp_id=4918" id="sidearmAd38" rel="smarttag">Jack Sendelbach</a> </strong>replaced the injured <strong><a href="http://goeags.com/roster.aspx?rp_id=4892" id="sidearmAd39" rel="smarttag">Ketner Kupp</a></strong> in the starting lineup for the first three games.<br />&nbsp;<br />Eastern previously announced that starting nose tackle and 2016 first team All-Big Sky Conference performer <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd40" rel="smarttag">Jay-Tee Tiuli</a></strong> underwent surgery in late September and will miss the remainder of the 2017 season. However, he has not redshirted, so he will be able to return for his senior season in 2018 as an injury redshirt. Tiuli has played in 36 career games (11 as a starter), and has had 77 total tackles with 8 1/2 sacks, three quarterback hurries and two passes deflected. He earned third team preseason All-America honors from stats, and first team all-league accolades from College Sports Madness.<br />&nbsp;<br />Previously, starting offensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4895" id="sidearmAd41" rel="smarttag">Kaleb Levao</a> </strong>was lost for the remainder of the season as well. Actual injuries suffered by players are not disclosed.<br />&nbsp;<br />&nbsp;<br /><strong><u>First Starts of Careers Made by Nine Eagles in First Seven Games</u></strong><br />&nbsp;<br />The most recent starting debut for the Eagles this season came against Montana State on Oct. 14 when sophomore <strong><a href="http://goeags.com/roster.aspx?rp_id=4911" id="sidearmAd42" rel="smarttag">Tysen Prunty</a> </strong>started at safety in place of injured senior <strong><a href="http://goeags.com/roster.aspx?rp_id=4879" id="sidearmAd43" rel="smarttag">Jake Hoffman</a></strong>. Prunty finished his debut with a career-high seven tackles versus the Bobcats.<br />&nbsp;<br />Previously, two debuts were made against UC Davis on Oct. 7 when true freshman <strong><a href="http://goeags.com/roster.aspx?rp_id=4829" id="sidearmAd44" rel="smarttag">Anfernee Gurley</a></strong> made this first start of his career as an extra defensive back and running back <strong><a href="http://goeags.com/roster.aspx?rp_id=4902" id="sidearmAd45" rel="smarttag">Sam McPherson</a> </strong>started at running back. In his first series as a starter, McPherson gathered in a 40-yard touchdown pass. Gurley finished with a career-high nine tackles.<br />&nbsp;<br />One game earlier versus Sacramento State on Sept. 30, sophomore <strong><a href="http://goeags.com/roster.aspx?rp_id=4931" id="sidearmAd46" rel="smarttag">Jayson Williams</a> </strong>made his first start when EWU began with a four receiver set. He had three catches for 74 yards, including 59-yarder in the first quarter that set-up Eastern's first touchdown of the day in the 52-31 win.<br />&nbsp;<br />Redshirt freshman offensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4924" id="sidearmAd47" rel="smarttag">Brett Thompson</a> </strong>saw significant action at Fordham, then the 2016 graduate of Olympia (Wash.) High School made the first start of his career in Eastern's come-from-behind 48-41 victory against Montana. Starting offensive guard <strong><a href="http://goeags.com/roster.aspx?rp_id=4905" id="sidearmAd48" rel="smarttag">Matt Meyer</a></strong> has been injured and out since playing sparingly versus Fordham, and previously <strong><a href="http://goeags.com/roster.aspx?rp_id=4895" id="sidearmAd49" rel="smarttag">Kaleb Levao</a></strong> was lost for the season with a knee injury. The result was three different starting offensive lines in three games (NDSU, Fordham and Montana), with three players starting multiple positions (<strong><a href="http://goeags.com/roster.aspx?rp_id=4923" id="sidearmAd50" rel="smarttag">Tristen Taylor</a>, <a href="http://goeags.com/roster.aspx?rp_id=4917" id="sidearmAd51" rel="smarttag">Chris Schlichting</a></strong> and <strong><a href="http://goeags.com/roster.aspx?rp_id=4881" id="sidearmAd52" rel="smarttag">Jack Hunter</a></strong>).<br />&nbsp;<br />Junior tight end <strong><a href="http://goeags.com/roster.aspx?rp_id=4851" id="sidearmAd53" rel="smarttag">Henderson Belk</a></strong> was listed as a starter against Texas Tech, but EWU began with four wide receivers instead. Belk, though, made his starting debut one game later versus North Dakota State. Against Fordham on Sept. 16, sophomore defensive nose tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4894" id="sidearmAd54" rel="smarttag">Dylan Ledbetter</a></strong> made the first start of his career as an injury replacement for <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd55" rel="smarttag">Jay-Tee Tiuli</a></strong>, who has also now been lost for the season. Ledbetter, whose father, Mark, lettered as a linebacker at Washington State from 1986-89, had a career-high eight tackles and two of EWU's 10 sacks. He entered the game with 34 tackles and 2 1/2 sacks in his previous 16 games as an Eagle. Also, junior wide receiver <strong><a href="http://goeags.com/roster.aspx?rp_id=4866" id="sidearmAd56" rel="smarttag">Zach Eagle</a> </strong>made his first start as an Eagle wide receiver against Fordham and caught a pass for 14 yards and had two punt returns.<br />&nbsp;<br />When EWU played at Texas Tech on Sept. 2, a total of 21 of 22 starters hit the field with starting experience under their belts. Six full-time starters returned on each side of the ball, plus all of the team's specialists from a year ago. An additional five starters on offense and four on defense had previously started for the Eagles. The lone starting debut came on defense when sophomore <strong><a href="http://goeags.com/roster.aspx?rp_id=4918" id="sidearmAd57" rel="smarttag">Jack Sendelbach</a> </strong>started in place of injured <strong><a href="http://goeags.com/roster.aspx?rp_id=4892" id="sidearmAd58" rel="smarttag">Ketner Kupp</a></strong> on defense.<br />&nbsp;<br />Eight freshman redshirts made their Eastern debuts against Texas Tech on Sept. 2 &ndash; <strong><a href="http://goeags.com/roster.aspx?rp_id=4849" id="sidearmAd59" rel="smarttag">Eric Barriere</a>, <a href="http://goeags.com/roster.aspx?rp_id=4897" id="sidearmAd60" rel="smarttag">Talolo Limu-Jones</a>, <a href="http://goeags.com/roster.aspx?rp_id=4858" id="sidearmAd61" rel="smarttag">Calin Criner</a>, <a href="http://goeags.com/roster.aspx?rp_id=4907" id="sidearmAd62" rel="smarttag">Keith Moore</a></strong>, <strong><a href="http://goeags.com/roster.aspx?rp_id=4900" id="sidearmAd63" rel="smarttag">Rudolph Mataia Jr.</a>, <a href="http://goeags.com/roster.aspx?rp_id=4924" id="sidearmAd64" rel="smarttag">Brett Thompson</a>, <a href="http://goeags.com/roster.aspx?rp_id=4855" id="sidearmAd65" rel="smarttag">Nicholas Blair</a></strong> and <strong><a href="http://goeags.com/roster.aspx?rp_id=4859" id="sidearmAd66" rel="smarttag">Conner Crist</a></strong>. Three true freshmen made their debuts in an Eastern uniform, including <strong><a href="http://goeags.com/roster.aspx?rp_id=4829" id="sidearmAd67" rel="smarttag">Anfernee Gurley</a></strong>, <strong><a href="http://goeags.com/roster.aspx?rp_id=4827" id="sidearmAd68" rel="smarttag">Johnny Edwards IV</a></strong> and <strong><a href="http://goeags.com/roster.aspx?rp_id=4840" id="sidearmAd69" rel="smarttag">Chris Ojoh</a>. </strong>Three other true freshmen were on Eastern's travel squad and did not play -- quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4838" id="sidearmAd70" rel="smarttag">Nick Moore</a></strong>, cornerback <strong><a href="http://goeags.com/roster.aspx?rp_id=4828" id="sidearmAd71" rel="smarttag">Ira Branch</a></strong>, and wide receiver <strong><a href="http://goeags.com/roster.aspx?rp_id=4826" id="sidearmAd72" rel="smarttag">Andrew Boston</a></strong>. They remain redshirts, as well as junior defensive end <strong><a href="http://goeags.com/roster.aspx?rp_id=4926" id="sidearmAd73" rel="smarttag">Jim Townsend</a>.</strong><br />&nbsp;<br />In addition, <strong><a href="http://goeags.com/coaches.aspx?rc=112" id="sidearmAd74" rel="smarttag">Aaron Best</a></strong> made his head coaching debut versus the Red Raiders. It came versus the same team former head coach Beau Baldwin made his EWU head coaching debut against back on Aug. 30, 2008, in a 49-24 Red Raider victory. Interestingly, Best is a 1996 graduate of Curtis High School in Tacoma, Wash., and Baldwin graduated from the same school six years earlier. Best was making his debut as Baldwin's offensive line coach in that 2008 game.<br />&nbsp;<br />The UC Davis game on Oct. 7 was the 250th game for <a href="http://goeags.com/coaches.aspx?rc=112" id="sidearmAd75" rel="smarttag">Aaron Best</a> associated with the Eastern football program. Now in his 21st year as either a player or a coach, his current total of 251 games have yielded a 164-87 record for 65 percent.<br />&nbsp;<br />&nbsp;<br /><strong><u>Career Starts</u></strong><br />&nbsp;<br />Defense (236 starts by 20 players): <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd76" rel="smarttag">Mitch Fettig</a></strong> 29, <strong><a href="http://goeags.com/roster.aspx?rp_id=4898" id="sidearmAd77" rel="smarttag">Andre Lino</a></strong> 27, <strong><a href="http://goeags.com/roster.aspx?rp_id=4929" id="sidearmAd78" rel="smarttag">Nzuzi Webster</a></strong> 25, <strong><a href="http://goeags.com/roster.aspx?rp_id=4871" id="sidearmAd79" rel="smarttag">Victor Gamboa</a></strong> 23, <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd80" rel="smarttag">Albert Havili</a></strong> 23, <strong><a href="http://goeags.com/roster.aspx?rp_id=4896" id="sidearmAd81" rel="smarttag">Josh Lewis</a></strong> 17, <strong><a href="http://goeags.com/roster.aspx?rp_id=4932" id="sidearmAd82" rel="smarttag">Keenan Williams</a></strong> 16, <strong><a href="http://goeags.com/roster.aspx?rp_id=4879" id="sidearmAd83" rel="smarttag">Jake Hoffman</a></strong> 11, <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd84" rel="smarttag">Jay-Tee Tiuli</a></strong> 11, <strong><a href="http://goeags.com/roster.aspx?rp_id=4888" id="sidearmAd85" rel="smarttag">Cole Karstetter</a></strong> 11, <strong><a href="http://goeags.com/roster.aspx?rp_id=4927" id="sidearmAd86" rel="smarttag">D'londo Tucker</a></strong> 9, <strong><a href="http://goeags.com/roster.aspx?rp_id=4892" id="sidearmAd87" rel="smarttag">Ketner Kupp</a></strong> 9, <strong><a href="http://goeags.com/roster.aspx?rp_id=4857" id="sidearmAd88" rel="smarttag">Kurt Calhoun</a></strong> 8, <strong><a href="http://goeags.com/roster.aspx?rp_id=4918" id="sidearmAd89" rel="smarttag">Jack Sendelbach</a></strong> 3, <strong><a href="http://goeags.com/roster.aspx?rp_id=4886" id="sidearmAd90" rel="smarttag">Jonah Jordan</a></strong> 4,<strong> <a href="http://goeags.com/roster.aspx?rp_id=4894" id="sidearmAd91" rel="smarttag">Dylan Ledbetter</a> </strong>4, <strong><a href="http://goeags.com/roster.aspx?rp_id=4891" id="sidearmAd92" rel="smarttag">John Kreifels</a></strong> 2,<strong> <a href="http://goeags.com/roster.aspx?rp_id=4850" id="sidearmAd93" rel="smarttag">Conner Baumann</a></strong> 2 (including 1 as a fullback), <strong><a href="http://goeags.com/roster.aspx?rp_id=4829" id="sidearmAd94" rel="smarttag">Anfernee Gurley</a></strong> 1, <strong><a href="http://goeags.com/roster.aspx?rp_id=4911" id="sidearmAd95" rel="smarttag">Tysen Prunty</a></strong> 1.<br />&nbsp;<br />Offense (168 starts by 16 players): <strong><a href="http://goeags.com/roster.aspx?rp_id=4923" id="sidearmAd96" rel="smarttag">Tristen Taylor</a></strong> 21, <strong><a href="http://goeags.com/roster.aspx?rp_id=4917" id="sidearmAd97" rel="smarttag">Chris Schlichting</a></strong> 21, <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd98" rel="smarttag">Gage Gubrud</a></strong> 20, <strong><a href="http://goeags.com/roster.aspx?rp_id=4905" id="sidearmAd99" rel="smarttag">Matt Meyer</a></strong> 16, <strong><a href="http://goeags.com/roster.aspx?rp_id=4854" id="sidearmAd100" rel="smarttag">Spencer Blackburn</a> </strong>18, <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd101" rel="smarttag">Nic Sblendorio</a></strong> 16, <strong><a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd102" rel="smarttag">Antoine Custer Jr.</a></strong> 12, <strong><a href="http://goeags.com/roster.aspx?rp_id=4928" id="sidearmAd103" rel="smarttag">Nsimba Webster</a></strong> 9, <strong><a href="http://goeags.com/roster.aspx?rp_id=4881" id="sidearmAd104" rel="smarttag">Jack Hunter</a></strong> 8,<strong> <a href="http://goeags.com/roster.aspx?rp_id=4866" id="sidearmAd105" rel="smarttag">Zach Eagle</a></strong> 5, <strong><a href="http://goeags.com/roster.aspx?rp_id=4872" id="sidearmAd106" rel="smarttag">Jayce Gilder</a> </strong>4, <strong><a href="http://goeags.com/roster.aspx?rp_id=4924" id="sidearmAd107" rel="smarttag">Brett Thompson</a></strong> 4, <strong><a href="http://goeags.com/roster.aspx?rp_id=4873" id="sidearmAd108" rel="smarttag">Terence Grady</a></strong> 4, <strong><a href="http://goeags.com/roster.aspx?rp_id=4895" id="sidearmAd109" rel="smarttag">Kaleb Levao</a></strong> 4 (including 1 as defensive lineman), <strong><a href="http://goeags.com/roster.aspx?rp_id=4920" id="sidearmAd110" rel="smarttag">Stu Stiles</a></strong> 2, <strong><a href="http://goeags.com/roster.aspx?rp_id=4851" id="sidearmAd111" rel="smarttag">Henderson Belk</a></strong> 2, <strong><a href="http://goeags.com/roster.aspx?rp_id=4902" id="sidearmAd112" rel="smarttag">Sam McPherson</a></strong> 1, <strong><a href="http://goeags.com/roster.aspx?rp_id=4931" id="sidearmAd113" rel="smarttag">Jayson Williams</a></strong> 1.<br />&nbsp;<br />&nbsp;<br /><strong><u>Consecutive Extra Points Record Ends at 85 for <a href="http://goeags.com/roster.aspx?rp_id=4847" id="sidearmAd114" rel="smarttag">Roldan Alcobendas</a></u></strong><br />&nbsp;<br />Kicker <strong><a href="http://goeags.com/roster.aspx?rp_id=4847" id="sidearmAd115" rel="smarttag">Roldan Alcobendas</a> </strong>missed his first extra point attempt of the game against UC Davis on Oct. 7, ending his school-record string of consecutive career extra points made at 85. In his 25-game career, Alcobendas has made 16-of-23 field goals and 124-of-129 extra points. Thus far this year he has made 29-of-30 extra point attempts and 7-of-10 field goals.<br />&nbsp;<br />He has also handled kickoff duties as of late for the Eagles, and is averaging 60.6 yards on 32 kicks this season with seven touchbacks. In his career, he has exactly 100 kickoffs for 57.5 average (5,750 total yards) with 17 touchbacks.<br />&nbsp;<br />Alcobendas is a 2013 graduate of Camas (Wash.) High School, and had to sit out both the 2013 and 2015 seasons because of knee injuries. He finished the 2016 season 9-of-15 kicking field goals and made 73-of-74 extra points. He made his last 63 extra points in a row in 2016 to shatter the previous season record of 47. His 73 total extra points made in 2016 were one behind the Big Sky Conference record of 74 set by former Eagle Kevin Miller in 2013. He also averaged 54.6 yards on 44 kickoffs with seven touchbacks.<br />&nbsp;<br />Returning to the venue he suffered a season-ending knee injury in 2014, Alcobendas made field goals of 48 and 31 yards and had a career-high 11 total points in EWU's 41-17 victory over Montana State in 2016 to earn Big Sky Conference Special Teams Player of the Week honors. His 48-yarder was the best of his career, and equals the 23rd-longest in school history. He also had a 31-yarder blocked and made all five of his extra point attempts to account for 11 of EWU's points. In addition, he averaged 64.0 yards in three kickoffs, including one touchback.<br />&nbsp;<br />&nbsp;<br /><strong><u>Career Average for Dascalo is Fifth Among the Top Punters in School History</u></strong><br />&nbsp;<br />With a 41.0 average on 28 punts thus far in 2017 to rank 32nd in FCS, <strong><a href="http://goeags.com/roster.aspx?rp_id=4861" id="sidearmAd116" rel="smarttag">Jordan Dascalo</a> </strong>has now punted 106 times as an Eagle for a 40.8 career average to rank fifth in school history. Against UC Davis on Oct. 7, he averaged 42.5 yards per punt with a long of 56 and one downed inside the 20-yard line. The average field position for the Aggies after his punts was its own 29-yard line.<br />&nbsp;<br />He averaged 46.8 yards on six punts in EWU's season-opener against Texas Tech with a long of 58. A pair of his punts were downed inside the 20, and the average starting position for TTU after his six punts was its own 23. Dascalo also kicked off three times, with all three resulting in touchbacks. He had a 62-yard punt at Fordham on Sept. 16, equaling the second-longest of his career (he had a 67-yarder in 2015 versus Montana), and ranking as the 19th-longest in school history. He had a 45.0 average on four punts in that game, with two of them downed inside the 20.<br />&nbsp;<br />In his career, Dascalo has now had 34 punts downed inside the 20. He has had 10 punts in his career of at least 56 yards, including a career-long of 67 to rank sixth in school history. He is also 4-of-7 in his EWU career kicking field goals, and has averaged 59.9 yards (6,644 total yards) in 111 career kickoffs with 45 touchbacks.<br />&nbsp;<br />Dascalo, who punted as a freshman in 2014 for Washington State, earned Big Sky Conference Special Teams Player of the Week honors for his performance against his former team on Sept. 3, 2016. He averaged 55.3 yards on three punts, including one downed inside the Cougar 20-yard line. He also kicked a 48-yard field goal on the final play of the first half that started a decisive 17-0 scoring run by the Eagles in the 45-42 win. He also had seven kickoffs for a 57.0 average against WSU with one touchback. His 48-yarder equaled the 23rd-longest in school history and was the best in nearly seven years by an Eagle since Mike Jarrett booted a 49-yarder versus Idaho State on 10/3/09.<br />&nbsp;<br />&nbsp;<br /><strong><u>Looking Ahead for Eagles</u></strong><br />&nbsp;<br />Eastern heads back on the road for an Oct. 21 game at Southern Utah (6-5 last year/5-3 Big Sky). The SUU game is the first of three-straight games against teams with winning records overall and in league play in 2016. After a bye week on Oct. 28, Eastern hosts Weber State (7-5/6-2) for Homecoming on Nov. 4 and plays at fellow defending Big Sky champion North Dakota (9-3/8-0) on Nov. 11. The regular season closes with Senior Day at Roos Field on Nov. 18 versus Portland State, with the FCS Playoffs beginning the following weekend on Nov. 25.<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>More <a href="http://goeags.com/coaches.aspx?rc=112" id="sidearmAd117" rel="smarttag">Aaron Best</a> Comments</u></strong></h2><p>&nbsp;<br /><em>On Southern Utah:</em> &quot;They got after Weber last week, and we'll have our hands full. They are very sound schematically, and have a lot of returning players on both sides of the ball. They have a great coach in Demario Warren and he's been around that program for a while now. He will have his team ready. They have the home-field advantage, so we have to try to take that away from them.&quot;<br />&nbsp;<br /><em>On MSU Win: </em>&quot;They are always hard-fought, not matter if it's home or away. The second half offensively we didn't get the ball very often, and the defense was out there quite a bit. We didn't do a good job of keeping possession of the ball, and gave one up on special teams. That started giving them the momentum, and they were one score away. But we got a big one that <a href="http://goeags.com/roster.aspx?rp_id=4932" id="sidearmAd118" rel="smarttag">Keenan Williams</a> recovered to get us back on track. We took what they gave us on offense, and in those games where we don't have a ton of possessions, we want to make sure we are meticulous. We have to kind of grind it out, which we did.&quot;<br />&nbsp;<br /><em>On Four Takeaways Against MSU, Including Two in the Red Zone:</em> &quot;They are huge, huge. Turnovers in the red zone are not really just one turnover, they are almost worth one-and-a-half. They are worth a lot, especially when you talk about flipping the field.&quot;<br />&nbsp;<br /><em>On Big Plays:</em> &quot;Great players make great plays in big situations. The last time I checked, all these games are big. It doesn't have to be home, away, conference or non-conference, you only get 11 guaranteed games so they are all big. The standard is to make big plays in big situations and that's what Gage did. He took it on himself to pack the ball in a passing situation and move the sticks. He got us another set of downs.&quot;<br />&nbsp;<br /><em>On <a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd119" rel="smarttag">Gage Gubrud</a>'s Passing Production: </em>&quot;We obviously are taking what the defense gives us, but I love the consistent play. The first two games we were a bit inconsistent, but he's come into his own since then. We're not in this for stats, we're in this for wins &ndash; Gage is the first to admit that. He doesn't care if it's six handoffs or six throws, he's all about team victories and we'll see how that goes. But we'll continue to lean on our star, and he is star &ndash; a well-known one. Because he's a known commodity, it's a testament to Gage and our coaching staff that he continues to thrive in those situations. I'm proud of them and all the players making plays around Gage.&quot;<br />&nbsp;<br /><em>On Improving Each Week:</em> &quot;It's like anything, we want to peak at the right time, and the right time is the latter part of the season. At Fordham we were able to find out what winning was like for this team in 2017. Our team has done a great job on really focusing and believing in the task at hand, and believing in themselves.&quot;<br />&nbsp;<br /><em>On Winning Turnover Battle:</em> &quot;It's big. When we win the turnover battle we win games here at Eastern. That's the way it's been.&quot;<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>More Team Notes</u></strong></h2><p>&nbsp;<br /><strong><u><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd120" rel="smarttag">Gage Gubrud</a> Wins Pair of National Player of the Week Honors</u></strong><br />&nbsp;<br />Both in numbers and accolades, it's been quite a roll <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd121" rel="smarttag">Gage Gubrud</a></strong> and the Eastern Washington University football offense has been on as of late.<br />&nbsp;<br />The junior All-America quarterback was selected as the NCAA Football Championship Subdivision Offensive Player of the Week for the second-straight week from College Sports Madness after directing EWU's fourth-quarter rally in a 41-38 win at UC Davis on Oct. 7. He was also chosen by CSM as its Big Sky Conference Offensive Player of the Week, and earned honorable mention for FCS Performer of the Week for the third time this season by College Performance Awards. One week earlier versus Sacramento State, he was selected as the College Sports Madness FCS Offensive Player of the Week. He also won his third-straight Big Sky Conference Offensive Player of the Week honor &ndash; the sixth time overall in his career &ndash; and became the first Eagle to win it three consecutive weeks. Gubrud joins the likes of Travis Lulay of Montana State and Doug Nussmeier and John Friesz of Idaho as other players in league history to garner the award three times in a row.<br />&nbsp;<br />The 2014 graduate of McMinnville (Ore.) High School helped Eastern erase an 11-point fourth-quarter deficit at UC Davis by directing scoring drives of 71, 55 and 75 yards in the final quarter. Finishing with six touchdown passes and 452 yards passing, he passed 6 yards to <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd122" rel="smarttag">Nic Sblendorio</a></strong> for a game-winning TD with 1:37 to play, followed by a missed 49-yard field goal by the Aggies that could have knotted the game. It was Eastern's 23rd victory since 2010 when trailing or tied in the fourth quarter, including two this season. The Aggies finished with a 551-501 advantage in total offense, but Eastern had 205 of its yards in the fourth quarter alone. The Eagles managed only 13 points in the first 41 minutes of the game, having five three-and-outs in that span. Eastern, however, had a five touchdown drives of 73 yards or more, and another of 55. Gubrud completed 33-of-53 passes and completed passes to 10 different receivers. His six touchdown passes were one away from the school record.<br />&nbsp;<br />Versus Sac State on Sept. 30, he accounted for 486 yards and six touchdowns in a 52-31 victory. Gubrud completed 35-of-50 passes as he finished with 447 passing yards and five touchdowns. He also caught a 43-yard touchdown pass from running back <strong><a href="http://goeags.com/roster.aspx?rp_id=4902" id="sidearmAd123" rel="smarttag">Sam McPherson</a></strong>, and had six rushes for a net loss of four yards. He had a hand in 57 of EWU's 86 offensive plays, resulting in the seventh-most yards in school history with 651.<br />&nbsp;<br />&nbsp;<br /><strong><u>Eagles Celebrate 50th Anniversary of Games at Roos/Woodward Field With 50th Game on the Red Turf</u></strong><br />&nbsp;<br />The North Dakota State game on Sept. 9 was the 50th at Roos Field since the red turf surface was installed in 2010. After beating Sacramento State on Sept. 30 and Montana State on Oct. 14, Eastern is now 43-9 overall, and have lost just five regular season games at &quot;The Inferno&quot; &ndash; 33-5 (86.8 percent), plus are 10-4 in playoff games. The only regular season losses at home for EWU since then are to conference foes Montana State (2011), Portland State (2011 and 2015) and Northern Arizona (2015), as well as North Dakota State (2017).<br />&nbsp;<br />This is the seventh season the stadium has been known as &quot;Roos Field,&quot; as a new red synthetic Sprinturf surface made its debut in 2010. Eastern finished a perfect 8-0 in its debut season at &quot;The Inferno,&quot; including three playoff victories. Eastern is 42-9 overall (82 percent) since the red turf was installed in 2010 &ndash; including a 4-0 record versus rival Montana. Eastern has a 154-63 record (71.0 percent) in 217 games at Roos Field (formerly Woodward Field) since 1967, with the Eagles utilizing Joe Albi Stadium in Spokane as the school's main home field from 1983-89.<br />&nbsp;<br />In 2016, Eastern finished 7-1 in the 50th season of football at EWU's current stadium location, which opened in 1967 and is celebrating its 50th anniversary in the 2017 season. A crowd of 11,301 were on hand for EWU's most recent home game versus Montana State, the fifth-most in school history and giving EWU 23-straight regular season sellouts (crowd of 8,600 or more) and 35 overall.<br />&nbsp;<br />Eastern's 2016 average attendance was 8,435 (67,477 in eight home games), ranking behind the school record of 9,577 set in five home games in 2015. The Montana game on Oct. 29 had a crowd of 10,931 to rank as the fifth-most in school history, with the top three coming versus the Griz (11,702 in 2010, 11,583 in 2006 and 11,339 in 2014).<br />&nbsp;<br />&nbsp;<br /><strong><u>Eastern is 25-13 (66 percent) Since 2010 Versus Ranked Opponents </u></strong><br />&nbsp;<br />The Eagles have now played 121 games against ranked teams in the NCAA Football Championship Subdivision since becoming a member of that classification in 1983 (then known as I-AA). Eastern is 54-67 (.446 in those games, including a 17-42 mark (.288) versus top 10 foes. Since 2010, though, the Eagles are 25-13 overall (.658) and 8-7 (.533 versus top 10 teams. So far this season, Eastern is 0-1 with a 40-13 loss to second-ranked North Dakota State (the Eagles were ranked seventh).<br />&nbsp;<br />Eastern was 6-2 against ranked teams in 2016, having lost to top-ranked North Dakota State by a 50-44 score in overtime and then falling 40-38 to 13th-ranked Youngstown State in the semifinals of the FCS Playoffs. Eastern defeated Northern Iowa, ranked 10th at the time, by a 34-30 score on Sept. 17, beat No. 25 Northern Arizona 50-35 on Sept. 24, defeated No. 16 Montana 35-16 on Oct. 29, knocked off No. 14 Cal Poly 42-21 on Nov. 5, then beat No. 14 Central Arkansas 31-14 on Dec. 3 and was victorious over No. 12 Richmond 38-0 on Dec. 10. Overall, EWU has faced the No. 1 team in FCS nine times, winning twice (35-31 in 2004 over Southern Illinois in the FCS Playoffs and 30-21 in 2002 over Montana at Albi Stadium in Spokane, Wash.<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>More Player Notes</u></strong></h2><p>&nbsp;<br /><strong><u>Gubrud Heads List of Players Honored With Preseason Accolades</u></strong><br />&nbsp;<br />There are at least 5,160 reasons Eastern Washington University's <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd124" rel="smarttag">Gage Gubrud</a></strong> is now among the favorites to win the Walter Payton Award presented by STATS to the top offensive player in the NCAA Football Championship Subdivision.<br />&nbsp;<br />The junior quarterback burst on the FCS scene a year ago in his first season as a starter by passing for a FCS record 5,160 yards, to go along with 48 touchdown passes and more than 5,700 yards of total offense. On Aug. 2, STATS named him among the players on the Watch List to win the award after finishing third in the voting a year ago. He was later named to the watch list for FCS Performer of the Year as selected by College Football Performance Awards.<br />&nbsp;<br />Gubrud was joined on the STATS Watch List by Chase Edmonds from Fordham, which hosts EWU in The Bronx, N.Y., on Sept. 16. Edmonds was first in the nation in rushing yards per game (163.5), and second in all-purpose yards per game (194.6) and points per game (10.9). He finished fourth in the voting for last year's Payton Award, right behind Gubrud.<br />&nbsp;<br />In addition to the Watch List, Gubrud was selected to the STATS preseason All-America second team and was picked defend his title as the league's Offensive MVP. He was last year's NCAA Football Championship Subdivision Player of the Year by the Touchdown Club of Columbus.<br />&nbsp;<br />Defensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd125" rel="smarttag">Jay-Tee Tiuli</a> </strong>earned third team preseason All-America honors from STATS, while Gubrud, defensive end <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd126" rel="smarttag">Albert Havili</a></strong> and safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd127" rel="smarttag">Mitch Fettig</a> </strong>earned preseason All-Big Sky Conference honors. In addition, Gubrud was selected by College Sports Madness to win the Big Sky Conference Offensive Player of the Year award and was joined on CSM's preseason All-BSC squad by eight other Eagles. Defensive nose tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd128" rel="smarttag">Jay-Tee Tiuli</a></strong> joined Gubrud on the first team, with wide receiver <strong><a href="http://goeags.com/roster.aspx?rp_id=4916" id="sidearmAd129" rel="smarttag">Nic Sblendorio</a></strong>, safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd130" rel="smarttag">Mitch Fettig</a></strong>, cornerback <strong><a href="http://goeags.com/roster.aspx?rp_id=4929" id="sidearmAd131" rel="smarttag">Nzuzi Webster</a></strong> and defensive end <strong><a href="http://goeags.com/roster.aspx?rp_id=4876" id="sidearmAd132" rel="smarttag">Albert Havili</a></strong> picked for the second team, and center <strong><a href="http://goeags.com/roster.aspx?rp_id=4854" id="sidearmAd133" rel="smarttag">Spencer Blackburn</a> </strong>and linebacker <strong><a href="http://goeags.com/roster.aspx?rp_id=4892" id="sidearmAd134" rel="smarttag">Ketner Kupp</a> </strong>chosen to the third team.<br />&nbsp;<br />&nbsp;<br /><strong><u>Gubrud Among Two All-Americans and Six All-BSC Players Back</u></strong><br />&nbsp;<br />Quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd135" rel="smarttag">Gage Gubrud</a></strong> was honored on six All-America teams in 2016, including as a first team selection by Hero Sports. Gubrud was a second team selection by STATS, the American Football Coaches Association, Associated Press and College Sports Madness. Hero Sports also selected him to its Sophomore All-America squad. Four seniors also received All-America accolades, and a sixth, center <strong><a href="http://goeags.com/roster.aspx?rp_id=4854" id="sidearmAd136" rel="smarttag">Spencer Blackburn</a></strong>, who was picked for the Hero Sports Sophomore All-America squad.&nbsp;<br />&nbsp;<br />Gubrud and <a href="http://goeags.com/roster.aspx?rp_id=4581" id="sidearmAd137" rel="smarttag">Cooper Kupp</a> were honored on Nov. 22 as the Big Sky Conference co-Offensive MVPs, the first time in league history two players from the same team were selected by the coaches to share the award. Both were unanimous selections as first team selections in the league, with Kupp also becoming just the fourth player in league history to earn first team all-league all four seasons.<br />&nbsp;<br />A total of 13 Eagles overall were honored, including a league-high seven first team selections. Returning for 2017 are first team defensive tackle <strong><a href="http://goeags.com/roster.aspx?rp_id=4925" id="sidearmAd138" rel="smarttag">Jay-Tee Tiuli</a></strong>, second team center <strong><a href="http://goeags.com/roster.aspx?rp_id=4854" id="sidearmAd139" rel="smarttag">Spencer Blackburn</a></strong>, third team cornerback <strong><a href="http://goeags.com/roster.aspx?rp_id=4929" id="sidearmAd140" rel="smarttag">Nzuzi Webster</a></strong> and honorable mention performers <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd141" rel="smarttag">Mitch Fettig</a> </strong>(safety) and <strong><a href="http://goeags.com/roster.aspx?rp_id=4923" id="sidearmAd142" rel="smarttag">Tristen Taylor</a></strong> (offensive tackle).<br />&nbsp;<br />Blackburn took over as Eastern's starting center in the fourth game of the season for injured senior <a href="http://goeags.com/roster.aspx?rp_id=4574" id="sidearmAd143" rel="smarttag">Jerrod Jones</a>, and earned second team All-Big Sky Conference honors. After Blackburn's insertion into the starting lineup beginning with the Northern Arizona game on Sept. 24, Eastern's five starters on the offensive line for the rest of the year consisted of two redshirt freshmen and a trio of sophomores.<br />&nbsp;<br />Eastern players have now been selected as the Big Sky Conference Offensive MVP in 12 of the last 16 seasons, including six of the last seven.<br />&nbsp;<br />&nbsp;<br /><strong><u>Gubrud Breaks Three FCS, Seven Big Sky and 18 EWU Records</u></strong><br />&nbsp;<br />Sophomore quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd144" rel="smarttag">Gage Gubrud</a></strong> &ndash; the Big Sky's co-Offensive MVP along with teammate <strong><a href="http://goeags.com/roster.aspx?rp_id=4581" id="sidearmAd145" rel="smarttag">Cooper Kupp</a></strong> -- put up some remarkable numbers in his first season as EWU's starter, breaking three FCS records, seven Big Sky marks and 18 school records.<br />&nbsp;<br />Gubrud is a 2014 graduate of McMinnville (Ore.) High School and passed for an FCS record 5,160 yards in the 2016 season, breaking the record of 5,076 by Taylor Heinicke of Old Dominion in 2012. His 11 games with at least 300 yards passing and 12 with at least 300 yards of total offense are also FCS records. Gubrud's total of 5,766 yards of total offense were just 33 from the total offense mark of 5,799 set by Steve McNair of Alcorn in 1994. Gubrud broke EWU and Big Sky Conference single season records previous set by Vernon Adams Jr. in 2013 with 4,994 passing yards and 5,559 yards of offense.<br />&nbsp;<br />Gubrud's average of 411.9 yards of offense per game was also a league and school record, and ranks fifth in FCS history. He broke the previous Big Sky record set 25 years prior by Jamie Martin of Weber State with a 394.3 average in 1991. Gubrud's final tally of 368.6 passing yards per game was an EWU school record, breaking the record of 364.5 set by Bo Levi Mitchell in 2011. They were also the second-most in Big Sky history (behind the record of 379.6 set by Dave Dickenson of Montana in 1995) and ranked ninth all-time in FCS.<br />&nbsp;<br />Gubrud also set Big Sky and school records for total offensive plays (704), passing completions (386) and attempts (570), and a school record for rushing yards by a quarterback with 606 (the old record was 605 by Vernon Adams Jr. in 2013). The six single game EWU records he set as a sophomore were for passing yards (520 vs. Montana State), total offense (551 vs. Washington State), touchdowns responsible for (7 vs. UC Davis), points responsible for (42 vs. UC Davis), fewest interceptions per pass attempt (0 in 64 attempts versus Central Arkansas) and completions (47 vs. Central Arkansas), which was also a league record. He has since broken his own records for passing yards and total offense, with 549 passing and 560 total at Montana on Sept. 23, 2017.<br />&nbsp;<br />&nbsp;<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>Recent Game Recap</u></strong></h2><p>&nbsp;<br /><strong><u>#10 Eastern Washington 31, Montana State 19</u></strong><br />&nbsp;<br />It was a turnover turnaround for the Eastern football team. After nearly giving away the lead with fumbles on back-to-back possessions, the defense for No. 10/9 Eagles did the same moments later to help preserve a 31-19 EWU victory over Montana State Oct. 14 at Roos Field in Cheney, Wash. It was the fourth Big Sky Conference win in four tries this season for the Eagles, who have now won 12-straight league games and have had 23 consecutive regular season sellouts at &quot;The Inferno.&quot; A crowd of 11,301 &ndash; the fifth-most in school history &ndash; were on hand for the game. Sophomore running back <strong><a href="http://goeags.com/roster.aspx?rp_id=4860" id="sidearmAd146" rel="smarttag">Antoine Custer Jr.</a> </strong>rushed for a career-high 147 yards and two touchdowns and junior quarterback <strong><a href="http://goeags.com/roster.aspx?rp_id=4875" id="sidearmAd147" rel="smarttag">Gage Gubrud</a> </strong>had 227 passing yards and a TD. But the difference was turnovers, as EWU ended up with four takeaways &ndash; including two in the red zone -- and three giveaways, and are now 40-0 since 2010 when they've won the turnover battle. White the Eagles finished with 451 yards of total offense, Eastern's defense held MSU to 353 yards. There were no lead changes, but the game featured runs of 10 and 14 consecutive points by Eastern, and a run of 12 points by MSU. Although the Eagles had three turnovers themselves that turned into seven points, Eastern's <strong><a href="http://goeags.com/roster.aspx?rp_id=4932" id="sidearmAd148" rel="smarttag">Keenan Williams</a></strong> recovered a fumble with 8:52 to play and <strong><a href="http://goeags.com/roster.aspx?rp_id=4871" id="sidearmAd149" rel="smarttag">Victor Gamboa</a> </strong>had an interception with 2:01 remaining to turn the tide in EWU's favor. Montana State's three fumbles in the game were turned into 17 Eagle points, including a nearly six minute touchdown drive that clinched the win in the fourth quarter for EWU. Gubrud improved his record as Eastern's starter to 16-4. He completed his first 16 passes as he finished 25-of-31 for 224 yards and a touchdown. He also rushed for 21 net yards despite getting sacked four times, two ending on lost fumbles. Junior linebacker <strong><a href="http://goeags.com/roster.aspx?rp_id=4892" id="sidearmAd150" rel="smarttag">Ketner Kupp</a></strong> had the fifth double-figure tackle performance of his career, finishing with 12. Junior defensive end <strong><a href="http://goeags.com/roster.aspx?rp_id=4932" id="sidearmAd151" rel="smarttag">Keenan Williams</a></strong> finished with nine tackles, a key fumble recovery in the fourth quarter and a quarterback hurry.&nbsp; Junior safety <strong><a href="http://goeags.com/roster.aspx?rp_id=4869" id="sidearmAd152" rel="smarttag">Mitch Fettig</a></strong> had nine tackles, having entered the game with a team-leading total of 58. Junior linebacker <strong><a href="http://goeags.com/roster.aspx?rp_id=4857" id="sidearmAd153" rel="smarttag">Kurt Calhoun</a> </strong>added seven tackles and a fumble recovery, and sophomore <strong><a href="http://goeags.com/roster.aspx?rp_id=4911" id="sidearmAd154" rel="smarttag">Tysen Prunty</a></strong> also had seven stops with a pass broken up. He was making the first start of his career as an injury replacement at safety.<br />&nbsp;<br />&nbsp;<br />&nbsp;</p><h2><strong><u>Series History</u></strong></h2><p>&nbsp;<br />* Eastern leads the all-time series 6-2, but is just 3-2 in Cedar City. The Eagles lost there by a 43-21 score in the first-ever meeting in 1998, but then won there in 2002 (49-14) and 2009 (41-28) before falling in 2012 (30-27). Eastern won there again in 2014 (42-30), and has also picked up home victories in 2003 (49-21), 2010 (31-24) and 2013 (34-10).<br /><br />&nbsp;<br /><strong><u>Looking Back</u></strong><br /><br /><strong>#2 Eastern Washington 42, Southern Utah 30 (Oct. 11, 2014)</strong> -- The second-ranked Eagles rushed for 280 yards to take pressure off the first career start by quarterback <a href="http://goeags.com/roster.aspx?rp_id=4614" id="sidearmAd155" rel="smarttag">Jordan West</a>, and the Eagles went on to defeat Southern Utah 42-30 on Oct. 11, 2014, in a Big Sky Conference game at Eccles Coliseum in Cedar City, Utah. The Eagles used timely offense and defense &ndash; as well as a blocked punt in the second quarter by Tevin McDonald &ndash; to turn a 14-7 deficit into a 42-24 lead early in the fourth quarter. Sophomore Jalen Moore and senior Mario Brown had career-best performances to combine for 267 yards and three touchdowns, while West had 288 yards through the air. Eastern had 54 rushes in the game and passed 27 times en route to a 568-513 advantage in total offense. West finished 20-of-27 with three touchdowns, one interception and an impressive passer efficiency rating of 192.9. Brown, starting in place of the injured Quincy Forte, had a career-high 134 yards rushing on 22 carries and scored once. Moore had his best game as an Eagle with 133 yards, also on 22 carries, and scored a pair of touchdowns. Sophomore <a href="http://goeags.com/roster.aspx?rp_id=4545" id="sidearmAd156" rel="smarttag">Kendrick Bourne</a> had five catches for 90 yards and a pair of touchdowns, and <a href="http://goeags.com/roster.aspx?rp_id=4581" id="sidearmAd157" rel="smarttag">Cooper Kupp</a> led EWU receivers with six catches for 63 yards. Freshman redshirt cornerback <strong><a href="http://goeags.com/roster.aspx?rp_id=4871" id="sidearmAd158" rel="smarttag">Victor Gamboa</a></strong> had the first two interceptions of his career for the Eagles and seven tackles. Safety <a href="http://goeags.com/roster.aspx?rp_id=4546" id="sidearmAd159" rel="smarttag">Zach Bruce</a> led Eastern in tackles with eight.<br /><br /><strong>#4 Eastern Washington 34, Southern Utah 10 (Oct. 19, 2013) -- </strong>Eastern intercepted three passes and had four sacks to beat Southern Utah 34-10 at Roos Field. Leading just 14-3 at halftime, Eastern's offense got untracked in the second half and scored touchdowns on three-straight possessions in front of a sold-out crowd of 10,135.&nbsp; EWU out-gained SUU in total offense 486-368, including advantages of 161-28 in the first quarter and 175-102 in the decisive third period. Eastern quarterback Vernon Adams Jr. completed 25-of-35 passes for 298 yards and three touchdowns in the win, and <a href="http://goeags.com/roster.aspx?rp_id=4581" id="sidearmAd160" rel="smarttag">Cooper Kupp</a> had 11 catches for 168 yards and a score. Linebacker Cody McCarthy led the defense with eight tackles, and Ronnie Hamlin added seven. Eastern won the turnover battle 3-2 against a team that entered the game ranked eighth in the NCAA Football Championship Subdivision with a plus nine margin for the season. &nbsp;All three turnovers EWU forced were interceptions recorded by Tevin McDonald, Ronald Baines and <a href="http://goeags.com/roster.aspx?rp_id=4555" id="sidearmAd161" rel="smarttag">Samson Ebukam</a>, who returned his 21 yards for the first score of the day. Sacks were recorded by Andru Pulu, <a href="http://goeags.com/roster.aspx?rp_id=4605" id="sidearmAd162" rel="smarttag">Matthew Sommer</a><strong>,</strong> Anthony Larry and Evan Day<strong>.</strong> It was the first time EWU had three interceptions in a single game in three seasons.<br /><br /><strong>#1 Eastern Washington 30, Southern Utah 27 (Oct. 27, 2010)</strong> -- In the 30-27 Southern Utah win in 2012, senior quarterback Brad Sorenson passed for 392 yards and SUU kicked a field goal with three seconds left to pull off the upset over No. 1 ranked EWU. Eastern had entered the game 6-1 and 5-0 in the Big Sky, and SUU entered just 3-5 overall and 2-3 in the league. The Thunderbirds scored the final 10 points in a game that featured five lead changes and no lead of more than seven points. Both teams finished with nearly 500 yards of offense, but a missed Eastern field goal with 2:51 left and a made SUU field goal with three seconds remaining was the difference as the Eagles fell from their perch as the No. 1 team in the NCAA Football Championship Subdivision. On a day when Eastern managed only 91 rushing yards, quarterbacks Vernon Adams Jr. and Kyle Padron combined to pass for 404 yards. However, Sorenson was up to the task, as the senior completed 33-of-43 passes with one interception and one touchdown. Adams started both halves and finished 11-of-15 for 181 yards and a score. Ashton Clark had a career-high 11 catches for 86 yards and a touchdown, with his catch total ranking 12th in school history. Ronnie Hamlin had 13 tackles to lead the Eagle defense, and T.J. Lee added nine with a sack.</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><!--Start of Display Size:  (7)--><div class="wnBlock displaySize displaySizeId7 nestedCategory" id="DisplaySizeId7"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">College Sports</span><span class="text abridgedHeadline">College</span><a class="wnContent more enabled" href="/category/162314/college"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportNCAAFootball story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Football"><meta content="2017-10-21 00:02:10"><h4 class="wnContent headline"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">Eagles to play Southern Utah in Big Sky Conference matchup</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">Eagles to play Southern Utah in Big Sky Conference matchup</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15211019_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15211019_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0.</p></span><a class="more" href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0.</p></span><a class="more" href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NCAA-Football"><meta content="2017-10-20 23:54:18"><h4 class="wnContent headline"><a href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><span class="text">Whitworth to host Puget Sound Saturday on SWX</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><span class="text">Whitworth to host Puget Sound Saturday on SWX</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15210966_G.jpg" title="Photo: Whitworth Athletics" alt="Photo: Whitworth Athletics"></a><span class="caption left width180"><span class="text">Photo: Whitworth Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15210966_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Whitworth University returns home to take on its oldest football rival on Saturday when the Pirates host the University of Puget Sound in the Pine Bowl at 1:05 pm.&nbsp; The game televised regionally on SWX and will be heard live in Spokane on KSBN 1230am and on the world wide web at KSBN.net.&nbsp; The radio broadcast will begin at 12:45 pm.</p></span><a class="more" href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Whitworth University returns home to take on its oldest football rival on Saturday when the Pirates host the University of Puget Sound in the Pine Bowl at 1:05 pm.&nbsp; The game televised regionally on SWX and will be heard live in Spokane on KSBN 1230am and on the world wide web at KSBN.net.&nbsp; The radio broadcast will begin at 12:45 pm.</p></span><a class="more" href="/story/36647924/whitworth-to-host-puget-sound-saturday-on-swx"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-20 01:28:50"><h4 class="wnContent headline"><a href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><span class="text">Zags ranked 19th in preseason Coaches' Poll</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><span class="text">Zags ranked 19th in preseason Coaches' Poll</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15202927_G.png" title="Gonzaga opens season in coaches’ poll for eighth straight season. Photo: Gonzaga Athletics" alt="Gonzaga opens season in coaches’ poll for eighth straight season. Photo: Gonzaga Athletics"></a><span class="caption left width180"><span class="text">Gonzaga opens season in coaches’ poll for eighth straight season. Photo: Gonzaga Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15202927_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Gonzaga men&rsquo;s basketball team was ranked No. 19 in the USA TODAY Coaches&rsquo; preseason poll Thursday. It marked the eighth straight season that the Zags appeared in the coaches&rsquo; preseason poll.</p></span><a class="more" href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Gonzaga men&rsquo;s basketball team was ranked No. 19 in the USA TODAY Coaches&rsquo; preseason poll Thursday. It marked the eighth straight season that the Zags appeared in the coaches&rsquo; preseason poll.</p></span><a class="more" href="/story/36640439/zags-ranked-19th-in-preseason-coaches-poll"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-10-20 00:31:39"><h4 class="wnContent headline"><a href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><span class="text">Chris Petersen named to Bryant, Dodd Award watch lists</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><span class="text">Chris Petersen named to Bryant, Dodd Award watch lists</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15202627_G.jpg" title="Photo: UW Athletics" alt="Photo: UW Athletics"></a><span class="caption left width180"><span class="text">Photo: UW Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15202627_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Washington football coach Chris Petersen has been named to the watch list for the Paul &quot;Bear&quot; Bryant Award and to the midseason watch list for the Dodd Trophy. Both are given annually to the nation's top college coach.</p></span><a class="more" href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Washington football coach Chris Petersen has been named to the watch list for the Paul &quot;Bear&quot; Bryant Award and to the midseason watch list for the Dodd Trophy. Both are given annually to the nation's top college coach.</p></span><a class="more" href="/story/36640213/chris-petersen-named-to-bryant-dodd-award-watch-lists"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAA story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA"><meta content="2017-10-19 23:09:26"><h4 class="wnContent headline"><a href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><span class="text">Idaho approves contract extensions for Petrino and Verlin</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><span class="text">Idaho approves contract extensions for Petrino and Verlin</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15201877_G.jpg" title="Photo: Idaho Athletics" alt="Photo: Idaho Athletics"></a><span class="caption left width180"><span class="text">Photo: Idaho Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15201877_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Petrino's contract is an amendment to his current deal and will run through June 30, 2022. His previous agreement was set to expire Dec. 30, 2020. Petrino will earn a one-year extension if he is not in breach of contract by July 1, 2018.</p></span><a class="more" href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Petrino's contract is an amendment to his current deal and will run through June 30, 2022. His previous agreement was set to expire Dec. 30, 2020. Petrino will earn a one-year extension if he is not in breach of contract by July 1, 2018.</p></span><a class="more" href="/story/36639784/idaho-approves-contract-extensions-for-petrino-and-verlin"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-19 22:46:30"><h4 class="wnContent headline"><a href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><span class="text">Gonzaga picked to finish 2nd in WCC, Perkins & Williams preseason All-WCC team</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><span class="text">Gonzaga picked to finish 2nd in WCC, Perkins & Williams preseason All-WCC team</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15201639_G.jpg" title="Photo: Gonzaga Athletics" alt="Photo: Gonzaga Athletics"></a><span class="caption left width180"><span class="text">Photo: Gonzaga Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15201639_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Zags were slated second in the league's preseason poll behind Saint Mary's. GU received 73 points in the poll, with a first place, while the Gaels grabbed eight first place votes and 81 points.</p></span><a class="more" href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Zags were slated second in the league's preseason poll behind Saint Mary's. GU received 73 points in the poll, with a first place, while the Gaels grabbed eight first place votes and 81 points.</p></span><a class="more" href="/story/36639623/gonzaga-picked-to-finish-2nd-in-wcc-perkins-williams-preseason-all-wcc-team"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-19 02:09:07"><h4 class="wnContent headline"><a href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><span class="text">Zags picked to win 14th WCC crown, Barta & Stockton preseason All-WCC</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><span class="text">Zags picked to win 14th WCC crown, Barta & Stockton preseason All-WCC</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15193945_G.png" title="Photo: Gonzaga Athletics" alt="Photo: Gonzaga Athletics"></a><span class="caption left width180"><span class="text">Photo: Gonzaga Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15193945_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>For the fifth-straight season, the Gonzaga women's basketball team was picked as the West Coast Conference preseason favorite. <a href="http://www.gozags.com/sports/w-baskbl/mtt/laura_stockton_975221.html">Laura Stockton</a> and <a href="http://www.gozags.com/sports/w-baskbl/mtt/jill_barta_955435.html">Jill Barta</a> were named to the Preseason All-WCC team.</p></span><a class="more" href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For the fifth-straight season, the Gonzaga women's basketball team was picked as the West Coast Conference preseason favorite. <a href="http://www.gozags.com/sports/w-baskbl/mtt/laura_stockton_975221.html">Laura Stockton</a> and <a href="http://www.gozags.com/sports/w-baskbl/mtt/jill_barta_955435.html">Jill Barta</a> were named to the Preseason All-WCC team.</p></span><a class="more" href="/story/36631262/zags-picked-to-win-14th-wcc-crown-barta-stockton-preseason-all-wcc"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-19 02:05:10"><h4 class="wnContent headline"><a href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><span class="text">Zags Norvell Jr. named to Julius Erving Award watch list</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><span class="text">Zags Norvell Jr. named to Julius Erving Award watch list</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15193908_G.png" title="Photo: Gonzaga Athletics" alt="Photo: Gonzaga Athletics"></a><span class="caption left width180"><span class="text">Photo: Gonzaga Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15193908_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>Norvell Jr. redshirted for the Zags last season and will make his freshman debut in 2017-18.</p></span><a class="more" href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Norvell Jr. redshirted for the Zags last season and will make his freshman debut in 2017-18.</p></span><a class="more" href="/story/36631247/zags-norvell-jr-named-to-julius-erving-award-watch-list"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-10-19 00:05:06"><h4 class="wnContent headline"><a href="/story/36630812/wsu-to-host-colorado-on-saturday"><span class="text">WSU to host Colorado on Saturday</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36630812/wsu-to-host-colorado-on-saturday"><span class="text">WSU to host Colorado on Saturday</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36630812/wsu-to-host-colorado-on-saturday"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15193138_G.jpg" title="Cougars are currently ranked No. 15 in the AP Poll. Photo: WSU Athletics" alt="Cougars are currently ranked No. 15 in the AP Poll. Photo: WSU Athletics"></a><span class="caption left width180"><span class="text">Cougars are currently ranked No. 15 in the AP Poll. Photo: WSU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36630812/wsu-to-host-colorado-on-saturday"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15193138_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Washington State is 6-1 for the first time since 2003 and enters the week ranked No. 15 in the Associated Press Top-25.</p></span><a class="more" href="/story/36630812/wsu-to-host-colorado-on-saturday"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Washington State is 6-1 for the first time since 2003 and enters the week ranked No. 15 in the Associated Press Top-25.</p></span><a class="more" href="/story/36630812/wsu-to-host-colorado-on-saturday"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-18 23:38:29"><h4 class="wnContent headline"><a href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><span class="text">WSU men’s basketball to hold open practice Oct. 21</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><span class="text">WSU men’s basketball to hold open practice Oct. 21</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15192753_G.jpg" title="Photo: WSU Athletics" alt="Photo: WSU Athletics"></a><span class="caption left width180"><span class="text">Photo: WSU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15192753_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Members of the men's basketball team will be available to sign autographs following the conclusion of practice. Those in attendance will also hear from fourth-year head coach, <a href="http://www.wsucougars.com/coaches.aspx?rc=553" rel="smarttag">Ernie Kent</a>.&nbsp;<br /> &nbsp;</p></span><a class="more" href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Members of the men's basketball team will be available to sign autographs following the conclusion of practice. Those in attendance will also hear from fourth-year head coach, <a href="http://www.wsucougars.com/coaches.aspx?rc=553" rel="smarttag">Ernie Kent</a>.&nbsp;<br />&nbsp;</p></span><a class="more" href="/story/36630640/wsu-mens-basketball-to-hold-open-practice-oct-21"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId7');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size:  (7)--><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd63" class="wnad wnad63">
<script>wnad_63.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Promo Box - Col 4A (24)--><div class="wnBlock displaySize displaySizeId24 promoBox" id="DisplaySizeId24"><ul class="wnGroup contentGroup odd last"><li class="wnItem feature  link priority-1 odd displaySizeId-4 odd-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.khq.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376213_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.khq.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376213_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.</span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.<br /></span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-2 even displaySizeId-4 even-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.nbcrightnow.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376216_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.nbcrightnow.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376216_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.<br /></span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.</span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-3 odd displaySizeId-4 odd-4 last"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.kulr8.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/702249_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.kulr8.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/702249_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Breaking news, weather and community information for Billings, MT and surrounding areas.</span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Billings, Mont. and surrounding area, including northern Wyoming.<br /></span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId24');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Promo Box - Col 4A (24)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Eastern Washington</span><span class="text abridgedHeadline">EWU</span><a class="wnContent more enabled" href="/category/162663/ewu-sports"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportNCAAFootball story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Football"><meta content="2017-10-21 00:02:10"><h4 class="wnContent headline"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">Eagles to play Southern Utah in Big Sky Conference matchup</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">Eagles to play Southern Utah in Big Sky Conference matchup</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15211019_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15211019_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0.</p></span><a class="more" href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>After a 31-19 home triumph versus Montana State, the Eagles are now 4-0 in the Big Sky Conference standings just ahead of Northern Arizona at 3-0.</p></span><a class="more" href="/story/36647943/eagles-to-play-southern-utah-in-big-sky-conference-matchup"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NCAA-Football"><meta content="2017-10-15 00:59:00"><h4 class="wnContent headline"><a href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><span class="text">Eagles continue Big Sky dominance with win over Montana State</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><span class="text">Eagles continue Big Sky dominance with win over Montana State</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15160954_G.jpg" title="Eagles extend their Big Sky Conference winning streak to 12 games." alt="Eagles extend their Big Sky Conference winning streak to 12 games."></a><span class="caption left width180"><span class="text">Eagles extend their Big Sky Conference winning streak to 12 games.</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15160954_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>After nearly giving away the lead with fumbles on back-to-back possessions, the defense for No. 10/9 Eagles did the same moments later to help preserve a 31-19 EWU victory over Montana State.</p></span><a class="more" href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>After nearly giving away the lead with fumbles on back-to-back possessions, the defense for No. 10/9 Eagles did the same moments later to help preserve a 31-19 EWU victory over Montana State.</p></span><a class="more" href="/story/36598852/eagles-continue-big-sky-dominance-with-win-over-montana-state"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-14 00:01:32"><h4 class="wnContent headline"><a href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><span class="text">Delaney Hodgins tabbed Big Sky Conference preseason MVP</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><span class="text">Delaney Hodgins tabbed Big Sky Conference preseason MVP</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15155693_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15155693_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The senior was tabbed to the All-Big Sky First Team following the conclusion of the 2016-17 season after averaging 17.5 points per game. During her junior season.</p></span><a class="more" href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The senior was tabbed to the All-Big Sky First Team following the conclusion of the 2016-17 season after averaging 17.5 points per game. During her junior season.</p></span><a class="more" href="/story/36594786/delaney-hodgins-tabbed-big-sky-conference-preseason-mvp"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-13 23:39:53"><h4 class="wnContent headline"><a href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><span class="text">Eagles women's basketball picked to finish 6th in Big Sky</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><span class="text">Eagles women's basketball picked to finish 6th in Big Sky</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15155344_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15155344_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Last season, the Eagles stayed true to their fourth-place Preseason Coaches Poll prediction, as they racked up their third-consecutive 19-win season with a 19-14 overall record.</p></span><a class="more" href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Last season, the Eagles stayed true to their fourth-place Preseason Coaches Poll prediction, as they racked up their third-consecutive 19-win season with a 19-14 overall record.</p></span><a class="more" href="/story/36594690/eagles-womens-basketball-picked-to-finish-6th-in-big-sky"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-13 23:35:55"><h4 class="wnContent headline"><a href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><span class="text">Eagles men's basketball picked to finish 6th in Big Sky Conference</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><span class="text">Eagles men's basketball picked to finish 6th in Big Sky Conference</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15155299_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15155299_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Led by Big Sky Conference Player of the Year candidate <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd2" rel="smarttag">Bogdan Bliznyuk</a></strong>, the Eagles feature a team with size throughout their lineup. Bliznyuk was named to the preseason All-Big Sky team, and is one of 10 returning players to the Eagle roster.</p></span><a class="more" href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Led by Big Sky Conference Player of the Year candidate <strong><a href="http://goeags.com/roster.aspx?rp_id=4935" id="sidearmAd2" rel="smarttag">Bogdan Bliznyuk</a></strong>, the Eagles feature a team with size throughout their lineup. Bliznyuk was named to the preseason All-Big Sky team, and is one of 10 returning players to the Eagle roster.</p></span><a class="more" href="/story/36594670/eagles-mens-basketball-picked-to-finish-6th-in-big-sky-conference"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAABasketball story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Basketball"><meta content="2017-10-12 23:20:18"><h4 class="wnContent headline"><a href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><span class="text">EWU's Bogdan Bliznyuk selected to preseason All-Big Sky team</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><span class="text">EWU's Bogdan Bliznyuk selected to preseason All-Big Sky team</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15145520_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15145520_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A two-time co-captain for the Eagles, Bliznyuk was a second-team All-Big Sky and All-District 6 performer last year, and was the league's Freshman of the Year in 2014-15.&nbsp;</p></span><a class="more" href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A two-time co-captain for the Eagles, Bliznyuk was a second-team All-Big Sky and All-District 6 performer last year, and was the league's Freshman of the Year in 2014-15.&nbsp;</p></span><a class="more" href="/story/36586269/ewus-bogdan-bliznyuk-selected-to-preseason-all-big-sky-team"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-10-11 23:50:09"><h4 class="wnContent headline"><a href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><span class="text">Eagles look to keep winning streak alive against Bobcats</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><span class="text">Eagles look to keep winning streak alive against Bobcats</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15135859_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15135859_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Two of the top teams in the Big Sky Conference in recent years pair off this week when the No. 10/9 Eastern Washington University football team hosts Montana State,</p></span><a class="more" href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Two of the top teams in the Big Sky Conference in recent years pair off this week when the No. 10/9 Eastern Washington University football team hosts Montana State,</p></span><a class="more" href="/story/36576564/eagles-look-to-keep-winning-streak-alive-against-bobcats"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-10-08 05:53:20"><h4 class="wnContent headline"><a href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><span class="text">No. 10 Eagles rally past Aggies for 41-38 win</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><span class="text">No. 10 Eagles rally past Aggies for 41-38 win</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15105238_G.jpg" title="Photo: EWU Athletics" alt="Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15105238_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p><br />The Eastern Washington University football team rallied from an 11-point deficit in the fourth quarter by scoring 21 points in the period and went on to spoil the upset hopes of UC Davis with a heart-stopping 41-38 victory over the Aggies.</p></span><a class="more" href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p><br />The Eastern Washington University football team rallied from an 11-point deficit in the fourth quarter by scoring 21 points in the period and went on to spoil the upset hopes of UC Davis with a heart-stopping 41-38 victory over the Aggies.</p></span><a class="more" href="/story/36546696/no-10-eagles-rally-past-aggies-for-41-38-win"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportInterview story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - Interview"><meta content="2017-10-03 06:25:07"><h4 class="wnContent headline"><a href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><span class="text">Jim Hayford talks about 2017 SYSA Annual Event</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><span class="text">Jim Hayford talks about 2017 SYSA Annual Event</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15061885_G.jpg" title="Doors open for the SYSA event at 6:00 pm" alt="Doors open for the SYSA event at 6:00 pm"></a><span class="caption left width180"><span class="text">Doors open for the SYSA event at 6:00 pm</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15061885_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Former Eastern Washington men's basketball head coach Jim Hayford talked with our Sam Adams about the Spokane Youth Sports Association and his contributions towards the community.</p></span><a class="more" href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Former Eastern Washington men's basketball head coach Jim Hayford talked with our Sam Adams about the Spokane Youth Sports Association and his contributions towards the community.</p></span><a class="more" href="/story/36505815/jim-hayford-talks-about-2017-sysa-annual-event"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NCAA-Football"><meta content="2017-10-04 23:15:49"><h4 class="wnContent headline"><a href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><span class="text">Eagles look for 4th straight win vs UC Davis</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><span class="text">Eagles look for 4th straight win vs UC Davis</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/15078865_G.jpg" title="Eagles started the year 0-2 and now look for their 4th straight win. Photo: EWU Athletics" alt="Eagles started the year 0-2 and now look for their 4th straight win. Photo: EWU Athletics"></a><span class="caption left width180"><span class="text">Eagles started the year 0-2 and now look for their 4th straight win. Photo: EWU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/15078865_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The top two offenses in the Big Sky Conference will square off when the 10th-ranked Eastern Washington University football team plays at UC Davis and new Aggie head coach Dan Hawkins this Saturday.</p></span><a class="more" href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The top two offenses in the Big Sky Conference will square off when the 10th-ranked Eastern Washington University football team plays at UC Davis and new Aggie head coach Dan Hawkins this Saturday.</p></span><a class="more" href="/story/36524132/eagles-look-for-4th-straight-win-vs-uc-davis"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://SWXRN.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText">All content &copy; Copyright  2000  - 2017 SWXRN. All Rights Reserved.<BR>For more information on this site, please read  our <A HREF='/story/18990/this-web-sites-privacy-policy'  >Privacy Policy</a>, and <A HREF='/story/18991/this-sites-terms-of-service'  >Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.</div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E")); </script> <script type="text/javascript"> try { var pageTracker = _gat._getTracker("UA-15497971-2"); pageTracker._trackPageview(); } catch(err) {}</script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>