<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9jzm6dt" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9jzm6dt";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Press Pass Pullman: Week One - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</title>
<meta name="Description" content="It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach theorizes about Bi..."><meta name="KEYWORDS" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="news_keywords" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/09/05"><meta name="owner" content="SWXRN"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="release-7.3.9-Hotfix-SMEV-641-Override.1"><meta name="wn-base" content="IIS26"><meta name="wnreadableurl" content="press-pass-pullman-week-one"><meta property="og:title" content="Press Pass Pullman: Week One"><meta property="og:type" content="article"><meta property="og:url" content="http://www.swxrightnow.com/story/36288227/press-pass-pullman-week-one"><meta property="og:image" content="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"><meta property="og:description" content="It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach theorizes about Bi..."><link rel="canonical" href="http://www.swxrightnow.com/story/36288227/press-pass-pullman-week-one"><meta name="author" content="Lindsay Joy"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Press Pass Pullman: Week One"><meta name="twitter:description" content="It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach theorizes about Bi..."><meta name="twitter:image" content="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:page_id" content="130847515832" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=release-7.3.9-Hotfix-SMEV-641-Override.1_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://SWXRN.images.worldnow.com/interface/css/container-e.css?ver=2017-07-25%2016%3A38%3A55_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_release-7.3.9-Hotfix-SMEV-641-Override.1" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=release-7.3.9-Hotfix-SMEV-641-Override.1"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=release-7.3.9-Hotfix-SMEV-641-Override.1"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=release-7.3.9-Hotfix-SMEV-641-Override.1"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1641 UL
                    , #menu1641 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641 A,
                    #menu1641 LI.wnOn .wnSublevel A,
                    #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641
                        .wnLevel1, #menu1641
                        .wnLevel1 LI { height: 38px; }
                            #menu1641 .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu1641 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu1641 LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1641 .wnSublevel { background-color: #d5d5d5;  }
                #menu1641 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu1641 > .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel { width: 978px; }
                    #menu1641 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu1641 .wnLeft { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu1641 LI.wnOn .wnLeft { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1641 .wnRight { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu1641 LI.wnOn .wnRight { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1641 .wnRight .wnMiddle { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1641 LI.wnOn .wnMiddle { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu1641 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu1641 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'SWXRN',
            affiliateId : '863',
            baseUrl : 'www.swxrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '64',mdPartnerDomain : 'http://dub.swxrightnow.com'},
            registrationId : '557063',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://SWXRN.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='release-7.3.9-Hotfix-SMEV-641-Override.1';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='SWXRN';
wng_pageInfo.ownerAffiliateId=parseInt('863',10);
wng_pageInfo.containerId=parseInt('36288227',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='Sport';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/36288227/press-pass-pullman-week-one';
wng_pageInfo.content_authors='Lindsay Joy';
wng_pageInfo.headline='Press Pass Pullman: Week One';
wng_pageInfo.pageTitle='Press Pass Pullman: Week One - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTag='SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffSWXRN';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:300,height:150,wncc:"Sport",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["63"]={id:"63",wnsz:"63",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'inline',aff:'SWXRN'},width:300,height:600,wncc:"Sport",parent:"WNAd63",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.adsettings={disableInitialLoad:true};</script>
<script type="text/javascript" src="http://SWXRN.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-07-25%2016%3A38%3A55_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/SWXRN.config.js?ver=release-7.3.9-Hotfix-SMEV-641-Override.1_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=release-7.3.9-Hotfix-SMEV-641-Override.1_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/swxrn/custom/swxrn_story_zoom.css" /><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel='alternate' type='application/rss+xml' title='Top Sports Headlines' href='http://www.swxrightnow.com/category/162885/publishing-category-top-stories?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='College Headlines' href='http://www.swxrightnow.com/category/162314/college?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Pro Headlines' href='http://www.swxrightnow.com/category/162313/pro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Prep Headlines' href='http://www.swxrightnow.com/category/160221/high-school-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington Sports' href='http://www.swxrightnow.com/category/50896/washington-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Idaho Sports' href='http://www.swxrightnow.com/category/50867/idaho-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington State' href='http://www.swxrightnow.com/category/162664/washington-state?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Univ. of Idaho' href='http://www.swxrightnow.com/category/162831/idaho?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Eastern Washington' href='http://www.swxrightnow.com/category/162663/ewu-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Gonzaga' href='http://www.swxrightnow.com/category/160218/gonzaga?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Central Washington' href='http://www.swxrightnow.com/category/192801/central-washington?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Whitworth' href='http://www.swxrightnow.com/category/174693/whitworth-university?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Shock' href='http://www.swxrightnow.com/category/160220/spokane-shock?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Chiefs' href='http://www.swxrightnow.com/category/162666/spokane-chiefs?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Americans' href='http://www.swxrightnow.com/category/115764/tri-city-americans?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Dust Devils' href='http://www.swxrightnow.com/category/145287/tri-city-dust-devils?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Yakima Bears' href='http://www.swxrightnow.com/category/108040/yakima-bears?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Seattle Mariners' href='http://www.swxrightnow.com/category/162830/seattle-mariners?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Hydro Insider' href='http://www.swxrightnow.com/category/78290/hydroinsidercom-unlimited-hydroplane-racing?clienttype=rss'><link rel='stylesheet' type='text/css' href='http://ftpcontent.worldnow.com/swxrn/custom/custom.css' /><script src="http://ftpcontent.worldnow.com/swxrn/custom/custom.js"></script><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><script src="//acdn.adnxs.com/prebid/c/7045/pb.js"></script></head><body id="WNAffSWXRN" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-55' ,"dma":'73' ,"group":'Cowles'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Press Pass Pullman: Week One - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo_dark.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1641" class="wnMainMenu"><div class="wnHorizontal"><div class="wnStatic"><div class="wnMenuTypeImage"><ul class="wnLevel1" id="submenu1641"><li class="wnFirstNode" id="menu1641_1-C155145"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/"><img src="http://SWXRN.images.worldnow.com/images/499120_G.gif" width="49" height="38" border="0" alt="SWX Right Now.com" title="SWX Right Now.com" onsrc="http://SWXRN.images.worldnow.com/images/499121_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_1-C155145"><li class="wnFirstNode" id="menu1641_1_1-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_1_2-C326823"><span><a href="/category/326823/hydro-wrap-up-2017">Hydro Wrap Up 2017</a></span></li><li class="" id="menu1641_1_6-C163470"><span><a href="/category/163470/games-contests">Games &amp; Contests</a></span></li><li class="" id="menu1641_1_5-C208947"><span><a href="/category/208947/extra-points">Extra Points</a></span></li><li class="" id="menu1641_1_3-C284880"><span><a href="/category/284880/swx-podcasts">SWX Podcast</a></span></li><li class="" id="menu1641_1_4-C220728"><span><a href="/category/220728/featured-slideshows">Featured Slideshows</a></span></li></ul></li><li class="" id="menu1641_2-C160216"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160216/scores"><img src="http://SWXRN.images.worldnow.com/images/499122_G.gif" width="97" height="38" border="0" alt="Scores" title="Scores" onsrc="http://SWXRN.images.worldnow.com/images/499123_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_2-C160216"><li class="wnFirstNode" id="menu1641_2_1-C161806"><span><a href="/category/161806/national-scores">National Scores</a></span></li><li class="" id="menu1641_2_2-C161807"><span><a href="/category/161807/college-scores">College Scores</a></span></li><li class="" id="menu1641_2_3-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_2_4-S9920984"><span><a href="/story/9920984/report-a-score">Report a Score</a></span></li></ul></li><li class="" id="menu1641_3-C162314"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162314/college"><img src="http://SWXRN.images.worldnow.com/images/499124_G.gif" width="65" height="38" border="0" alt="College" title="College" onsrc="http://SWXRN.images.worldnow.com/images/499125_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_3-C162314"><li class="wnFirstNode" id="menu1641_3_1-C162664"><span><a href="/category/162664/washington-state">WSU</a></span></li><li class="" id="menu1641_3_2-C160218"><span><a href="/category/160218/gonzaga">Gonzaga</a></span></li><li class="" id="menu1641_3_3-C162663"><span><a href="/category/162663/ewu-sports">EWU</a></span></li><li class="" id="menu1641_3_4-C174693"><span><a href="/category/174693/whitworth-university">Whitworth</a></span></li><li class="" id="menu1641_3_5-C162831"><span><a href="/category/162831/idaho">Idaho</a></span></li><li class="" id="menu1641_3_6-C267736"><span><a href="/category/267736/university-of-washington">Washington</a></span></li><li class="" id="menu1641_3_7-C192801"><span><a href="/category/192801/central-washington">CWU</a></span></li><li class="" id="menu1641_3_8-C262164"><span><a href="/category/262164/bobcats">Bobcats</a></span></li><li class="" id="menu1641_3_9-C262165"><span><a href="/category/262165/grizzlies">Grizzlies</a></span></li></ul></li><li class="" id="menu1641_4-C162313"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162313/pro"><img src="http://SWXRN.images.worldnow.com/images/499126_G.gif" width="36" height="38" border="0" alt="Pro" title="Pro" onsrc="http://SWXRN.images.worldnow.com/images/499127_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_4-C162313"><li class="wnFirstNode" id="menu1641_4_3-C272346"><span><a href="/category/272346/seattle-seahawks">Seattle Seahawks</a></span></li><li class="" id="menu1641_4_4-C162666"><span><a href="/category/162666/spokane-chiefs">Spokane Chiefs</a></span></li><li class="" id="menu1641_4_5-C160220"><span><a href="/category/160220/spokane-empire">Spokane Empire</a></span></li><li class="" id="menu1641_4_6-C284681"><span><a href="/category/284681/montana-pro-sports">Pro Sports</a></span></li><li class="" id="menu1641_4_2-C193768"><span><a href="/category/193768/the-offseason">The Offseason</a></span></li><li class="" id="menu1641_4_1-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_5-C160221"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160221/high-school-sports"><img src="http://SWXRN.images.worldnow.com/images/499128_G.gif" width="96" height="38" border="0" alt="High School" title="High School" onsrc="http://SWXRN.images.worldnow.com/images/499129_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_5-C160221"><li class="wnFirstNode" id="menu1641_5_1-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_5_2-C318106"><span><a href="/category/318106/student-athlete">Student Athlete </a></span></li><li class="" id="menu1641_5_4-C162688"><span><a href="/category/162688/greater-spokane-league">Greater Spokane League</a></span></li><li class="" id="menu1641_5_5-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_5_6-C284683"><span><a href="/category/284683/montana-high-school-sports">High School Sports</a></span></li><li class="" id="menu1641_5_3-C286972"><span><a href="/category/286972/prep-countdown">Prep Countdown</a></span></li></ul></li><li class="" id="menu1641_6-L654994"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://www.nwprepsnow.com"><img src="http://SWXRN.images.worldnow.com/images/4054557_G.png" width="140" height="38" border="0" alt="High School to NWPrepsNow.com" title="High School to NWPrepsNow.com" onsrc="http://SWXRN.images.worldnow.com/images/4054564_G.png"></a></span></span></span></span></li><li class="" id="menu1641_7-C160222"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160222/video-center"><img src="http://SWXRN.images.worldnow.com/images/499132_G.gif" width="102" height="38" border="0" alt="Video Center" title="Video Center" onsrc="http://SWXRN.images.worldnow.com/images/499133_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_7-C160222"><li class="wnFirstNode" id="menu1641_7_1-L375234"><span><a href="http://www.swxrightnow.com/global/category.asp?c=">All Video</a></span></li><li class="" id="menu1641_7_2-C162982"><span><a href="/category/162982/vc-college">College </a></span></li><li class="" id="menu1641_7_3-C162981"><span><a href="/category/162981/vc-pro">Pro </a></span></li><li class="" id="menu1641_7_4-C162980"><span><a href="/category/162980/vc-high-school">High School </a></span></li><li class="" id="menu1641_7_5-C162983"><span><a href="/category/162983/vc-gonzaga">Gonzaga </a></span></li><li class="" id="menu1641_7_6-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_7_7-C162984"><span><a href="/category/162984/vc-wsu">WSU</a></span></li><li class="" id="menu1641_7_8-C162986"><span><a href="/category/162986/vc-ewu">EWU</a></span></li><li class="" id="menu1641_7_9-C162987"><span><a href="/category/162987/vc-spokane-empire">VC - Spokane Empire</a></span></li></ul></li><li class="" id="menu1641_8-C155146"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather"><img src="http://SWXRN.images.worldnow.com/images/499134_G.gif" width="73" height="38" border="0" alt="Weather" title="Weather" onsrc="http://SWXRN.images.worldnow.com/images/499135_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_8-C155146"><li class="wnFirstNode" id="menu1641_8_1-C120835"><span><a href="/category/120835/road-pass-conditions">Road &amp; Pass Conditions</a></span></li><li class="" id="menu1641_8_2-S9962976"><span><a href="/story/9962976/radar-maps">Radar</a></span></li><li class="" id="menu1641_8_3-S9963255"><span><a href="/story/9963255/satellite-maps">Satellite</a></span></li><li class="" id="menu1641_8_4-S9974691"><span><a href="/story/9974691/school-closures-delays">School Closures &amp; Delays</a></span></li><li class="" id="menu1641_8_5-L524823"><span><a href="/link/524823/inland-northwest-ski-conditions">Ski Conditions</a></span></li></ul></li><li class="" id="menu1641_9-C160225"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160225/about-us"><img src="http://SWXRN.images.worldnow.com/images/499136_G.gif" width="76" height="38" border="0" alt="About Us" title="About Us" onsrc="http://SWXRN.images.worldnow.com/images/499137_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_9-C160225"><li class="wnFirstNode" id="menu1641_9_1-S9913533"><span><a href="/story/9913533/swx-contact-information">SWX Contact Information</a></span></li><li class="" id="menu1641_9_2-S9914380"><span><a href="/story/9914380/swx-on-tv">SWX on TV</a></span></li><li class="" id="menu1641_9_4-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_9_5-S9914228"><span><a href="/story/9914228/advertise-with-swx">Advertise with SWX</a></span></li><li class="" id="menu1641_9_3-S12164224"><span><a href="/story/12164224/closed-captioning-inquiries">Closed Captioning Inquiries</a></span></li><li class="" id="menu1641_9_6-S9914091"><span><a href="/story/9914091/jobs-at-swx">Jobs at SWX</a></span></li><li class="" id="menu1641_9_7-L376213"><span><a href="http://www.khq.com/">KHQ Right Now</a></span></li><li class="" id="menu1641_9_8-L376216"><span><a href="http://www.nbcrightnow.com/">NBC Right Now</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1641"></div></div></div></div><div id="spacermenu1641" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1641', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : true, level1Height : '38', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Press Pass Pullman: Week One</h3>
<em class="wnDate">Posted: 
<script type="text/javascript">
                                wnRenderDate('Tuesday, September 5, 2017 1:12 AM EDT', '', false);</script>
</em><noscript><em class="wnDate">Tuesday, September 5, 2017 1:12 AM EDT</em></noscript><!--END wnDate-->
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">by Lindsay Joy, SWX Anchor/Reporter</span><div class="simple"><span class="email item"><a target="_self" title="" href="mailto:lindsay.joy@khq.com?body=http://www.swxrightnow.com/story/36288227/press-pass-pullman-week-one">Email</a></span></div><div class="wn-anchor"><a href="#" class="connect">Connect</a><div class="connect off"><div class="email item"><a target="_self" title="" href="mailto:lindsay.joy@khq.com?body=http://www.swxrightnow.com/story/36288227/press-pass-pullman-week-one">lindsay.joy@khq.com</a></div><div class="facebook item"><div class="fb-follow" data-colorscheme="light" data-layout="button" data-show-faces="false" data-href="https://www.facebook.com/LindsayJoySWX"></div></div></div></div></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div><!--DISPLAY SIZE 37: -->
<div id="WNDS37" class="wnDS37 wnDSContainer-standard wnDS">
<div class="wnDSItems-standard">
<div id="divWNStoryVideoDS37" style="&#xA;          height: 485px; overflow: hidden; position: relative;&#xA;        "><div id="divWNGalleryDS37" style="&#xA;            top: 354px; z-index: 1000; position: absolute;&#xA;          "></div><div id="divWNVideoCanvasDS37" style="position: absolute; top: 0px;"></div><script type="text/javascript">
          var widgetVideoCanvasDS37 = new WNVideoWidget("WNVideoCanvas2", "divWNVideoCanvasDS37", "DS37");
          widgetVideoCanvasDS37.SetStylePackage("flatlight");
          widgetVideoCanvasDS37.SetSkin(CANVAS_SKINS.flat.silver);
          widgetVideoCanvasDS37.SetWidth("630");
          widgetVideoCanvasDS37.SetHeight("355");
          widgetVideoCanvasDS37.SetVariable("landingPage", document.location.href);
          widgetVideoCanvasDS37.SetVariable("clipId", "13675346");
          widgetVideoCanvasDS37.SetVariable("transportShareButtons", "cc");
          widgetVideoCanvasDS37.SetVariable("controlsType", "fixed");
          
            widgetVideoCanvasDS37.SetEmbeddedGallery("wnstory", "36288227");
          

            try {
                if(wn.video.site.enablestorypageautoplay) {
                    widgetVideoCanvasDS37.SetVariable('isAutoStart', 'true');
                }
            }
            catch(e) {}

          widgetVideoCanvasDS37.RenderWidget();
          
            galleryPlacement = 'both';
            if (navigator.userAgent.match(/(iPhone|iPod|iPad)/) ||
            galleryPlacement != 'inside')
            {
            containerHeight = 355 + 130;
            $('#divWNStoryVideoDS37').css('height',containerHeight + 'px');

            var WNGalleryDS37 = new WNVideoWidget("WNGallery", "divWNGalleryDS37", "DS37");
            WNGalleryDS37.SetStylePackage("flatlight");
            WNGalleryDS37.SetVariable("hasSearch", "false");
            WNGalleryDS37.SetVariable("rows", "1");
            WNGalleryDS37.SetVariable("columns", "2");
            WNGalleryDS37.SetVariable("showTooltip", "true");
            WNGalleryDS37.SetVariable("tabHeight", "0");
            WNGalleryDS37.SetVariable("tabFontSize", "0");
            WNGalleryDS37.SetVariable("dropDownFontSize", "0");
            WNGalleryDS37.SetVariable("videoListImageWidth", "140");
            WNGalleryDS37.SetVariable("videoListImageHeight", "79");
            WNGalleryDS37.SetVariable("storyId", "36288227");
            WNGalleryDS37.SetVariable("clipId", "13675346");
            WNGalleryDS37.SetWidth(630);
            WNGalleryDS37.SetHeight(130);


            try {
              if (wn.video.site.storyPageContinuousPlay) {
                WNGalleryDS37.SetVariable("isContinuousPlay", true);
              } else {
                WNGalleryDS37.SetVariable("isContinuousPlay", false);
              }

            } 
            catch(e) {}

            try {
              if (wn.video.site.disableSinglePageClipInStory) {
                WNGalleryDS37.SetVariable("disableSinglePageClipInStory", true);
              } else {
                WNGalleryDS37.SetVariable("disableSinglePageClipInStory", false);
              }
            }
            catch(e) {}

            WNGalleryDS37.RenderWidget();
            }
          </script></div></div><!--END wnDSItems-->
</div><!--
                END wnDS37-->
</div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnLeft" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://SWXRN.images.worldnow.com/images/14831018_G.jpg" alt="" title="" border="0" width="180">
</div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated left"><p>It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach&nbsp;theorizes&nbsp;about Bigfoot, aliens, and galaxies that are far, far away. He also demonstrates how simple it is to throw a proper shovel pass&nbsp;and talks about a few Texas Tech quarterbacks who struggled to do so.</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 2A (80)--><div class="wnBlock displaySize displaySizeId80 headlineBox" id="DisplaySizeId80"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Local Sports from SWX</span><span class="text abridgedHeadline">Local Sports from SWX</span><a class="wnContent more" href="/category/162885/publishing-category-top-stories"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature SportLocal story priority-1 odd displaySizeId-7 odd-7"><meta content="Sport - Local"><meta content="2017-08-28 07:01:32"><h4 class="wnContent headline"><a href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><span class="text">Cooper-Scott, Saroni win in final full IRONMAN in Coeur d'Alene</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><span class="text">Cooper-Scott, Saroni win in final full IRONMAN in Coeur d'Alene</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14763427_G.png" title="Spokane's Haley Cooper-Scott wins her first IRONMAN" alt="Spokane's Haley Cooper-Scott wins her first IRONMAN"></a><span class="caption left width180"><span class="text">Spokane's Haley Cooper-Scott wins her first IRONMAN</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14763427_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>After a 14-year run, Sunday marked the finale for the final full IRONMAN race in Coeur d'Alene. In the end, two first-time winners were victorious in the last 140.6 race in the Lake City.</p> </span><a class="more" href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>After a 14-year run, Sunday marked the finale for the final full IRONMAN race in Coeur d'Alene. In the end, two first-time winners were victorious in the last 140.6 race in the Lake City.</p></span><a class="more" href="/story/36228980/cooper-scott-saroni-win-in-final-full-ironman-in-coeur-dalene"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-2 even displaySizeId-7 even-7"><meta content="Sport - Local"><meta content="2017-08-27 23:17:00"><h4 class="wnContent headline"><a href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><span class="text">Team White claims Chiefs' annual Red-White game</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><span class="text">Team White claims Chiefs' annual Red-White game</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14761920_G.jpg" title="Photo: Spokane Chiefs/Larry Brunt" alt="Photo: Spokane Chiefs/Larry Brunt"></a><span class="caption left width180"><span class="text">Photo: Spokane Chiefs/Larry Brunt</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14761920_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>SPOKANE, Wash. &ndash; Offense was on display in full force on Sunday afternoon at Spokane Arena as Team White piled on seven goals in a 7-4 win over Team Red in the Spokane Chiefs&rsquo; annual Red-White Game capping their 2017 Training Camp.</p> </span><a class="more" href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>SPOKANE, Wash. &ndash; Offense was on display in full force on Sunday afternoon at Spokane Arena as Team White piled on seven goals in a 7-4 win over Team Red in the Spokane Chiefs&rsquo; annual Red-White Game capping their 2017 Training Camp.</p></span><a class="more" href="/story/36227880/team-white-claims-chiefs-annual-red-white-game"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-3 odd displaySizeId-7 odd-7"><meta content="Sport - Local"><meta content="2017-08-24 00:43:27"><h4 class="wnContent headline"><a href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><span class="text">2017 Spokane Chiefs training camp rosters announced</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><span class="text">2017 Spokane Chiefs training camp rosters announced</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14734698_G.jpg" title="All camp events at Spokane Arena throughout the weekend are free and open to the public." alt="All camp events at Spokane Arena throughout the weekend are free and open to the public."></a><span class="caption left width180"><span class="text">All camp events at Spokane Arena throughout the weekend are free and open to the public.</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14734698_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>This year&rsquo;s event&nbsp;includes 62 players, including 34 forwards, 21 defensemen and 7 goalies.</p> </span><a class="more" href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>This year&rsquo;s event&nbsp;includes 62 players, including 34 forwards, 21 defensemen and 7 goalies.</p></span><a class="more" href="/story/36204298/2017-spokane-chiefs-training-camp-rosters-announced"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="Sport - Local"><meta content="2017-08-18 22:00:59"><h4 class="wnContent headline"><a href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><span class="text">Chiefs' 2017 training camp team names announced</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><span class="text">Chiefs' 2017 training camp team names announced</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14693176_G.jpg" title="Courtesy: NHL.com" alt="Courtesy: NHL.com"></a><span class="caption left width180"><span class="text">Courtesy: NHL.com</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14693176_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Spokane Chiefs announced on Friday the team names for their 2017 training camp, which begins on Thursday, August 24 at Spokane Arena. This year&rsquo;s teams will be Team Johnson, Team Sawyer and Team Ryan.</p> </span><a class="more" href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Spokane Chiefs announced on Friday the team names for their 2017 training camp, which begins on Thursday, August 24 at Spokane Arena. This year&rsquo;s teams will be Team Johnson, Team Sawyer and Team Ryan.</p></span><a class="more" href="/story/36170093/chiefs-2017-training-camp-team-names-announced"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-5 odd displaySizeId-7 odd-7 collapsed"><meta content="Sport - Local"><meta content="2017-08-15 23:19:47"><h4 class="wnContent headline"><a href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><span class="text">Chris Baird hired as assistant director for hockey operations</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><span class="text">Chris Baird hired as assistant director for hockey operations</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14662868_G.jpg" title="Courtesy: Spokane Chiefs" alt="Courtesy: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Courtesy: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14662868_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Baird spent the last 10 seasons as the team&rsquo;s video coordinator, analyzing coaches&rsquo; video and advanced statistics. A Spokane native and Lakeside High School graduate, he was originally hired on by the Chiefs midway through the 2006-07 campaign.</p></span><a class="more" href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Baird spent the last 10 seasons as the team&rsquo;s video coordinator, analyzing coaches&rsquo; video and advanced statistics. A Spokane native and Lakeside High School graduate, he was originally hired on by the Chiefs midway through the 2006-07 campaign.</p></span><a class="more" href="/story/36143421/chris-baird-hired-as-assistant-director-for-hockey-operations"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-6 even displaySizeId-7 even-7 collapsed"><meta content="Sport - Local"><meta content="2017-08-10 22:56:59"><h4 class="wnContent headline"><a href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><span class="text">Kailer Yamamoto signs 3-year deal with Edmonton Oilers</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><span class="text">Kailer Yamamoto signs 3-year deal with Edmonton Oilers</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14626166_G.jpg" title="Courtesy: Edmonton Oilers" alt="Courtesy: Edmonton Oilers"></a><span class="caption left width180"><span class="text">Courtesy: Edmonton Oilers</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14626166_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Yamamoto, picked 22nd overall, appeared in 65 games with the Western Hockey League's (WHL) Spokane Chiefs last season, posting 99 points (42G, 57A), 46 penalty minutes and a plus 14 rating. He was also named to the 2016-17 WHL Western Conference Second All-Star Team.</p></span><a class="more" href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Yamamoto, picked 22nd overall, appeared in 65 games with the Western Hockey League's (WHL) Spokane Chiefs last season, posting 99 points (42G, 57A), 46 penalty minutes and a plus 14 rating. He was also named to the 2016-17 WHL Western Conference Second All-Star Team.</p></span><a class="more" href="/story/36111200/kailer-yamamoto-signs-3-year-deal-with-edmonton-oilers"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportLocal story priority-7 odd displaySizeId-7 odd-7 collapsed last"><meta content="Sport - Local"><meta content="2017-08-02 00:02:22"><h4 class="wnContent headline"><a href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><span class="text">Chiefs' Ty Smith to represent Canada at Ivan Hlinka Cup</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><span class="text">Chiefs' Ty Smith to represent Canada at Ivan Hlinka Cup</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14536511_G.jpg" title="Courtesy: Spokane Chiefs" alt="Courtesy: Spokane Chiefs"></a><span class="caption left width180"><span class="text">Courtesy: Spokane Chiefs</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14536511_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Smith is a regular for Canada in international play, having served as team captain at the 2016 Youth Winter Olympic Games and 2016 World U17 Hockey Challenge (Canada Black). He earned silver medals in both while picking up tournament all-star honors at the U17 challenge.</p> </span><a class="more" href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Smith is a regular for Canada in international play, having served as team captain at the 2016 Youth Winter Olympic Games and 2016 World U17 Hockey Challenge (Canada Black). He earned silver medals in both while picking up tournament all-star honors at the U17 challenge.</p></span><a class="more" href="/story/36026810/chiefs-ty-smith-to-represent-canada-at-ivan-hlinka-cup"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId80');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 2A (80)--><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><!--Start of Display Size:  (7)--><div class="wnBlock displaySize displaySizeId7 nestedCategory" id="DisplaySizeId7"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">College Sports</span><span class="text abridgedHeadline">College</span><a class="wnContent more enabled" href="/category/162314/college"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature Sport story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport"><meta content="2017-09-05 05:12:13"><h4 class="wnContent headline"><a href="/story/36288227/press-pass-pullman-week-one"><span class="text">Press Pass Pullman: Week One</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36288227/press-pass-pullman-week-one"><span class="text">Press Pass Pullman: Week One</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/36288227/press-pass-pullman-week-one"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36288227/press-pass-pullman-week-one"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach&nbsp;theorizes&nbsp;about Bigfoot, aliens, and galaxies that are far, far away. He also demonstrates how simple it is to throw a proper shovel pass&nbsp;and talks about a few Texas Tech quarterbacks who struggled to do so. </span><a class="more" href="/story/36288227/press-pass-pullman-week-one"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach&nbsp;theorizes&nbsp;about Bigfoot, aliens, and galaxies that are far, far away. He also demonstrates how simple it is to throw a proper shovel pass&nbsp;and talks about a few Texas Tech quarterbacks who struggled to do so. </span><a class="more" href="/story/36288227/press-pass-pullman-week-one"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-2 even displaySizeId-20 even-20"><meta content="Sport"><meta content="2017-09-05 04:14:48"><h4 class="wnContent headline"><a href="/story/36288095/grizzly-sports-report-9-4-17"><span class="text">Grizzly Sports Report, 9-4-17</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36288095/grizzly-sports-report-9-4-17"><span class="text">Grizzly Sports Report, 9-4-17</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, September 5 2017 12:14 AM EDT</span><span class="wnContent timestamp gmttime">2017-09-05 04:14:50 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width250"><a href="/story/36288095/grizzly-sports-report-9-4-17"><img border="0" width="250" data-path="http://KTMF.images.worldnow.com/images/14830917_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36288095/grizzly-sports-report-9-4-17"><img border="0" width="115" data-path="http://KTMF.images.worldnow.com/images/14830917_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">The Montana Grizzlies get the 45-23 win over Valpo. Coach Stitt, WR Jerry Louie-McGhee join Shaun Rainey to break down the victory. Riley Corcoran also joins the show for the &quot;call of the game&quot; and Ben Wineman updates us on the other fall sports at UM. </span><a class="more" href="/story/36288095/grizzly-sports-report-9-4-17"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">The Montana Grizzlies get the 45-23 win over Valpo. Coach Stitt, WR Jerry Louie-McGhee join Shaun Rainey to break down the victory. Riley Corcoran also joins the show for the &quot;call of the game&quot; and Ben Wineman updates us on the other fall sports at UM. </span><a class="more" href="/story/36288095/grizzly-sports-report-9-4-17"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-3 odd displaySizeId-20 odd-20"><meta content="General001"><meta content="2017-09-05 00:10:26"><h4 class="wnContent headline"><a href="/story/36287467/super-8-plays-of-the-week-94"><span class="text">Super 8 Plays of the Week 9/4</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36287467/super-8-plays-of-the-week-94"><span class="text">Super 8 Plays of the Week 9/4</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, September 4 2017 8:10 PM EDT</span><span class="wnContent timestamp gmttime">2017-09-05 00:10:55 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36287467/super-8-plays-of-the-week-94"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14829100_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36287467/super-8-plays-of-the-week-94"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14829100_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Check out this week's top plays from the gridiron and soccer pitch!</p></span><a class="more" href="/story/36287467/super-8-plays-of-the-week-94"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Check out this week's top plays from the gridiron and soccer pitch!</p></span><a class="more" href="/story/36287467/super-8-plays-of-the-week-94"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport"><meta content="2017-09-05 00:00:38"><h4 class="wnContent headline"><a href="/story/36287436/bobcat-sports-report-washington-state"><span class="text">Bobcat Sports Report: Washington State</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36287436/bobcat-sports-report-washington-state"><span class="text">Bobcat Sports Report: Washington State</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, September 4 2017 8:00 PM EDT</span><span class="wnContent timestamp gmttime">2017-09-05 00:00:43 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36287436/bobcat-sports-report-washington-state"><img border="0" width="180" data-path="http://KTMF.images.worldnow.com/images/14829497_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36287436/bobcat-sports-report-washington-state"><img border="0" width="115" data-path="http://KTMF.images.worldnow.com/images/14829497_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Breaking down the Bobcats 31-0 loss at Washington State. Jay Sanderson talks with head coach Jeff Choate. Kyle Sherman sits down with sophomore quarterback Chris Murray. The premiere of&nbsp;Big Cats, Little Trucks with Matt Brownlow. Plus, the Bobcat Breakdown featuring sophomore wide receiver Kevin Kassis. </span><a class="more" href="/story/36287436/bobcat-sports-report-washington-state"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Breaking down the Bobcats 31-0 loss at Washington State. Jay Sanderson talks with head coach Jeff Choate. Kyle Sherman sits down with sophomore quarterback Chris Murray. The premiere of&nbsp;Big Cats, Little Trucks with Matt Brownlow. Plus, the Bobcat Breakdown featuring sophomore wide receiver Kevin Kassis. </span><a class="more" href="/story/36287436/bobcat-sports-report-washington-state"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="General001"><meta content="2017-09-04 05:06:05"><h4 class="wnContent headline"><a href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><span class="text">Sparks' Game Winning Kickoff Return is Deja Vu for Rocky</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><span class="text">Sparks' Game Winning Kickoff Return is Deja Vu for Rocky</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, September 4 2017 1:06 AM EDT</span><span class="wnContent timestamp gmttime">2017-09-04 05:06:05 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14824232_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14824232_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Last year it was a 93 yard return from Sam Sparks&nbsp;that saved the Battlin' Bears win. This year, it only took Sparks 86 yards.</p> </span><a class="more" href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Last year it was a 93 yard return from Sam Sparks&nbsp;that saved the Battlin' Bears win. This year, it only took Sparks 86 yards.</p></span><a class="more" href="/story/36282788/sparks-game-winning-kickoff-return-is-deja-vu-for-rocky"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="General001"><meta content="2017-09-04 04:14:27"><h4 class="wnContent headline"><a href="/story/36282731/crowd-surfing-93"><span class="text">Crowd Surfing 9/3</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36282731/crowd-surfing-93"><span class="text">Crowd Surfing 9/3</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, September 4 2017 12:14 AM EDT</span><span class="wnContent timestamp gmttime">2017-09-04 04:14:27 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36282731/crowd-surfing-93"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14824087_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36282731/crowd-surfing-93"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14824087_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Week two of football season brought some slick moves - on and off the field! </span><a class="more" href="/story/36282731/crowd-surfing-93"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Week two of football season brought some slick moves - on and off the field! </span><a class="more" href="/story/36282731/crowd-surfing-93"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="General001"><meta content="2017-09-03 21:05:14"><h4 class="wnContent headline"><a href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><span class="text">MSUB Women End Road Trip with Loss to Drury</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><span class="text">MSUB Women End Road Trip with Loss to Drury</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, September 3 2017 5:05 PM EDT</span><span class="wnContent timestamp gmttime">2017-09-03 21:05:14 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14822091_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14822091_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>For the second straight game, a late goal for the Montana State University Billings women&rsquo;s soccer team was not enough as the Yellowjackets fell to Drury University 2-1 Sunday at Foster Field on the campus of the University of Nebraska Kearney.</p> </span><a class="more" href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For the second straight game, a late goal for the Montana State University Billings women&rsquo;s soccer team was not enough as the Yellowjackets fell to Drury University 2-1 Sunday at Foster Field on the campus of the University of Nebraska Kearney.</p></span><a class="more" href="/story/36281620/msub-women-end-road-trip-with-loss-to-drury"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-09-03 06:54:45"><h4 class="wnContent headline"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">No. 24 Washington St. dominates Montana St. 31-0 to win first opener under Mike Leach</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">No. 24 Washington St. dominates Montana St. 31-0 to win first opener under Mike Leach</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14820406_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14820406_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Luke Falk threw for 311 yards and three touchdowns, setting the school career touchdowns passing record, as No. 24 Washington State beat Montana State 31-0 in the season opener for both teams on Saturday night.</p></span><a class="more" href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Luke Falk threw for 311 yards and three touchdowns, setting the school career touchdowns passing record, as No. 24 Washington State beat Montana State 31-0 in the season opener for both teams on Saturday night.</p></span><a class="more" href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="General001"><meta content="2017-09-03 04:46:31"><h4 class="wnContent headline"><a href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><span class="text">Sparks' Deja Vu Return Lifts Rocky to Win Over MSU Northern</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><span class="text">Sparks' Deja Vu Return Lifts Rocky to Win Over MSU Northern</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, September 3 2017 12:46 AM EDT</span><span class="wnContent timestamp gmttime">2017-09-03 04:46:31 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14820091_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14820091_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">It took 307 yards rushing and an 86-yard kickoff return for a touchdown for the Rocky Mountain College football team defeat Montana State University-Northern, 32-25, in Frontier Conference action at Herb Klindt Field on Saturday afternoon.  The 307 rushing yards from Rocky Mountain (1-1, 1-0 Frontier) is the most by a Battlin&rsquo; Bears team since November 15, 2014. Mason Melby ran for 149 yards and Sam Sparks added 114 for the Bears. They are the first Rocky duo to run for 100-plus...</span><a class="more" href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">It took 307 yards rushing and an 86-yard kickoff return for a touchdown for the Rocky Mountain College football team defeat Montana State University-Northern, 32-25, in Frontier Conference action at Herb Klindt Field on Saturday afternoon.  The 307 rushing yards from Rocky Mountain (1-1, 1-0 Frontier) is the most by a Battlin&rsquo; Bears team since November 15, 2014. Mason Melby ran for 149 yards and Sam Sparks added 114 for the Bears. They are the first Rocky duo to run for 100-plus...</span><a class="more" href="/story/36279764/sparks-deja-vu-return-lifts-rocky-to-win-over-msu-northern"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature General001 story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="General001"><meta content="2017-09-03 04:08:03"><h4 class="wnContent headline"><a href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><span class="text">Griz Slow to Start; Heat Up in Second Half to Beat Valpo</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><span class="text">Griz Slow to Start; Heat Up in Second Half to Beat Valpo</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Sunday, September 3 2017 12:08 AM EDT</span><span class="wnContent timestamp gmttime">2017-09-03 04:08:03 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width180"><a href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><img border="0" width="180" data-path="http://KULR.images.worldnow.com/images/14820096_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><img border="0" width="115" data-path="http://KULR.images.worldnow.com/images/14820096_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Starting quarterback Reese Phillips, who was making his first collegiate start, went 27-38 for 381 yards and four touchdowns.</p> </span><a class="more" href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Starting quarterback Reese Phillips, who was making his first collegiate start, went 27-38 for 381 yards and four touchdowns.</p></span><a class="more" href="/story/36279694/griz-slow-to-start-heat-up-in-second-half-to-beat-valpo"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId7');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size:  (7)--><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd63" class="wnad wnad63">
<script>wnad_63.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Promo Box - Col 4A (24)--><div class="wnBlock displaySize displaySizeId24 promoBox" id="DisplaySizeId24"><ul class="wnGroup contentGroup odd last"><li class="wnItem feature  link priority-1 odd displaySizeId-4 odd-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.khq.com/"><span class="text">KHQ Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.khq.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376213_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.khq.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376213_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.</span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Spokane, Coeur d&#39;Alene and surrounding areas.<br /></span><a class="more" href="http://www.khq.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-2 even displaySizeId-4 even-4"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.nbcrightnow.com/"><span class="text">NBC Right Now</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.nbcrightnow.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/376216_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.nbcrightnow.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/376216_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.<br /></span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Kennwick-Richland-Pasco, Yakima and surrounding communities.</span><a class="more" href="http://www.nbcrightnow.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-3 odd displaySizeId-4 odd-4 last"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.kulr8.com/"><span class="text">KULR 8</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.kulr8.com/"><img border="0" width="90" data-path="http://SWXRN.images.worldnow.com/images/702249_LS.png"></a></div><div class="wnContent summaryImage abridged left width115"><a href="http://www.kulr8.com/"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/702249_LA.png"></a></div><div class="wnContent summary abridged"><span class="text">Breaking news, weather and community information for Billings, MT and surrounding areas.</span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Billings, Mont. and surrounding area, including northern Wyoming.<br /></span><a class="more" href="http://www.kulr8.com/"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId24');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Promo Box - Col 4A (24)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Washington St.</span><span class="text abridgedHeadline">WSU</span><a class="wnContent more enabled" href="/category/162664/washington-state"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature Sport story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport"><meta content="2017-09-05 05:12:13"><h4 class="wnContent headline"><a href="/story/36288227/press-pass-pullman-week-one"><span class="text">Press Pass Pullman: Week One</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36288227/press-pass-pullman-week-one"><span class="text">Press Pass Pullman: Week One</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/36288227/press-pass-pullman-week-one"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36288227/press-pass-pullman-week-one"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14831018_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach&nbsp;theorizes&nbsp;about Bigfoot, aliens, and galaxies that are far, far away. He also demonstrates how simple it is to throw a proper shovel pass&nbsp;and talks about a few Texas Tech quarterbacks who struggled to do so. </span><a class="more" href="/story/36288227/press-pass-pullman-week-one"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">It might be the season premiere of Press Pass Pullman, but Mike Leach is already in mid-season form. This week, after talking about his team's win over Montana State, Coach Leach&nbsp;theorizes&nbsp;about Bigfoot, aliens, and galaxies that are far, far away. He also demonstrates how simple it is to throw a proper shovel pass&nbsp;and talks about a few Texas Tech quarterbacks who struggled to do so. </span><a class="more" href="/story/36288227/press-pass-pullman-week-one"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NCAA-Football"><meta content="2017-09-03 06:54:45"><h4 class="wnContent headline"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">No. 24 Washington St. dominates Montana St. 31-0 to win first opener under Mike Leach</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">No. 24 Washington St. dominates Montana St. 31-0 to win first opener under Mike Leach</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width180"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14820406_G.jpg"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14820406_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Luke Falk threw for 311 yards and three touchdowns, setting the school career touchdowns passing record, as No. 24 Washington State beat Montana State 31-0 in the season opener for both teams on Saturday night.</p></span><a class="more" href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Luke Falk threw for 311 yards and three touchdowns, setting the school career touchdowns passing record, as No. 24 Washington State beat Montana State 31-0 in the season opener for both teams on Saturday night.</p></span><a class="more" href="/story/36279887/no-24-washington-state-dominates-montana-state-31-0-in-first-season-opening-win-under-mike-leach"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - NCAA-Football"><meta content="2017-08-28 22:57:47"><h4 class="wnContent headline"><a href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><span class="text">No. 24 WSU opens up 2017 season against Montana State</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><span class="text">No. 24 WSU opens up 2017 season against Montana State</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14771231_G.jpg" title="Courtesy: WSU Athletics" alt="Courtesy: WSU Athletics"></a><span class="caption left width180"><span class="text">Courtesy: WSU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14771231_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Washington State leads the all-time series with Montana State 8-0, six of those wins coming in Pullman including the last meeting, 23-22 in 2010. Montana State went 4-7 last season including a 2-6 mark in Big Sky Conference play under second-year head coach Jeff Choate.</p> </span><a class="more" href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Washington State leads the all-time series with Montana State 8-0, six of those wins coming in Pullman including the last meeting, 23-22 in 2010. Montana State went 4-7 last season including a 2-6 mark in Big Sky Conference play under second-year head coach Jeff Choate.</p></span><a class="more" href="/story/36236113/no-24-wsu-opens-up-2017-season-against-montana-state"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-08-22 21:00:22"><h4 class="wnContent headline"><a href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><span class="text">Mata’afa named to Ted Hendricks Award watch list</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><span class="text">Mata’afa named to Ted Hendricks Award watch list</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14721716_G.jpg" title="Courtesy: Washington State Athletics" alt="Courtesy: Washington State Athletics"></a><span class="caption left width180"><span class="text">Courtesy: Washington State Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14721716_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Mata'afa, a native of Lahaina, Hawaii, earned All-Pac-12 second team honors last season after finishing fifth in the league with 13.5 tackles including a team-high five sacks.</p> </span><a class="more" href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Mata'afa, a native of Lahaina, Hawaii, earned All-Pac-12 second team honors last season after finishing fifth in the league with 13.5 tackles including a team-high five sacks.</p></span><a class="more" href="/story/36192661/mataafa-named-to-ted-hendricks-award-watch-list"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-08-21 20:32:59"><h4 class="wnContent headline"><a href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><span class="text">Washington State ranked No. 24 in AP preseason poll</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><span class="text">Washington State ranked No. 24 in AP preseason poll</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14710307_G.jpg" title="WSU ranked in AP preseason poll for third time in school history. Courtesy: WSU Cougars" alt="WSU ranked in AP preseason poll for third time in school history. Courtesy: WSU Cougars"></a><span class="caption left width180"><span class="text">WSU ranked in AP preseason poll for third time in school history. Courtesy: WSU Cougars</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14710307_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Washington State football team will begin the season with a No. 24 ranking in the 2017 Associated Press preseason poll, released Monday. The Cougars' are one of four Pac-12 teams ranked in the Top 25 and it marks the third time in the history of the Associated Press poll.</p> </span><a class="more" href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Washington State football team will begin the season with a No. 24 ranking in the 2017 Associated Press preseason poll, released Monday. The Cougars' are one of four Pac-12 teams ranked in the Top 25 and it marks the third time in the history of the Associated Press poll.</p></span><a class="more" href="/story/36183223/washington-state-ranked-no-24-in-ap-preseason-poll"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-08-16 22:21:20"><h4 class="wnContent headline"><a href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><span class="text">Luke Falk named to Manning Award watch list</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><span class="text">Luke Falk named to Manning Award watch list</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14672413_G.jpg" title="Courtesy: Washington State Athletics" alt="Courtesy: Washington State Athletics"></a><span class="caption left width180"><span class="text">Courtesy: Washington State Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14672413_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Falk, a redshirt-senior, was also finalist for the Johnny Unitas Award and a semifinalist for the Davey O'Brien Award and Maxwell Award last season after throwing for the third-most yards in the country (4,468) and tying his own school-record with 38 touchdown passes.</p> </span><a class="more" href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Falk, a redshirt-senior, was also finalist for the Johnny Unitas Award and a semifinalist for the Davey O'Brien Award and Maxwell Award last season after throwing for the third-most yards in the country (4,468) and tying his own school-record with 38 touchdown passes.</p></span><a class="more" href="/story/36152696/luke-falk-named-to-manning-award-watch-list"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNBA story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NBA"><meta content="2017-08-14 23:36:23"><h4 class="wnContent headline"><a href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><span class="text">Jacob Wiley signs two-way contract with Nets</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><span class="text">Jacob Wiley signs two-way contract with Nets</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14653544_G.jpg" title="Courtesy: Brooklyn Nets" alt="Courtesy: Brooklyn Nets"></a><span class="caption left width180"><span class="text">Courtesy: Brooklyn Nets</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14653544_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Wiley (6&rsquo;8&rdquo;, 213) appeared in 34 games for Eastern Washington University last season (2016-17), recording averages of 20.4 points, 9.1 rebounds and 2.8 blocks in 34.3 minutes per contest while shooting 64.3 percent (265-of-412) from the field. He was named the Big Sky Conference Most Valuable Player and earned first team honors.</p> </span><a class="more" href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Wiley (6&rsquo;8&rdquo;, 213) appeared in 34 games for Eastern Washington University last season (2016-17), recording averages of 20.4 points, 9.1 rebounds and 2.8 blocks in 34.3 minutes per contest while shooting 64.3 percent (265-of-412) from the field. He was named the Big Sky Conference Most Valuable Player and earned first team honors.</p></span><a class="more" href="/story/36134296/jacob-wiley-signs-two-way-contract-with-nets"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-08-10 22:31:53"><h4 class="wnContent headline"><a href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><span class="text">WSU has two named to Polynesian Player of Year watch list</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><span class="text">WSU has two named to Polynesian Player of Year watch list</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14625556_G.jpg" title="Courtesy: WSU Athletics" alt="Courtesy: WSU Athletics"></a><span class="caption left width180"><span class="text">Courtesy: WSU Athletics</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14625556_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The winner of the 2017 Polynesian College Football Player of the Year Award will be announced on December 14, 2017. Five finalists will be unveiled on November 30.</p></span><a class="more" href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The winner of the 2017 Polynesian College Football Player of the Year Award will be announced on December 14, 2017. Five finalists will be unveiled on November 30.</p></span><a class="more" href="/story/36110999/wsu-has-two-named-to-polynesian-player-of-year-watch-list"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NCAA-Football"><meta content="2017-08-10 02:43:43"><h4 class="wnContent headline"><a href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><span class="text">WSU ranked No. 22 in Sports Illustrated's preseason Top 25</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><span class="text">WSU ranked No. 22 in Sports Illustrated's preseason Top 25</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14617977_G.jpg" title="WSU opens the season up with five straight home games." alt="WSU opens the season up with five straight home games."></a><span class="caption left width180"><span class="text">WSU opens the season up with five straight home games.</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14617977_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>&quot;To sniff the playoff, the Cougars will have to at least split matchups with USC (Sept. 29) at home and at Washington (Nov. 25), then win the Pac-12 title game. Before that they&rsquo;ll face trips to Oregon (Oct. 7) and Utah (Nov. 11) and host Stanford (Nov. 4).&quot;</p></span><a class="more" href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>&quot;To sniff the playoff, the Cougars will have to at least split matchups with USC (Sept. 29) at home and at Washington (Nov. 25), then win the Pac-12 title game. Before that they&rsquo;ll face trips to Oregon (Oct. 7) and Utah (Nov. 11) and host Stanford (Nov. 4).&quot;</p></span><a class="more" href="/story/36103124/wsu-ranked-no-22-in-sports-illustrateds-preseason-top-25"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNCAAFootball story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NCAA-Football"><meta content="2017-08-04 01:34:13"><h4 class="wnContent headline"><a href="/story/36059883/wsu-cracks-espns-preseason-top-25"><span class="text">WSU cracks ESPN's preseason Top 25</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36059883/wsu-cracks-espns-preseason-top-25"><span class="text">WSU cracks ESPN's preseason Top 25</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/36059883/wsu-cracks-espns-preseason-top-25"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14570462_G.jpg" title="WSU opens up their season on Sept. 2 against Montana State" alt="WSU opens up their season on Sept. 2 against Montana State"></a><span class="caption left width180"><span class="text">WSU opens up their season on Sept. 2 against Montana State</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36059883/wsu-cracks-espns-preseason-top-25"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14570462_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>&quot;The Cougars are another team to watch in the loaded Pac-12 North. Mike Leach finally has some experience, and not just with Luke Falk, who has seemingly quarterbacked on the Palouse for decades.&quot;</p> </span><a class="more" href="/story/36059883/wsu-cracks-espns-preseason-top-25"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>&quot;The Cougars are another team to watch in the loaded Pac-12 North. Mike Leach finally has some experience, and not just with Luke Falk, who has seemingly quarterbacked on the Palouse for decades.&quot;</p></span><a class="more" href="/story/36059883/wsu-cracks-espns-preseason-top-25"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://SWXRN.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText">All content &copy; Copyright  2000  - 2017 SWXRN. All Rights Reserved.<BR>For more information on this site, please read  our <A HREF='/story/18990/this-web-sites-privacy-policy'  >Privacy Policy</a>, and <A HREF='/story/18991/this-sites-terms-of-service'  >Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.</div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E")); </script> <script type="text/javascript"> try { var pageTracker = _gat._getTracker("UA-15497971-2"); pageTracker._trackPageview(); } catch(err) {}</script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>