<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized JS Includes - prehead--><script src="//worldnow-d.openx.net/w/1.0/jstag?nc=43459271-wnow"></script><script class="kxct" data-id="qv9jzm6dt" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9jzm6dt";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Seahawks sign QB Austin Davis - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</title>
<meta name="Description" content="The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team’s 90-man roster, quarterback Jake Heaps was released.  Dav..."><meta name="KEYWORDS" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="news_keywords" content="SWX,sports,Gonzaga,tv,basketball,swxrightnow.com,Bulldogs,Zags,Spokane Chiefs,swx.com,basketball,sports,hockey,high school,whitworth,Spokane Shock,Spokane Sports"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/06/05"><meta name="owner" content="SWXRN"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="Container-E.98"><meta name="wn-base" content="IIS20"><meta name="wnreadableurl" content="seahawks-sign-qb-austin-davis"><meta property="og:title" content="Seahawks sign QB Austin Davis"><meta property="og:type" content="article"><meta property="og:url" content="http://www.swxrightnow.com/story/35594060/seahawks-sign-qb-austin-davis"><meta property="og:image" content="http://SWXRN.images.worldnow.com/images/14061968_G.jpg"><meta property="og:description" content="The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team’s 90-man roster, quarterback Jake Heaps was released.  Dav..."><link rel="canonical" href="http://www.swxrightnow.com/story/35594060/seahawks-sign-qb-austin-davis"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Seahawks sign QB Austin Davis"><meta name="twitter:description" content="The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team’s 90-man roster, quarterback Jake Heaps was released.  Dav..."><meta name="twitter:image" content="http://SWXRN.images.worldnow.com/images/14061968_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:page_id" content="130847515832" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=Container-E.98_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://SWXRN.images.worldnow.com/interface/css/container-e.css?ver=2017-05-12%2015%3A15%3A54_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_Container-E.98" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=Container-E.98"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=Container-E.98"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=Container-E.98"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1641 UL
                    , #menu1641 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641 A,
                    #menu1641 LI.wnOn .wnSublevel A,
                    #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #000000; }
                #menu1641
                        .wnLevel1, #menu1641
                        .wnLevel1 LI { height: 38px; }
                            #menu1641 .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu1641 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu1641 LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1641 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1641 .wnSublevel { background-color: #d5d5d5;  }
                #menu1641 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu1641 > .wnHorizontal .wnStatic .wnMenuTypeImage .wnSublevel { width: 978px; }
                    #menu1641 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu1641 .wnLeft { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu1641 LI.wnOn .wnLeft { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1641 .wnRight { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu1641 LI.wnOn .wnRight { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1641 .wnRight .wnMiddle { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1641 LI.wnOn .wnMiddle { background-image: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu1641 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://SWXRN.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu1641 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'SWXRN',
            affiliateId : '863',
            baseUrl : 'www.swxrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '64',mdPartnerDomain : 'http://dub.swxrightnow.com'},
            registrationId : '557063',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://SWXRN.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='Container-E.98';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='SWXRN';
wng_pageInfo.ownerAffiliateId=parseInt('863',10);
wng_pageInfo.containerId=parseInt('35594060',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='Sport - NFL';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/35594060/seahawks-sign-qb-austin-davis';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Seahawks sign QB Austin Davis';
wng_pageInfo.pageTitle='Seahawks sign QB Austin Davis - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTag='SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffSWXRN';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NFL",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:468,height:60,wncc:"Sport - NFL",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NFL",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NFL",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:728,height:90,wncc:"Sport - NFL",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'SWXRN'},width:300,height:150,wncc:"Sport - NFL",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'SWXRN'},width:300,height:250,wncc:"Sport - NFL",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["63"]={id:"63",wnsz:"63",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'inline',aff:'SWXRN'},width:300,height:600,wncc:"Sport - NFL",parent:"WNAd63",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
</script>
<script type="text/javascript" src="http://SWXRN.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-05-12%2015%3A15%3A54_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/SWXRN.config.js?ver=Container-E.98_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=Container-E.98_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/swxrn/custom/swxrn_story_zoom.css" /><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel='alternate' type='application/rss+xml' title='Top Sports Headlines' href='http://www.swxrightnow.com/category/162885/publishing-category-top-stories?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='College Headlines' href='http://www.swxrightnow.com/category/162314/college?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Pro Headlines' href='http://www.swxrightnow.com/category/162313/pro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Prep Headlines' href='http://www.swxrightnow.com/category/160221/high-school-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington Sports' href='http://www.swxrightnow.com/category/50896/washington-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Idaho Sports' href='http://www.swxrightnow.com/category/50867/idaho-sports-headlines?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Washington State' href='http://www.swxrightnow.com/category/162664/washington-state?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Univ. of Idaho' href='http://www.swxrightnow.com/category/162831/idaho?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Eastern Washington' href='http://www.swxrightnow.com/category/162663/ewu-sports?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Gonzaga' href='http://www.swxrightnow.com/category/160218/gonzaga?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Central Washington' href='http://www.swxrightnow.com/category/192801/central-washington?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Whitworth' href='http://www.swxrightnow.com/category/174693/whitworth-university?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Shock' href='http://www.swxrightnow.com/category/160220/spokane-shock?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Spokane Chiefs' href='http://www.swxrightnow.com/category/162666/spokane-chiefs?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Americans' href='http://www.swxrightnow.com/category/115764/tri-city-americans?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Tri-City Dust Devils' href='http://www.swxrightnow.com/category/145287/tri-city-dust-devils?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Yakima Bears' href='http://www.swxrightnow.com/category/108040/yakima-bears?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Seattle Mariners' href='http://www.swxrightnow.com/category/162830/seattle-mariners?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='Hydro Insider' href='http://www.swxrightnow.com/category/78290/hydroinsidercom-unlimited-hydroplane-racing?clienttype=rss'><link rel='stylesheet' type='text/css' href='http://ftpcontent.worldnow.com/swxrn/custom/custom.css' /><script src="http://ftpcontent.worldnow.com/swxrn/custom/custom.js"></script><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--></head><body id="WNAffSWXRN" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-55' ,"dma":'73' ,"group":'Cowles'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Seahawks sign QB Austin Davis - SWX Right Now-Sports for Spokane, CdA, Tri-Cities, WA</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo_dark.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://SWXRN.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1641" class="wnMainMenu"><div class="wnHorizontal"><div class="wnStatic"><div class="wnMenuTypeImage"><ul class="wnLevel1" id="submenu1641"><li class="wnFirstNode" id="menu1641_1-C155145"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/"><img src="http://SWXRN.images.worldnow.com/images/499120_G.gif" width="49" height="38" border="0" alt="SWX Right Now.com" title="SWX Right Now.com" onsrc="http://SWXRN.images.worldnow.com/images/499121_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_1-C155145"><li class="wnFirstNode" id="menu1641_1_1-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_1_7-C163470"><span><a href="/category/163470/games-contests">Games &amp; Contests</a></span></li><li class="" id="menu1641_1_6-C208947"><span><a href="/category/208947/extra-points">Extra Points</a></span></li><li class="" id="menu1641_1_3-C284880"><span><a href="/category/284880/swx-podcasts">SWX Podcast</a></span></li><li class="" id="menu1641_1_2-C161642"><span><a href="/category/161642/interactive-radar">HD Doppler 6i</a></span></li><li class="" id="menu1641_1_5-C220728"><span><a href="/category/220728/featured-slideshows">Featured Slideshows</a></span></li><li class="" id="menu1641_1_4-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_2-C160216"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160216/scores"><img src="http://SWXRN.images.worldnow.com/images/499122_G.gif" width="97" height="38" border="0" alt="Scores" title="Scores" onsrc="http://SWXRN.images.worldnow.com/images/499123_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_2-C160216"><li class="wnFirstNode" id="menu1641_2_1-C161806"><span><a href="/category/161806/national-scores">National Scores</a></span></li><li class="" id="menu1641_2_2-C161807"><span><a href="/category/161807/college-scores">College Scores</a></span></li><li class="" id="menu1641_2_3-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_2_4-S9920984"><span><a href="/story/9920984/report-a-score">Report a Score</a></span></li></ul></li><li class="" id="menu1641_3-C162314"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162314/college"><img src="http://SWXRN.images.worldnow.com/images/499124_G.gif" width="65" height="38" border="0" alt="College" title="College" onsrc="http://SWXRN.images.worldnow.com/images/499125_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_3-C162314"><li class="wnFirstNode" id="menu1641_3_1-C162664"><span><a href="/category/162664/washington-state">WSU</a></span></li><li class="" id="menu1641_3_2-C160218"><span><a href="/category/160218/gonzaga">Gonzaga</a></span></li><li class="" id="menu1641_3_3-C162663"><span><a href="/category/162663/ewu-sports">EWU</a></span></li><li class="" id="menu1641_3_4-C174693"><span><a href="/category/174693/whitworth-university">Whitworth</a></span></li><li class="" id="menu1641_3_5-C162831"><span><a href="/category/162831/idaho">Idaho</a></span></li><li class="" id="menu1641_3_6-C267736"><span><a href="/category/267736/university-of-washington">Washington</a></span></li><li class="" id="menu1641_3_7-C192801"><span><a href="/category/192801/central-washington">CWU</a></span></li><li class="" id="menu1641_3_8-C262164"><span><a href="/category/262164/bobcats">Bobcats</a></span></li><li class="" id="menu1641_3_9-C262165"><span><a href="/category/262165/grizzlies">Grizzlies</a></span></li></ul></li><li class="" id="menu1641_4-C162313"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/162313/pro"><img src="http://SWXRN.images.worldnow.com/images/499126_G.gif" width="36" height="38" border="0" alt="Pro" title="Pro" onsrc="http://SWXRN.images.worldnow.com/images/499127_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_4-C162313"><li class="wnFirstNode" id="menu1641_4_4-C272346"><span><a href="/category/272346/seattle-seahawks">Seattle Seahawks</a></span></li><li class="" id="menu1641_4_5-C162666"><span><a href="/category/162666/spokane-chiefs">Spokane Chiefs</a></span></li><li class="" id="menu1641_4_6-C160220"><span><a href="/category/160220/spokane-empire">Spokane Empire</a></span></li><li class="" id="menu1641_4_1-C78290"><span><a href="/category/78290/hydroinsidercom-unlimited-hydroplane-racing">HydroInsider.com</a></span></li><li class="" id="menu1641_4_7-C284681"><span><a href="/category/284681/montana-pro-sports">Pro Sports</a></span></li><li class="" id="menu1641_4_3-C193768"><span><a href="/category/193768/the-offseason">The Offseason</a></span></li><li class="" id="menu1641_4_2-C221261"><span><a href="/category/221261/tri-cities-americans">Tri-City Americans</a></span></li></ul></li><li class="" id="menu1641_5-C160221"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160221/high-school-sports"><img src="http://SWXRN.images.worldnow.com/images/499128_G.gif" width="96" height="38" border="0" alt="High School" title="High School" onsrc="http://SWXRN.images.worldnow.com/images/499129_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_5-C160221"><li class="wnFirstNode" id="menu1641_5_1-C161805"><span><a href="/category/161805/high-school-scores">High School Scores</a></span></li><li class="" id="menu1641_5_2-C318106"><span><a href="/category/318106/student-athlete">Student Athlete </a></span></li><li class="" id="menu1641_5_4-C162688"><span><a href="/category/162688/greater-spokane-league">Greater Spokane League</a></span></li><li class="" id="menu1641_5_5-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_5_6-C284683"><span><a href="/category/284683/montana-high-school-sports">High School Sports</a></span></li><li class="" id="menu1641_5_3-C286972"><span><a href="/category/286972/prep-countdown">Prep Countdown</a></span></li></ul></li><li class="" id="menu1641_6-L654994"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://www.nwprepsnow.com"><img src="http://SWXRN.images.worldnow.com/images/4054557_G.png" width="140" height="38" border="0" alt="High School to NWPrepsNow.com" title="High School to NWPrepsNow.com" onsrc="http://SWXRN.images.worldnow.com/images/4054564_G.png"></a></span></span></span></span></li><li class="" id="menu1641_7-C160222"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160222/video-center"><img src="http://SWXRN.images.worldnow.com/images/499132_G.gif" width="102" height="38" border="0" alt="Video Center" title="Video Center" onsrc="http://SWXRN.images.worldnow.com/images/499133_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_7-C160222"><li class="wnFirstNode" id="menu1641_7_1-L375234"><span><a href="http://www.swxrightnow.com/global/category.asp?c=">All Video</a></span></li><li class="" id="menu1641_7_2-C162982"><span><a href="/category/162982/vc-college">College </a></span></li><li class="" id="menu1641_7_3-C162981"><span><a href="/category/162981/vc-pro">Pro </a></span></li><li class="" id="menu1641_7_4-C162980"><span><a href="/category/162980/vc-high-school">High School </a></span></li><li class="" id="menu1641_7_5-C162983"><span><a href="/category/162983/vc-gonzaga">Gonzaga </a></span></li><li class="" id="menu1641_7_6-C196287"><span><a href="/category/196287/highschool-yakima-tricities">Yakima &amp; Tri-Cities HS Sports</a></span></li><li class="" id="menu1641_7_7-C162984"><span><a href="/category/162984/vc-wsu">WSU</a></span></li><li class="" id="menu1641_7_8-C162986"><span><a href="/category/162986/vc-ewu">EWU</a></span></li><li class="" id="menu1641_7_9-C162987"><span><a href="/category/162987/vc-spokane-empire">VC - Spokane Empire</a></span></li></ul></li><li class="" id="menu1641_8-C155146"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather"><img src="http://SWXRN.images.worldnow.com/images/499134_G.gif" width="73" height="38" border="0" alt="Weather" title="Weather" onsrc="http://SWXRN.images.worldnow.com/images/499135_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_8-C155146"><li class="wnFirstNode" id="menu1641_8_1-C120835"><span><a href="/category/120835/road-pass-conditions">Road &amp; Pass Conditions</a></span></li><li class="" id="menu1641_8_2-S9962976"><span><a href="/story/9962976/radar-maps">Radar</a></span></li><li class="" id="menu1641_8_3-S9963255"><span><a href="/story/9963255/satellite-maps">Satellite</a></span></li><li class="" id="menu1641_8_4-S9974691"><span><a href="/story/9974691/school-closures-delays">School Closures &amp; Delays</a></span></li><li class="" id="menu1641_8_5-L524823"><span><a href="/link/524823/inland-northwest-ski-conditions">Ski Conditions</a></span></li></ul></li><li class="" id="menu1641_9-C160225"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/160225/about-us"><img src="http://SWXRN.images.worldnow.com/images/499136_G.gif" width="76" height="38" border="0" alt="About Us" title="About Us" onsrc="http://SWXRN.images.worldnow.com/images/499137_G.gif"></a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1641_9-C160225"><li class="wnFirstNode" id="menu1641_9_1-S9913533"><span><a href="/story/9913533/swx-contact-information">SWX Contact Information</a></span></li><li class="" id="menu1641_9_2-S9914380"><span><a href="/story/9914380/swx-on-tv">SWX on TV</a></span></li><li class="" id="menu1641_9_4-C186452"><span><a href="/category/186452/swx-program-guide">SWX Program Guide</a></span></li><li class="" id="menu1641_9_5-S9914228"><span><a href="/story/9914228/advertise-with-swx">Advertise with SWX</a></span></li><li class="" id="menu1641_9_3-S12164224"><span><a href="/story/12164224/closed-captioning-inquiries">Closed Captioning Inquiries</a></span></li><li class="" id="menu1641_9_6-S9914091"><span><a href="/story/9914091/jobs-at-swx">Jobs at SWX</a></span></li><li class="" id="menu1641_9_7-L376213"><span><a href="http://www.khq.com/">KHQ Right Now</a></span></li><li class="" id="menu1641_9_8-L376216"><span><a href="http://www.nbcrightnow.com/">NBC Right Now</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1641"></div></div></div></div><div id="spacermenu1641" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1641', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : true, level1Height : '38', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://SWXRN.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Seahawks sign QB Austin Davis</h3>
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnLeft" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://SWXRN.images.worldnow.com/images/14061968_G.jpg" alt="Courtesy: Seattle Seahawks" title="Courtesy: Seattle Seahawks" border="0" width="180">
<span>Courtesy: Seattle Seahawks</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated left"><p><em>By Seattle Seahawks </em></p><p>The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team&rsquo;s 90-man roster, quarterback <strong><a class="player" href="http://www.seahawks.com/team/players/roster/jake-heaps">Jake Heaps</a></strong> was released.&nbsp;</p><p>Davis will be added to the backup quarterback competition that currently includes <strong><a class="player" href="http://www.seahawks.com/team/players/roster/trevone-boykin">Trevone Boykin</a></strong>, last year&rsquo;s No. 2 QB.</p><p>Davis, 28, is in his sixth season, having entered the league as an undrafted free agent out of Southern Mississippi. After signing with the Rams in 2012, Davis made his regular season debut in 2014 when he appeared in 10 games, starting eight, including a Week 7 victory over Seattle that was statistically the best game of his career.</p><p>Davis signed with Cleveland in 2015, appearing in three games and starting two, then spent part of last season with the Denver Broncos.</p><p>In 13 career games, 10 of them starts, Davis has completed 62.4 percent of his passes (236 for 378) for 2,548 yards, 13 touchdowns and 12 interceptions, giving him an 80.4 career passer rating.</p><p><img alt="" src="data:image/jpeg;base64,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" /></p><p>Heaps, a Sammamish, Washington native and former Skyline High School standout, signed with Seattle in early May. He spent training camp and the preseason with the Seahawks in 2016, originally joining the club following last year's draft.</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd63" class="wnad wnad63">
<script>wnad_63.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Seattle Seahawks</span><a class="wnContent more enabled" href="/category/272346/seattle-seahawks"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature SportNFL story priority-1 odd displaySizeId-20 odd-20"><meta content="Sport - NFL"><meta content="2017-06-06 03:21:47"><h4 class="wnContent headline"><a href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><span class="text">Seahawks' Wagner and Chancellor added to NFL Network's Top 100</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><span class="text">Seahawks' Wagner and Chancellor added to NFL Network's Top 100</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14064582_G.jpg" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14064582_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Two more Seahawks, linebacker Bobby Wagner and safety Kam Chancellor, were unveiled on the NFL Network&rsquo;s Top 100 Players of 2017 list Monday, with Chancellor checking in at No. 34 on the list and Wagner at No. 39.</p> </span><a class="more" href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Two more Seahawks, linebacker Bobby Wagner and safety Kam Chancellor, were unveiled on the NFL Network&rsquo;s Top 100 Players of 2017 list Monday, with Chancellor checking in at No. 34 on the list and Wagner at No. 39.</p></span><a class="more" href="/story/35595723/seahawks-wagner-and-chancellor-added-to-nfl-networks-top-100"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-2 even displaySizeId-20 even-20"><meta content="Sport - NFL"><meta content="2017-06-05 22:08:24"><h4 class="wnContent headline"><a href="/story/35594060/seahawks-sign-qb-austin-davis"><span class="text">Seahawks sign QB Austin Davis</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35594060/seahawks-sign-qb-austin-davis"><span class="text">Seahawks sign QB Austin Davis</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35594060/seahawks-sign-qb-austin-davis"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14061968_G.jpg" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35594060/seahawks-sign-qb-austin-davis"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14061968_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team&rsquo;s 90-man roster, quarterback Jake Heaps was released.&nbsp; Davis will be added to the backup quarterback competition that currently includes Trevone Boykin, last year&rsquo;s No. 2 QB.</p></span><a class="more" href="/story/35594060/seahawks-sign-qb-austin-davis"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seahawks added depth at quarterback Monday, signing former Rams, Browns and Broncos quarterback Austin Davis. To make room on the team&rsquo;s 90-man roster, quarterback Jake Heaps was released.&nbsp; Davis will be added to the backup quarterback competition that currently includes Trevone Boykin, last year&rsquo;s No. 2 QB.</p></span><a class="more" href="/story/35594060/seahawks-sign-qb-austin-davis"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-3 odd displaySizeId-20 odd-20"><meta content="Sport - NFL"><meta content="2017-06-03 01:23:52"><h4 class="wnContent headline"><a href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><span class="text">Pete Carroll discusses injury updates on Earl Thomas, Tyler Lockett and more</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><span class="text">Pete Carroll discusses injury updates on Earl Thomas, Tyler Lockett and more</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14047153_G.png" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14047153_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seahawks&rsquo; third of seven Organized Team Activities (OTAs) wrapped up on Friday at Renton&rsquo;s Virginia Mason Athletic Center, and when Seattle head coach Pete Carroll met with the media after his team&rsquo;s voluntary offseason workout, he shared encouraging news on the injury front.</p> </span><a class="more" href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seahawks&rsquo; third of seven Organized Team Activities (OTAs) wrapped up on Friday at Renton&rsquo;s Virginia Mason Athletic Center, and when Seattle head coach Pete Carroll met with the media after his team&rsquo;s voluntary offseason workout, he shared encouraging news on the injury front.</p></span><a class="more" href="/story/35579617/pete-carroll-discusses-injury-updates-on-earl-thomas-tyler-lockett-and-more"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-4 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NFL"><meta content="2017-06-02 21:40:17"><h4 class="wnContent headline"><a href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><span class="text">Seahawks honor Cortez Kennedy with '96' helmet decal</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><span class="text">Seahawks honor Cortez Kennedy with '96' helmet decal</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14045212_G.jpg" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14045212_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A week after the death of Seahawks legend Cortez Kennedy, the Seahawks took the field for organized team activities with No. 96 decals on the backs of their helmets to honor Kennedy, a member of the Pro Football Hall of Fame and Seahawks Ring of Honor. The Seahawks will wear the decal throughout the 2017 season.</p> </span><a class="more" href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A week after the death of Seahawks legend Cortez Kennedy, the Seahawks took the field for organized team activities with No. 96 decals on the backs of their helmets to honor Kennedy, a member of the Pro Football Hall of Fame and Seahawks Ring of Honor. The Seahawks will wear the decal throughout the 2017 season.</p></span><a class="more" href="/story/35578407/seahawks-honor-cortez-kennedy-with-96-helmet-decal"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-5 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NFL"><meta content="2017-05-31 21:49:02"><h4 class="wnContent headline"><a href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><span class="text">Seahawks sign defensive backs Jordan Simone and Marcus Cromartie</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><span class="text">Seahawks sign defensive backs Jordan Simone and Marcus Cromartie</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14025281_G.jpg" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14025281_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seahawks added a pair of defensive backs to their roster Wednesday, signing safeties Jordan Simone and Marcus Cromartie. Running back Troymaine Pope and receiver Speedy Noil were waived to make room on the 90-man roster. Cromartie, who went undrafted out of Wisconsin in 2013.</p> </span><a class="more" href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seahawks added a pair of defensive backs to their roster Wednesday, signing safeties Jordan Simone and Marcus Cromartie. Running back Troymaine Pope and receiver Speedy Noil were waived to make room on the 90-man roster. Cromartie, who went undrafted out of Wisconsin in 2013.</p></span><a class="more" href="/story/35559793/seahawks-sign-defensive-backs-jordan-simone-and-marcus-cromartie"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-6 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NFL"><meta content="2017-05-30 22:16:36"><h4 class="wnContent headline"><a href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><span class="text">Seahawks' Michael Bennett ranked 46th by NFL Network's Top 100</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><span class="text">Seahawks' Michael Bennett ranked 46th by NFL Network's Top 100</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/14017007_G.jpg" title="Courtesy: NFL Network" alt="Courtesy: NFL Network"></a><span class="caption left width180"><span class="text">Courtesy: NFL Network</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/14017007_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Defensive lineman Michael Bennett became the third Seattle Seahawks player named to NFL Network's Top 100. Bennett was ranked as the 46th best player in the NFL, which is up from his 2016 ranking of 59th. Bennett joins fellow defensive teammate Cliff Avril, who was ranked 56th, and receiver Doug Baldwin, who was ranked 88th.</p></span><a class="more" href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Defensive lineman Michael Bennett became the third Seattle Seahawks player named to NFL Network's Top 100. Bennett was ranked as the 46th best player in the NFL, which is up from his 2016 ranking of 59th. Bennett joins fellow defensive teammate Cliff Avril, who was ranked 56th, and receiver Doug Baldwin, who was ranked 88th.</p></span><a class="more" href="/story/35550223/seahawks-michael-bennett-ranked-46th-by-nfl-networks-top-100"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-7 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NFL"><meta content="2017-05-25 21:13:34"><h4 class="wnContent headline"><a href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><span class="text">New Orleans Saints Honor former Seahawks great Cortez Kennedy</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><span class="text">New Orleans Saints Honor former Seahawks great Cortez Kennedy</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/13981633_G.jpg" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/13981633_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The New Orleans Saints opened Organized Team Activities this week, and early Thursday &mdash; two days after the passing of Seahawks Legend Cortez Kennedy &mdash; the team unveiled a decal on their gold helmets to honor the Pro Football Hall of Fame defensive tackle. On Twitter, the Saints announced they will sport a large No. 96 &mdash; Kennedy&rsquo;s jersey number</p> </span><a class="more" href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The New Orleans Saints opened Organized Team Activities this week, and early Thursday &mdash; two days after the passing of Seahawks Legend Cortez Kennedy &mdash; the team unveiled a decal on their gold helmets to honor the Pro Football Hall of Fame defensive tackle. On Twitter, the Saints announced they will sport a large No. 96 &mdash; Kennedy&rsquo;s jersey number</p></span><a class="more" href="/story/35520151/new-orleans-saints-honor-former-seahawks-great-cortez-kennedy"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-8 even displaySizeId-20 even-20 collapsed"><meta content="Sport - NFL"><meta content="2017-05-24 23:04:47"><h4 class="wnContent headline"><a href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><span class="text">Report: Seattle Seahawks to meet with quarterback Colin Kaepernick</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><span class="text">Report: Seattle Seahawks to meet with quarterback Colin Kaepernick</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/13972045_G.png" title="Courtesy: San Francisco 49ers" alt="Courtesy: San Francisco 49ers"></a><span class="caption left width180"><span class="text">Courtesy: San Francisco 49ers</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/13972045_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seattle Seahawks are expected to meet with Colin Kaepernick on Wenesday as a possible backup to quarterback Russell Wilson, according to a report from NFL.com's Ian Rapoport.&nbsp;</p> </span><a class="more" href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seattle Seahawks are expected to meet with Colin Kaepernick on Wenesday as a possible backup to quarterback Russell Wilson, according to a report from NFL.com's Ian Rapoport.&nbsp;</p></span><a class="more" href="/story/35511302/report-seattle-seahawks-to-meet-with-quarterback-colin-kaepernick"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-9 odd displaySizeId-20 odd-20 collapsed"><meta content="Sport - NFL"><meta content="2017-05-23 21:53:28"><h4 class="wnContent headline"><a href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><span class="text">Seahawks remember hall of fame defensive tackle Cortez Kennedy</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><span class="text">Seahawks remember hall of fame defensive tackle Cortez Kennedy</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/13960118_G.png" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/13960118_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seattle Seahawks family has lost one of its most beloved individuals and proudest icons.&nbsp;Cortez Kennedy, the Pro Football Hall of Fame defensive tackle who spent all 11 of his NFL seasons in Seattle, died Tuesday. He was 48. &quot;Cortez Kennedy has been a pillar of the Seahawks franchise since joining the team as a rookie in 1990...</p></span><a class="more" href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seattle Seahawks family has lost one of its most beloved individuals and proudest icons.&nbsp;Cortez Kennedy, the Pro Football Hall of Fame defensive tackle who spent all 11 of his NFL seasons in Seattle, died Tuesday. He was 48. &quot;Cortez Kennedy has been a pillar of the Seahawks franchise since joining the team as a rookie in 1990...</p></span><a class="more" href="/story/35500463/seahawks-remember-hall-of-fame-defensive-tackle-cortez-kennedy"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature SportNFL story priority-10 even displaySizeId-20 even-20 collapsed last"><meta content="Sport - NFL"><meta content="2017-05-22 23:56:39"><h4 class="wnContent headline"><a href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><span class="text">Seahawks' roster status after rookie minicamp</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><span class="text">Seahawks' roster status after rookie minicamp</span></a></h4><div class="wnContent summaryImage left width180"><a href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><img border="0" width="180" data-path="http://SWXRN.images.worldnow.com/images/13951022_G.png" title="Courtesy: Seattle Seahawks" alt="Courtesy: Seattle Seahawks"></a><span class="caption left width180"><span class="text">Courtesy: Seattle Seahawks</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><img border="0" width="115" data-path="http://SWXRN.images.worldnow.com/images/13951022_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Seahawks welcomed to Seattle last week a rookie class that included 11 draft picks and eight undrafted free agents, a group that took part in a rookie minicamp last weekend. Now that rookies have joined the team and free agency has for the most part wound down...</p> </span><a class="more" href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Seahawks welcomed to Seattle last week a rookie class that included 11 draft picks and eight undrafted free agents, a group that took part in a rookie minicamp last weekend. Now that rookies have joined the team and free agency has for the most part wound down...</p></span><a class="more" href="/story/35491006/seahawks-roster-status-after-rookie-minicamp"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://SWXRN.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText">All content &copy; Copyright  2000  - 2017 SWXRN. All Rights Reserved.<BR>For more information on this site, please read  our <A HREF='/story/18990/this-web-sites-privacy-policy'  >Privacy Policy</a>, and <A HREF='/story/18991/this-sites-terms-of-service'  >Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.</div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E")); </script> <script type="text/javascript"> try { var pageTracker = _gat._getTracker("UA-15497971-2"); pageTracker._trackPageview(); } catch(err) {}</script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>